Other Squeeky Dashboard...AAHHHH - Civinfo
 
LinkBack Thread Tools
post #1 of 13 (permalink) Old 11th May 2010, 07:05 Thread Starter
 
ian 182's Avatar
 
Join Date: 3rd February 2010
Location: telford,shropshire SCOTLAND
Posts: 308
Thanks: 2
Thanked 8 Times in 8 Posts
iTrader: (0)
Squeeky Dashboard...AAHHHH

I have an annoying squeek coming from my dash,its in the speedo pod.The black piece of plastic on top squeeks now and again when iam on a rough road.Once i give it a push and a shove its fine,but some days it really pee's me off.

Any ideas???
ian 182 is offline  
Sponsored Links
Advertisement
 
post #2 of 13 (permalink) Old 11th May 2010, 07:11
Supporter
 
Car: Mazda MX-5 (lightly modded)
Join Date: 1st July 2007
Location: GB GB
Posts: 15,644
Thanks: 1,166
Thanked 1,546 Times in 1,415 Posts
iTrader: (8)
Take it to the dealer and tell them you are fed up of the dash squeeking.
They will have fixed many!!
Your warranty covers it
robbo51 is offline  
post #3 of 13 (permalink) Old 11th May 2010, 07:59
Sold a kidney last week!
 
TypeRiter's Avatar
 
Car: '59 Alabaster Silver FN2
Join Date: 27th May 2009
Location: Heathrow, London ENGLAND
Posts: 3,962
Thanks: 319
Thanked 224 Times in 217 Posts
iTrader: (8)
Quote:
Originally Posted by robbo51 View Post
Take it to the dealer and tell them you are fed up of the dash squeeking.
They will have fixed many!!
Your warranty covers it
Will have seen many, moot whether they've fixed many though
Willing to accept that people might have had success, but they're certain to be in the minority.

I suffered with this particular squeak - it is very annoying, very, very annoying in fact. What a poorly built car. shame really.
TypeRiter is offline  
 
post #4 of 13 (permalink) Old 11th May 2010, 09:30
The quest for perfection!
 
0507448n's Avatar
 
Join Date: 24th September 2008
Location: Ayrshire SCOTLAND
Posts: 666
Thanks: 11
Thanked 27 Times in 27 Posts
iTrader: (4)
turn up the volumn
0507448n is offline  
post #5 of 13 (permalink) Old 11th May 2010, 09:35
Supporter
 
budd3n's Avatar
 
Car: 2009 Type S 1.8 VTEC
Join Date: 15th February 2010
Location: Newcastle ENGLAND
Posts: 542
Thanks: 39
Thanked 13 Times in 13 Posts
iTrader: (0)
Quote:
Originally Posted by ian 182 View Post
I have an annoying squeek coming from my dash,its in the speedo pod.The black piece of plastic on top squeeks now and again when iam on a rough road.Once i give it a push and a shove its fine,but some days it really pee's me off.

Any ideas???
i'm suffering same problem, if i push the trim around the speedo it stops for a while!? let me know how you get on.

I'm trying to motivate myself to book it in knowing the fact i'll have a Jazz for a day...
budd3n is offline  
post #6 of 13 (permalink) Old 11th May 2010, 18:31
J_H
i-VTEC - DO YOU?
 
J_H's Avatar
 
Car: 2009 CTR, Black
Join Date: 11th December 2008
Location: Woking, UK ENGLAND
Posts: 3,111
Thanks: 26
Thanked 217 Times in 202 Posts
iTrader: (5)
I had a similar problem in the past and on the whole it was dealt with by the dealer. It has come back a little bit every now and again but I can't be bothered to send it in again, have bought some silicon spray to treat it instead.
J_H is offline  
post #7 of 13 (permalink) Old 11th May 2010, 21:27
I'LL NEVER WALK ALONE
 
The Vision's Avatar
 
Car: 56 plate 1.8 ES cosmic grey
Join Date: 24th November 2009
Location: liverpool ENGLAND
Posts: 3,095
Thanks: 231
Thanked 561 Times in 490 Posts
iTrader: (3)
Dealer fixed mine under warranty, that's one thing they got right !!
The Vision is offline  
post #8 of 13 (permalink) Old 12th May 2010, 12:32
Supporter
 
R555's Avatar
 
Car: 2007 CTR, Milano Red
Join Date: 17th November 2009
Location: North Yorks ENGLAND
Posts: 5,241
Thanks: 837
Thanked 410 Times in 381 Posts
iTrader: (6)
I've had mine fixed under warrenty, but its back now, its actually worse with the heaters on. If I put my AC on and set the temperture as low as possible the squeek isnt as bad..... I'm going to try some WD40 between the glass and the plastic to see if that fixes it.
R555 is offline  
post #9 of 13 (permalink) Old 12th May 2010, 13:08
Supporter
 
Car: Mazda MX-5 (lightly modded)
Join Date: 1st July 2007
Location: GB GB
Posts: 15,644
Thanks: 1,166
Thanked 1,546 Times in 1,415 Posts
iTrader: (8)
Use silicone spray instead..Better still the 'cowl fix' by removing it and remounting it on small thin rubber pads...My dealer did it for me
robbo51 is offline  
post #10 of 13 (permalink) Old 1st December 2010, 13:05
 
Join Date: 30th October 2008
Location: Glastonbury GB
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader: (0)
I had the same problem and went back to Honda which was a waste of time. I eventually fixed it myself....

Its the plastic lid above the speedo, remove it, spray it with WD40 and hey presto squeak is gone.
popey123 is offline  
post #11 of 13 (permalink) Old 1st December 2010, 13:39
Supporter
 
Trim89's Avatar
 
Car: 59 Milano R
Join Date: 4th August 2009
Location: Nottingham ENGLAND
Posts: 422
Thanks: 16
Thanked 34 Times in 34 Posts
iTrader: (3)
When i phoned to dealer to get mine in under warranty they said "is it more frequent when its cold" which is something i never noticed but there doesn't seem to be any correlation, its more so over bumps but does seem to be gettin worse this time of year, i think another trip to the dealers is in order but if they couldn't fix it the first im startin to lose hope
Trim89 is offline  
post #12 of 13 (permalink) Old 1st December 2010, 17:25
Move over..comming thru!!
 
Huge's Avatar
 
Car: 59 CTR GT + Nav
Join Date: 15th March 2009
Location: Bristol UK GB
Posts: 533
Thanks: 40
Thanked 27 Times in 26 Posts
iTrader: (7)
I had that problem for the first 2 weeks I had the car.... a trip to the dealers sorted it out. Not sure how they did it as I don't want to take the cowl off in case the squeak comes back!!
Huge is offline  
post #13 of 13 (permalink) Old 1st December 2010, 17:55
 
Join Date: 30th October 2008
Location: Glastonbury GB
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader: (0)
Quote:
Originally Posted by Trim89 View Post
When i phoned to dealer to get mine in under warranty they said "is it more frequent when its cold" which is something i never noticed but there doesn't seem to be any correlation, its more so over bumps but does seem to be gettin worse this time of year, i think another trip to the dealers is in order but if they couldn't fix it the first im startin to lose hope
Seriously dont bother, just lieft the lid above the speedo and gently spray wd.

Never had a noise since.
popey123 is offline  
Reply

  Civinfo > 8th Generation Euro Honda Civic (2006 - 2011) > Bugs, faults and irritations (8G)

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Civinfo forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
Your User Name is the name that appears by all your posts on the forum, and so should not be your email address.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
Transmission squeeky clutch?? Andrea Bugs, faults and irritations (8G) 196 20th November 2014 18:04
Suspension Squeeky sound jasem Wheels, Tyres, Suspension and Brakes (8G) 4 17th November 2011 19:26
Squeaks Squeeky noise from rear!any ideas anyone? kryptonion Bugs, faults and irritations (8G) 9 19th June 2010 00:08
Squeeky seat rossk1009 Type-R 4 31st January 2010 19:19
Suspension Squeeky Shockers scol78 Bugs, faults and irritations (8G) 11 12th October 2006 08:17

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome