Engine Check engine light after battery died - Civinfo
 7Likes
  • 1 Post By nturnb
  • 2 Post By M8TJT
  • 1 Post By Kremmen
  • 2 Post By M8TJT
  • 1 Post By Dmi3
 
LinkBack Thread Tools
post #1 of 15 (permalink) Old 5th August 2018, 22:50 Thread Starter
Supporter
 
Car: Deep Bronze, Type S 2.2
Join Date: 22nd July 2018
Location: Warwick
Posts: 13
Thanks: 4
Thanked 0 Times in 0 Posts
iTrader: (0)
Check engine light after battery died

Hi, so I bought this Type S 2009 2.2 diesel a little over a week ago.

The car was probably at the dealership for a while and they couldn't sell it, I think it could easily have stayed there for 2-3 months with no movement.
I drove the car on the same day to home for about 40 minutes and it all was fine.

Next day I found out that the battery died for some reason, although I am sure I didn't leave any lights on (they were set to auto). Anyway, I got helped with push start and immediately got the check engine error. It was Friday and I was supposed to travel 130 miles up North so I spent the next 3 hours driving which supposedly charged the battery, but the check engine light remained. I had no time to service it over that weekend, but on my way back two days later the light suddenly stopped showing and it was absolutely fine for the next 5 days or so.

Then last Saturday I was about to have another long commute and the error showed again. I traveled around 300 miles in one day and the light stayed on, although there were no problems with the car, but then it disappeared. Just today, shortly after starting the car, the light came up again... I drove the car a bit more and there are no issues with the car itself besides the check engine lights. It doesn't pop up immediately, though, but after about 5 seconds or so, and every first time that it happened, it didn't appear until at least 3 minutes into driving.

Could it be an issue with the battery or anything else? Thanks.
Dmi3 is offline  
Sponsored Links
Advertisement
 
post #2 of 15 (permalink) Old 6th August 2018, 06:05
Administrator
 
Kremmen's Avatar
 
Car: MY13 1.8 EX Auto
Join Date: 7th January 2007
Location: West London ENGLAND
Posts: 20,944
Thanks: 857
Thanked 1,708 Times in 1,431 Posts
iTrader: (0)
Eco display Eco display
Garage
If the battery has been allowed to go completely flat then that would be my guess that it's battery related.

I'd be checking how fast the voltage is dropping after an overnight stand. Voltages drop considerably faster in a battery that has lost both stages of charge.

Quote:
Bear in mind that even if you manage to recharge or jump start your battery, its life may have been significantly shortened after a discharge - you may want to replace it at some point for a new one
Kremmen is offline  
Thanks to Kremmen from:
post #3 of 15 (permalink) Old 6th August 2018, 11:44
Supporter
 
Bones126's Avatar
 
Join Date: 25th October 2017
Location: Birmingham
Posts: 1,170
Thanks: 85
Thanked 96 Times in 96 Posts
iTrader: (0)
Garage
Do you have an odb reader to see what error code it is showing?
Bones126 is offline  
 
post #4 of 15 (permalink) Old 6th August 2018, 11:49
Ex-Pat Geordie!
 
nturnb's Avatar
 
Car: 2015 Civic S Navi I-dtec
Join Date: 17th November 2013
Location: Irvine, Ayrshire GB
Posts: 2,185
Thanks: 119
Thanked 223 Times in 204 Posts
iTrader: (0)
Eco display
Quote:
Originally Posted by Bones126 View Post
Do you have an odb reader to see what error code it is showing?
If you don't have one it's a good investment. Be wary though, don't just buy any as it will not work on the 2.2. Make sure from the seller that it will work with your car.
Bones126 likes this.
nturnb is offline  
post #5 of 15 (permalink) Old 6th August 2018, 13:48 Thread Starter
Supporter
** Thread starter **
 
Car: Deep Bronze, Type S 2.2
Join Date: 22nd July 2018
Location: Warwick
Posts: 13
Thanks: 4
Thanked 0 Times in 0 Posts
iTrader: (0)
Quote:
Originally Posted by Kremmen View Post
If the battery has been allowed to go completely flat then that would be my guess that it's battery related.

I'd be checking how fast the voltage is dropping after an overnight stand. Voltages drop considerably faster in a battery that has lost both stages of charge.
Ok, thank you. I will probably try and get the battery replaced asap.
Dmi3 is offline  
post #6 of 15 (permalink) Old 6th August 2018, 14:05
Super Moderator
 
M8TJT's Avatar
 
Car: 10G 1.5 Civic Prestige
Join Date: 10th October 2015
Location: Bexhill, Sussex GB
Posts: 2,889
Thanks: 86
Thanked 215 Times in 207 Posts
iTrader: (1)
It might be worthwhile checking that the battery is actually duff and not 'something else'.
Kremmen and Bones126 like this.
M8TJT is offline  
post #7 of 15 (permalink) Old 6th August 2018, 14:27
Supporter
 
Trev27's Avatar
 
Car: 2010 Civic Si 2.2
Join Date: 5th January 2018
Location: Stockton on Tees GD
Posts: 326
Thanks: 0
Thanked 30 Times in 28 Posts
iTrader: (0)
Garage
Had this on mine when the battery went flat disappeared when charged, never appeared again though
Trev27 is offline  
post #8 of 15 (permalink) Old 6th August 2018, 17:18
Administrator
 
Kremmen's Avatar
 
Car: MY13 1.8 EX Auto
Join Date: 7th January 2007
Location: West London ENGLAND
Posts: 20,944
Thanks: 857
Thanked 1,708 Times in 1,431 Posts
iTrader: (0)
Eco display Eco display
Garage
I agree, got to try a long trickle charge first, preferably with something like a CTEK that does a full recondition.
Kremmen is offline  
Thanks to Kremmen from:
post #9 of 15 (permalink) Old 6th August 2018, 22:53 Thread Starter
Supporter
** Thread starter **
 
Car: Deep Bronze, Type S 2.2
Join Date: 22nd July 2018
Location: Warwick
Posts: 13
Thanks: 4
Thanked 0 Times in 0 Posts
iTrader: (0)
Quote:
Originally Posted by Kremmen View Post
I agree, got to try a long trickle charge first, preferably with something like a CTEK that does a full recondition.
Thanks, I will probably take it to a garage since I don't have any tools really. It drives fine but the message is really annoying.
Dmi3 is offline  
post #10 of 15 (permalink) Old 7th August 2018, 05:37
Administrator
 
Kremmen's Avatar
 
Car: MY13 1.8 EX Auto
Join Date: 7th January 2007
Location: West London ENGLAND
Posts: 20,944
Thanks: 857
Thanked 1,708 Times in 1,431 Posts
iTrader: (0)
Eco display Eco display
Garage
You just need something to check the overnight voltage drop.

After I CTEK mine, because it sits in the garage most weeks, it takes about a week to drop below 12v, when I CTEK it again.

I charged mine exactly a week ago, last Tuesday and it's still got 12v even though it hasn't moved:

Screenshot_20180807-053526_My Honda.jpg
Bones126 likes this.
Kremmen is offline  
post #11 of 15 (permalink) Old 7th August 2018, 08:30 Thread Starter
Supporter
** Thread starter **
 
Car: Deep Bronze, Type S 2.2
Join Date: 22nd July 2018
Location: Warwick
Posts: 13
Thanks: 4
Thanked 0 Times in 0 Posts
iTrader: (0)
Quote:
Originally Posted by Kremmen View Post
You just need something to check the overnight voltage drop.

After I CTEK mine, because it sits in the garage most weeks, it takes about a week to drop below 12v, when I CTEK it again.

I charged mine exactly a week ago, last Tuesday and it's still got 12v even though it hasn't moved:

Attachment 288272
Sorry for noob questions, but do I need to remove the battery to check the voltage drop? Also, which CTEK product I should use?

https://www.amazon.co.uk/CTEK-MXS-5-.../dp/B00FC42HAA

This would be suitable for both checking the battery health and also charging it?
Dmi3 is offline  
post #12 of 15 (permalink) Old 7th August 2018, 08:59
Administrator
 
Kremmen's Avatar
 
Car: MY13 1.8 EX Auto
Join Date: 7th January 2007
Location: West London ENGLAND
Posts: 20,944
Thanks: 857
Thanked 1,708 Times in 1,431 Posts
iTrader: (0)
Eco display Eco display
Garage
Kremmen is offline  
Thanks to Kremmen from:
post #13 of 15 (permalink) Old 7th August 2018, 18:45 Thread Starter
Supporter
** Thread starter **
 
Car: Deep Bronze, Type S 2.2
Join Date: 22nd July 2018
Location: Warwick
Posts: 13
Thanks: 4
Thanked 0 Times in 0 Posts
iTrader: (0)
Quote:
Originally Posted by Kremmen View Post
You are a gentleman and a scholar, thank you.
Dmi3 is offline  
post #14 of 15 (permalink) Old 7th August 2018, 23:36
Super Moderator
 
M8TJT's Avatar
 
Car: 10G 1.5 Civic Prestige
Join Date: 10th October 2015
Location: Bexhill, Sussex GB
Posts: 2,889
Thanks: 86
Thanked 215 Times in 207 Posts
iTrader: (1)
Quote:
Originally Posted by Dmi3 View Post
You are a gentleman and a scholar, thank you.
That's pushing the boundaries of reality a bit far Dmi. It is Kremmen that you are talking about here you know.
Kremmen and Bones126 like this.
M8TJT is offline  
post #15 of 15 (permalink) Old 9th August 2018, 08:41 Thread Starter
Supporter
** Thread starter **
 
Car: Deep Bronze, Type S 2.2
Join Date: 22nd July 2018
Location: Warwick
Posts: 13
Thanks: 4
Thanked 0 Times in 0 Posts
iTrader: (0)
Quote:
Originally Posted by M8TJT View Post
That's pushing the boundaries of reality a bit far Dmi. It is Kremmen that you are talking about here you know.
I just appreciate the people who spend time giving advice
M8TJT likes this.
Dmi3 is offline  
Reply

  Civinfo > 8th Generation Euro Honda Civic (2006 - 2011) > Bugs, faults and irritations (8G)

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Civinfo forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
Your User Name is the name that appears by all your posts on the forum, and so should not be your email address.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
Alarm battery died now alarm goes off bandalar Electronics (8G) 1 20th May 2014 22:46
Battery Died...now air con doesn't work gavpop General Discussion (8G) 1 21st April 2013 10:48
Battery died in cold now wont start with new batter Ransom General Discussion (8G) 15 28th November 2012 20:49
Engine Check engine light- fault code P250A - Engine Oil Level Sensor Circuit waqar Bugs, faults and irritations (8G) 1 29th April 2012 05:16
Engine check engine light on few days after AEM cold air intake installed rakuten Bugs, faults and irritations (8G) 10 23rd February 2012 18:42

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome