Electrics Radio, Aircon display blank radio not working - Civinfo
 
LinkBack Thread Tools
post #1 of 5 (permalink) Old 3rd April 2012, 16:29 Thread Starter
Supporter
 
Hotchy's Avatar
 
Car: 2007 57 2.2 Type S
Join Date: 19th February 2011
Location: Scotland SCOTLAND
Posts: 644
Thanks: 36
Thanked 39 Times in 39 Posts
iTrader: (1)
Radio, Aircon display blank radio not working

I turned my car on today and the area where the radio, aircon, time etc display is blank. Nothing. Radio cant turn on either. Any help on fixing this? What fuses need to be checked and where abouts? Hmm seems to be a problem after problem with this car...

No warrenty either.
Hotchy is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 3rd April 2012, 17:23
...............Daedalus
 
mpn_daedalus's Avatar
 
Car: CW Type R No. 460
Join Date: 5th August 2010
Location: Norfolk, UK GB
Posts: 3,687
Thanks: 236
Thanked 445 Times in 413 Posts
iTrader: (3)
http://www.civinfo.com/forum/electro...protected.html

Fuse 35 in the interior fuse box by the looks of it. Might be worth checking them all though.
mpn_daedalus is offline  
Thanks to mpn_daedalus from:
post #3 of 5 (permalink) Old 5th April 2012, 12:45 Thread Starter
Supporter
** Thread starter **
 
Hotchy's Avatar
 
Car: 2007 57 2.2 Type S
Join Date: 19th February 2011
Location: Scotland SCOTLAND
Posts: 644
Thanks: 36
Thanked 39 Times in 39 Posts
iTrader: (1)
Just checked the fuse and the fuse looks fine to me, replace it anyway? No.other fuses are broke.

Also broke the we fuse puller anywhere do a better replacement?
Hotchy is offline  
 
post #4 of 5 (permalink) Old 8th April 2012, 15:12 Thread Starter
Supporter
** Thread starter **
 
Hotchy's Avatar
 
Car: 2007 57 2.2 Type S
Join Date: 19th February 2011
Location: Scotland SCOTLAND
Posts: 644
Thanks: 36
Thanked 39 Times in 39 Posts
iTrader: (1)
Update for anyone who gets same problem. Took radio out.. and was testing for voltage etc, nothing then wiggled a wire and it worked lol must have a short connection but its fixed now!
Hotchy is offline  
post #5 of 5 (permalink) Old 14th April 2012, 12:34
Super Moderator
 
Grayfox's Avatar
 
Car: '11 Impreza R Special
Join Date: 1st February 2012
Location: NSW, Australia AU
Posts: 7,124
Thanks: 93
Thanked 1,009 Times in 890 Posts
iTrader: (0)
Eco display Eco display
Garage
Pliers can pull them out or just hit ebay for a cheap pair of fuse pullers

eBay - The UK's Online Marketplace

One like that will be fine, it will also remove the vanity bulb light bulb.
Grayfox is offline  
Reply

  Civinfo > 8th Generation Euro Honda Civic (2006 - 2011) > Bugs, faults and irritations (8G)

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Civinfo forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
Your User Name is the name that appears by all your posts on the forum, and so should not be your email address.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
Electrics Radio/Aircon Display problem pkef Electronics (8G) 20 25th September 2017 02:24
Electrics LCD aircon radio display potters1 Bugs, faults and irritations (8G) 12 3rd January 2014 17:50
Head Unit radio display STINGA Ipods, MP3 Players and ICE (8G) 2 14th October 2010 13:28
Electrics the aircon,temp.etc. display dashboard are not working tissot Electronics (8G) 2 12th October 2009 19:53
Technical Air Condition display not working without OEM radio MikaK Ipods, MP3 Players and ICE (8G) 0 4th December 2006 19:51

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome