AC/Heater clock/radio/air-con display - Civinfo
 
LinkBack Thread Tools
post #1 of 15 (permalink) Old 17th March 2014, 14:48 Thread Starter
 
Car: 2007 civic type R GT
Join Date: 21st June 2013
Location: Bromley ENGLAND
Posts: 12
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader: (0)
clock/radio/air-con display

on my 2007 Civic has anyone had issues where (what appears to be) a loss of power. The screen a has been flickering for some time now and has started switching off all together now. Any solutions would be great

regards
Mattsh is offline  
Sponsored Links
Advertisement
 
post #2 of 15 (permalink) Old 17th March 2014, 15:44
 
Pyngu's Avatar
 
Car: 2013 1.6d Sport, Alab. grey
Join Date: 3rd January 2014
Location: Sintra, Portugal PT
Posts: 92
Thanks: 3
Thanked 17 Times in 17 Posts
iTrader: (0)
Probably in the 8th gen section you could receive help quicker...
Pyngu is offline  
post #3 of 15 (permalink) Old 18th March 2014, 12:25
 
GaryCowan's Avatar
 
Join Date: 25th January 2014
Location: Lancaster ENGLAND
Posts: 25
Thanks: 1
Thanked 1 Time in 1 Post
iTrader: (0)
Does the radio pop through the speakers. From what I have found with a lot of research is its the radio at fault.

Sent from my GT-I8190N using Tapatalk
GaryCowan is offline  
 
post #4 of 15 (permalink) Old 18th March 2014, 14:11
Supporter
 
miked5's Avatar
 
Car: 2008 Type R NHB
Join Date: 27th February 2014
Location: Barnard Castle ENGLAND
Posts: 80
Thanks: 7
Thanked 3 Times in 2 Posts
iTrader: (1)
Had this problem with mine changed the radio unit and everything works ok now
miked5 is offline  
post #5 of 15 (permalink) Old 18th March 2014, 23:24 Thread Starter
** Thread starter **
 
Car: 2007 civic type R GT
Join Date: 21st June 2013
Location: Bromley ENGLAND
Posts: 12
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader: (0)
What does it involve Changing the radio unit. Is that expensive?
Thanks
Mattsh is offline  
post #6 of 15 (permalink) Old 18th March 2014, 23:28
 
GaryCowan's Avatar
 
Join Date: 25th January 2014
Location: Lancaster ENGLAND
Posts: 25
Thanks: 1
Thanked 1 Time in 1 Post
iTrader: (0)
There's a few how to videos on YouTube and such. Second hand radios off eBay.

Sent from my GT-I8190N using Tapatalk
GaryCowan is offline  
post #7 of 15 (permalink) Old 18th March 2014, 23:30
Supporter
 
miked5's Avatar
 
Car: 2008 Type R NHB
Join Date: 27th February 2014
Location: Barnard Castle ENGLAND
Posts: 80
Thanks: 7
Thanked 3 Times in 2 Posts
iTrader: (1)
I found a 2nd hand one on eBay for 80, Honda main dealer quoted me nearly 1100 for stereo and labour to fit ha. Unfortunately it is a pretty big job to remove it I think there's a thread on here of how to. You have to remove a lot of the dash


Sent from my iPhone using Tapatalk
miked5 is offline  
post #8 of 15 (permalink) Old 19th March 2014, 00:06 Thread Starter
** Thread starter **
 
Car: 2007 civic type R GT
Join Date: 21st June 2013
Location: Bromley ENGLAND
Posts: 12
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader: (0)
Ok thanks for your help. Must say I'm surprised that I need to replace a whole radio unit when it's a the display screen is playing up. Driving it today and it was of course doing it again. Gave it a good old fashion whack and it lighted up again. Not fixed but I thought it would be a loose wire or something?
Mattsh is offline  
post #9 of 15 (permalink) Old 19th March 2014, 00:28
Supporter
 
miked5's Avatar
 
Car: 2008 Type R NHB
Join Date: 27th February 2014
Location: Barnard Castle ENGLAND
Posts: 80
Thanks: 7
Thanked 3 Times in 2 Posts
iTrader: (1)
Yeah I read others have changed the display which has fixed it also. Does your radio work still?


Sent from my iPhone using Tapatalk
miked5 is offline  
post #10 of 15 (permalink) Old 19th March 2014, 00:33 Thread Starter
** Thread starter **
 
Car: 2007 civic type R GT
Join Date: 21st June 2013
Location: Bromley ENGLAND
Posts: 12
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader: (0)
Radio and air con work fine. No problems there
Mattsh is offline  
post #11 of 15 (permalink) Old 19th March 2014, 00:37
Supporter
 
miked5's Avatar
 
Car: 2008 Type R NHB
Join Date: 27th February 2014
Location: Barnard Castle ENGLAND
Posts: 80
Thanks: 7
Thanked 3 Times in 2 Posts
iTrader: (1)
Ahh I see well my radio wasn't working at all. More likely it's the display screen that has gone then. Have you checked for any blown fuses?


Sent from my iPhone using Tapatalk
miked5 is offline  
post #12 of 15 (permalink) Old 19th March 2014, 00:42
Supporter
 
miked5's Avatar
 
Car: 2008 Type R NHB
Join Date: 27th February 2014
Location: Barnard Castle ENGLAND
Posts: 80
Thanks: 7
Thanked 3 Times in 2 Posts
iTrader: (1)
miked5 is offline  
post #13 of 15 (permalink) Old 19th March 2014, 00:44
Supporter
 
Yazi's Avatar
 
Car: 2006 2.2 NHB
Join Date: 27th January 2013
Location: Peterborough, UK GB
Posts: 97
Thanks: 19
Thanked 6 Times in 6 Posts
iTrader: (0)
hi, if u need a radio. i will have one spare by friday. its being replaced by amdouble din . full working and very good condition. 70 plus delivery, or collection. pm me if u will want it and ill start a sale thread.
Yazi is offline  
post #14 of 15 (permalink) Old 19th March 2014, 00:57 Thread Starter
** Thread starter **
 
Car: 2007 civic type R GT
Join Date: 21st June 2013
Location: Bromley ENGLAND
Posts: 12
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader: (0)
I'll check the fuses. Many thanks. It either flickers, goes dim, working fine or not all. Very annoying so you think a fuse could at fault?

Fingers crossed
Mattsh is offline  
post #15 of 15 (permalink) Old 19th March 2014, 09:02
 
GaryCowan's Avatar
 
Join Date: 25th January 2014
Location: Lancaster ENGLAND
Posts: 25
Thanks: 1
Thanked 1 Time in 1 Post
iTrader: (0)
Quote:
Originally Posted by Yazi View Post
hi, if u need a radio. i will have one spare by friday. its being replaced by amdouble din . full working and very good condition. 70 plus delivery, or collection. pm me if u will want it and ill start a sale thread.
Where abouts are you mate?

Sent from my GT-I8190N using Tapatalk
GaryCowan is offline  
Reply

  Civinfo > 8th Generation Euro Honda Civic (2006 - 2011) > Electronics (8G)

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Civinfo forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
Your User Name is the name that appears by all your posts on the forum, and so should not be your email address.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
Electrics Clock Radio AC Display not working PeTa Electronics (8G) 17 27th February 2017 20:02
Electrics Radio/Clock/Temp display dead rossimo27 Bugs, faults and irritations (8G) 6 17th March 2014 13:38
Electrics Problem with radio/clock display LFC24 Electronics (8G) 0 15th September 2013 00:12
Electrics Fading Clock/Radio Display WhistlerUK Electronics (8G) 15 12th October 2012 18:45
Computer Strange Radio/Clock Display problem civicman1 Bugs, faults and irritations (8G) 0 11th March 2008 20:12

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome