Other rad fan not working - Civinfo
 
LinkBack Thread Tools
post #1 of 2 (permalink) Old 18th November 2014, 21:03 Thread Starter
Supporter
 
creambun2006's Avatar
 
Car: 2006 1.8 petrol
Join Date: 22nd March 2014
Location: gloucester ENGLAND
Posts: 210
Thanks: 7
Thanked 3 Times in 3 Posts
iTrader: (1)
rad fan not working

Hi
I had the main fan drivers side stop working seems seized so popped in another universal one , tested with direct power all working ,
but it does not kick in when driving left it ticking over for 20mins but no power going to fan .
which and where is the fuse and relay for this fan ,
checked the 2 relays under bonnet seem fine all fuses seem ok
what next please any ideas
creambun2006 is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 26th November 2014, 11:13
 
Join Date: 31st January 2013
Location: Norfolk GB
Posts: 451
Thanks: 4
Thanked 41 Times in 37 Posts
iTrader: (1)
Could be that the coolant temp switch for the fan has died.
Tricky-Ricky is offline  
Reply

  Civinfo > 8th Generation Euro Honda Civic (2006 - 2011) > Electronics (8G)

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Civinfo forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
Your User Name is the name that appears by all your posts on the forum, and so should not be your email address.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
Aircon fan not working Bigdaddy General Discussion (8G) 15 31st July 2014 15:39
Coolant Rad cap not fitting james-lew Engines and Transmission (8G) 2 3rd December 2013 15:51
Turn fan off, increase fan speed = what mode? Mouse9 General Discussion (8G) 1 29th May 2013 21:19
When you switch the fan off then speed 1 - What fan mode is it in? Mouse9 General Discussion (8G) 6 3rd February 2013 02:21
Cosmic Old and New Rad Mobiles Conrad'67 Gallery (8G) 8 19th July 2007 23:31

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome