Electrics How do I fix the thermometer for the outside temperature - Civinfo
 
LinkBack Thread Tools
post #1 of 10 (permalink) Old 1st March 2015, 18:41 Thread Starter
 
Join Date: 15th February 2015
Location: UK GB
Posts: 5
Thanks: 9
Thanked 0 Times in 0 Posts
iTrader: (0)
How do I fix the thermometer for the outside temperature

Hi everyone

I have a Honda Civic 2007. My onboard thermometer (which gives a digital reading like the image below) is not giving correct readings. It either gives a reading much below the actual temperature or gives nothing at all, only dashes! How do I fix this? Any ideas?

I'm thinking about checking, and possibly replacing, the sensor but where is it located? Thank you for any help.

Sea Ocean is offline  
Sponsored Links
Advertisement
 
post #2 of 10 (permalink) Old 1st March 2015, 19:43
 
Steve_m's Avatar
 
Car: 2019 Civic 5D 1.5 Sport+
Join Date: 9th September 2007
Posts: 852
Thanks: 1
Thanked 264 Times in 219 Posts
iTrader: (0)
The ambient temperature sensor can be seen through the front bumper grille below the front number plate.

Your varied temperature readings does sound like a faulty sensor, but I would also check that there is no corrosion on the sensor connector as well.
Steve_m is offline  
Thanks to Steve_m from:
post #3 of 10 (permalink) Old 2nd March 2015, 13:09
Super Moderator
 
Grayfox's Avatar
 
Car: '11 Impreza R Special
Join Date: 1st February 2012
Location: NSW, Australia AU
Posts: 7,124
Thanks: 93
Thanked 1,011 Times in 891 Posts
iTrader: (0)
Eco display Eco display
Garage
I could replace the sensor, it does more than tell you ambient air temp.
It acts like a choke to modern cars.

It tells the ECU what baseline to use for fuel for the current air temp on start up
Grayfox is offline  
Thanks to Grayfox from:
 
post #4 of 10 (permalink) Old 2nd March 2015, 21:25
Supporter
 
Car: Galaxy Grey Met. 2006 1.8 EX
Join Date: 16th November 2014
Location: Carlisle, UK GB
Posts: 69
Thanks: 3
Thanked 5 Times in 5 Posts
iTrader: (1)
Sorry to hijack the thread - But I've noticed mine takes a little while to get to the "Correct" temperature (according to the weather), it normally starts off at around 7/8c, but then eventually makes it's way to, for instance, 2c (the actual temperature), is this normal?
Killgroup is offline  
post #5 of 10 (permalink) Old 2nd March 2015, 22:14
Stage 3 Hybrid
 
messiahontrial's Avatar
 
Car: 56 Alabaster FN3
Join Date: 27th August 2012
Location: Ayr ENGLAND
Posts: 6,223
Thanks: 3,270
Thanked 2,328 Times in 1,784 Posts
iTrader: (10)
This is the temp sensor, centre pic...



Just above O/S outlet of FMIC, (aftermarket mod to my 2.2).

messiahontrial is offline  
Thanks to messiahontrial from:
post #6 of 10 (permalink) Old 8th March 2015, 18:05 Thread Starter
** Thread starter **
 
Join Date: 15th February 2015
Location: UK GB
Posts: 5
Thanks: 9
Thanked 0 Times in 0 Posts
iTrader: (0)
Thank you all very much. I plan to check it next weekend. I hope it won't rain (Urg... UK weather).

Killgroup,
I wish I could help you but I don't really know, although Grayfox's reply should suffice.
Sea Ocean is offline  
post #7 of 10 (permalink) Old 15th February 2016, 11:30
 
Car: 2008 2.2 SE I-CTDI
Join Date: 21st May 2015
Location: Sutherland SCOTLAND
Posts: 9
Thanks: 0
Thanked 8 Times in 6 Posts
iTrader: (0)
I know this is an old thread, but just in case anyone else has this come up, I have just replaced mine, bought the part from DHGate.com for $16 from China with free delivery, delivered in 2 weeks and with a long thin screwdriver (to release the little clips) and a pair of long nose pliers was able to get the old part off, and the new one on in 20 mins without removing the bumper, was a bit fiddly but relatively easy to do and as opposed to it saying it is 55C in the snow it is now showing a more reasonable 3C and I have cabin temperature control again, happy days.

Just thought this may help
Biotic Blue is offline  
Thank You to Biotic Blue from 3 Users:
post #8 of 10 (permalink) Old 15th February 2016, 12:07
 
ti500's Avatar
 
Car: 2011 Civic TI 500
Join Date: 30th September 2015
Location: Glasgow SCOTLAND
Posts: 436
Thanks: 53
Thanked 77 Times in 74 Posts
iTrader: (0)
Quote:
Originally Posted by Biotic Blue View Post
I know this is an old thread, but just in case anyone else has this come up, I have just replaced mine, bought the part from DHGate.com for $16 from China with free delivery, delivered in 2 weeks and with a long thin screwdriver (to release the little clips) and a pair of long nose pliers was able to get the old part off, and the new one on in 20 mins without removing the bumper, was a bit fiddly but relatively easy to do and as opposed to it saying it is 55C in the snow it is now showing a more reasonable 3C and I have cabin temperature control again, happy days.

Just thought this may help
Thanks for the post handy to know
ti500 is offline  
post #9 of 10 (permalink) Old 22nd March 2016, 22:15
MFG
 
Join Date: 22nd July 2014
Location: Amsterdam, NL NL
Posts: 22
Thanks: 10
Thanked 3 Times in 3 Posts
iTrader: (0)
Hey, thanks for this. Its very helpful to me

Quote:
Originally Posted by Biotic Blue View Post
I know this is an old thread, but just in case anyone else has this come up, I have just replaced mine, bought the part from DHGate.com for $16 from China with free delivery, delivered in 2 weeks and with a long thin screwdriver (to release the little clips) and a pair of long nose pliers was able to get the old part off, and the new one on in 20 mins without removing the bumper, was a bit fiddly but relatively easy to do and as opposed to it saying it is 55C in the snow it is now showing a more reasonable 3C and I have cabin temperature control again, happy days.

Just thought this may help
MFG is offline  
post #10 of 10 (permalink) Old 23rd December 2016, 12:49
 
pam6's Avatar
 
Join Date: 23rd June 2016
Posts: 29
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader: (0)
Thank you so much you dont know the oem part number do you please?
pam6 is offline  
Reply

  Civinfo > 8th Generation Euro Honda Civic (2006 - 2011) > Electronics (8G)

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Civinfo forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
Your User Name is the name that appears by all your posts on the forum, and so should not be your email address.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
Electrics I managed to FIX my temperature sensor! automobilklub Bugs, faults and irritations (8G) 16 21st July 2017 20:09
AC/Heater Heater / Thermometer Problem andyp79 Bugs, faults and irritations (8G) 25 23rd June 2014 00:20
Computer Temperature Gauge! (Faulty outside temperature sensor) SimplyTheBest1989 Bugs, faults and irritations (8G) 125 23rd June 2014 00:18
Car Thermometer Kremmen Any non Civic chat here please! 2 26th February 2013 20:52
Car's Thermometer fat4y General Discussion (8G) 13 10th June 2009 12:57

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome