Electrics Bizarre radio issue. - Civinfo
 
LinkBack Thread Tools
post #1 of 5 (permalink) Old 2nd November 2015, 15:39 Thread Starter
 
Join Date: 14th February 2015
Location: London, UK GB
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader: (0)
Thumbs down Bizarre radio issue.

Hi,

This is a new problem to me, and having done a search I haven't seen it on here. So maybe it is an unusual problem...?

After roughly an hour of motorway driving (I only do occasional long journeys) my radio emits one very loud popping crack sound and craps out. The clock/heater/channel display does that irritating thing where all the segments are illuminated. Then the radio repeatedly turns itself on, briefly pops and crackles like an old record and then turns itself off. Then on, then off, then on, then off etc.

There is no response to channel or volume selection and the satnav wasn't on so I don't know if that is effected.

This has happened twice, each time the heater was on because it was chilly outside.

The only cure I have found is to turn off the ignition and take the keys out. Leaving the keys in and turning it back on does not work, so I guess this resets the relevant bit of the electrical system somehow.

This is fine when sitting in a traffic jam (like this morning!) but zipping down the M4 at 11pm its a bit of a pain.

Thoughts, gentlemen? Thanks.
Apex Aerial Filming is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 2nd November 2015, 19:17
Civinfo Hobbyist Trader
 
x5252x's Avatar
 
Car: 2010 CTS GT
Join Date: 8th May 2013
Location: Cambridge, UK GB
Posts: 1,777
Thanks: 356
Thanked 410 Times in 330 Posts
iTrader: (22)
Sounds like your head unit is on its way out.

Could be something as simple as replacing a voltage regulator, but may be a good excuse to upgrade to a double din?
x5252x is offline  
post #3 of 5 (permalink) Old 4th November 2015, 17:01
 
Car: 2008 CTR, Milano Red.
Join Date: 10th January 2015
Location: Norway NO
Posts: 302
Thanks: 67
Thanked 19 Times in 17 Posts
iTrader: (1)
Same happened to me this summer. I was actually quite glad, as it explains why my display is going all weird on me sometimes. For me it's a good excuse for getting a double din when i have the money for it

Sent from my SM-G900F using Tapatalk
kevven is offline  
 
post #4 of 5 (permalink) Old 4th November 2015, 20:16
Ex-Pat Geordie!
 
nturnb's Avatar
 
Car: 2015 Civic S Navi I-dtec
Join Date: 17th November 2013
Location: Irvine, Ayrshire GB
Posts: 2,190
Thanks: 119
Thanked 223 Times in 204 Posts
iTrader: (0)
Eco display
Get a Priest, sounds like it needs an Exorcism mate
nturnb is offline  
post #5 of 5 (permalink) Old 4th November 2015, 21:27
turbo's are just cheating
 
AKBlackFn2's Avatar
 
Car: 2008 CTR NHB
Join Date: 29th January 2012
Location: Manchester GB
Posts: 307
Thanks: 8
Thanked 16 Times in 16 Posts
iTrader: (3)
Happened many times mate....head unit overheating....will only get worst till its totally gone. Afraid its a new hu Bobbie ... I went aftermarket mate...only way . p.s the speakers in the civic are better than they sound...the hu is poo


Az
AKBlackFn2 is offline  
Thanks to AKBlackFn2 from:
Reply

  Civinfo > 8th Generation Euro Honda Civic (2006 - 2011) > Electronics (8G)

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Civinfo forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
Your User Name is the name that appears by all your posts on the forum, and so should not be your email address.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
Electrics Clock Lcd radio screen issue NTurner Electronics (8G) 2 6th March 2015 13:06
Transmission Bizarre iShift issue Beanieboy Engines and Transmission (8G) 1 18th July 2014 10:26
Japanese Food Thread - Post the Bizarre or what you have experienced. MrBozo Any non Civic chat here please! 17 11th July 2014 22:01
Satnav Bizarre drive home Milano_Jon Electronics (8G) 14 10th September 2007 20:54

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome