Electrics Help! Please ! Intermittent CEL & COL faults - Civinfo
 1Likes
  • 1 Post By Bun75
 
LinkBack Thread Tools
post #1 of 5 (permalink) Old 30th July 2016, 09:20 Thread Starter
 
Join Date: 30th July 2016
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader: (0)
Help! Please ! Intermittent CEL & COL faults

Hello everyone, I'm hoping somebody can shed some light on this problem for me .
I have just bought an 2006 1,8 es petrol . Love it , but I keep getting the CEL come up . I have a scanner and it comes up knock sensor! I also keep getting the check oil light .
I have a receipt for a new knock sensor earlier this year ,& I changed the oil so I know its right.
So I kinda think this is a possible loom/ecu issue.
Its also fine sometimes. Yesterday I did 170 miles before it came up . yet the day before it came on in 3 miles.
I also think its not revving out that well ,but again that could be the knock sensor I guess.
Does anyone know if the 2 sensors share the same loom .Etc

Any help would be really appreciated, thanks
Bun75 is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 30th July 2016, 10:56
Supporter
 
lightningslow's Avatar
 
Car: 2007 1.8 EX iShift 5DR
Join Date: 11th July 2015
Location: essex ENGLAND
Posts: 1,821
Thanks: 36
Thanked 181 Times in 176 Posts
iTrader: (15)
Get it plugged in properly to see if its an open circuit. I find sensors that are 3rd party are horrendous for quality
lightningslow is offline  
post #3 of 5 (permalink) Old 30th July 2016, 18:45 Thread Starter
** Thread starter **
 
Join Date: 30th July 2016
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader: (0)
May have to do that although the replaced knock sensor was a Honda part .

I think I have discovered that it doesn't happen if I disconnect the oil sensor !
Which I think is weird. !!
Bun75 is offline  
 
post #4 of 5 (permalink) Old 31st July 2016, 17:05 Thread Starter
** Thread starter **
 
Join Date: 30th July 2016
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader: (0)
I was wrong . Still doing it !
I read there is a possibly update for the oil level issue. But i think its time to isolate and put some fresh wire in

Sent from my SM-N910F using Tapatalk
Bun75 is offline  
post #5 of 5 (permalink) Old 8th August 2016, 17:32 Thread Starter
** Thread starter **
 
Join Date: 30th July 2016
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader: (0)
So long and short is , i had to disconnect the alternator to fit a air con pump . However, i did not disconnect the battery for fear of losing the stereo code (if it has one ) ?????? I was very careful not to short any cables.
But i figured i either had an ecu that was having a strop or a broken knock sensor wire . So i disconnected the ecu and put A new wire in from sensor to ecu plug ....
Sorted!!!!
Either the wire was broken or the ecu needed to be powered down for a while. Either way it works

Sent from my SM-N910F using Tapatalk
Farqui likes this.
Bun75 is offline  
Reply

  Civinfo > 8th Generation Euro Honda Civic (2006 - 2011) > Electronics (8G)

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Civinfo forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
Your User Name is the name that appears by all your posts on the forum, and so should not be your email address.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
AC/Heater DTC P0533, PGM-FI Faults & Wiring Diagrams tjvanman Bugs, faults and irritations (8G) 2 10th February 2016 13:41
Faults Engine cel won't go out Eif1972 Engines and Transmission (8G) 3 26th September 2015 11:32
Brakes ABS & VSA "Check System" Faults. 43634 Bugs, faults and irritations (8G) 8 29th May 2013 21:57
Engine Latest faults, cracked exhaust manifold & rear screen delaminating damianscott71 Bugs, faults and irritations (8G) 11 16th July 2008 14:33
Long list faults faults faults pffffff meesterlijk Bugs, faults and irritations (8G) 77 2nd April 2007 10:39

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome