Other Intermittent wing mirror LED repeater - Civinfo
 
LinkBack Thread Tools
post #1 of 5 (permalink) Old 16th December 2016, 22:19 Thread Starter
 
Car: 2009 CTR, Milano Red
Join Date: 5th January 2016
Location: Manchester, UK GB
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader: (0)
Intermittent wing mirror LED repeater

Hello all!

First post so here after much time lurking, unfortunately its a bug-bear so here goes!

2 days after its Honda Approved warranty my passenger side LED wing mirror repeater has suddenly become largely broken...
The majority of the time the LEDs will only faintly flash when indicators/hazards/locks are enabled whereas there have been times that its worked perfectly since the time I first noticed it going wrong.

A new LED repeater unit is 45 and I don't really want to replace it if it can be helped. Incidentally my dad has the same issue with his FN2. Is this a common issue?

Thanks for any reponses!
McNuggats is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 16th December 2016, 22:46
Administrator
 
Farqui's Avatar
 
Car: x'06 2.2 EX FK3 Milano
Join Date: 29th April 2014
Location: n.Notts ENGLAND
Posts: 17,907
Thanks: 5,716
Thanked 4,165 Times in 3,861 Posts
iTrader: (31)
Eco display Eco display
Garage
Check the contacts? Maybe they are loose or slightly corroded...
Farqui is offline  
post #3 of 5 (permalink) Old 17th December 2016, 11:31
Supporter
 
anthropolyte's Avatar
 
Car: 2008 Type R FN2, NHB
Join Date: 2nd October 2014
Location: Bristol, UK GB
Posts: 1,211
Thanks: 58
Thanked 222 Times in 196 Posts
iTrader: (7)
I had this on mine too - unfortunately it's an indication (no pun intended) that the LED unit is failing. Needs replacing.
anthropolyte is offline  
 
post #4 of 5 (permalink) Old 17th December 2016, 13:39
Banned
 
Aqib's Avatar
 
Join Date: 22nd November 2011
Location: Glasgow, UK SCOTLAND
Posts: 7,705
Thanks: 296
Thanked 1,378 Times in 1,315 Posts
iTrader: (26)
Quote:
Originally Posted by anthropolyte View Post
I had this on mine too - unfortunately it's an indication (no pun intended) that the LED unit is failing. Needs replacing.
As above. New unit needed. MOT failure too
Aqib is offline  
post #5 of 5 (permalink) Old 17th December 2016, 17:15
 
Car: 2006 1.8 ES petrol v-tech
Join Date: 13th March 2015
Location: manchester ENGLAND
Posts: 282
Thanks: 7
Thanked 42 Times in 37 Posts
iTrader: (0)
As above duff unit, awful design by Honda that a bulb can't be simply replaced costing around 50p, silly design. There is a 'how to' on the forum as regards replacing the led's but it's a lot of messing about so pop the glass off then long nose pliers to release the pod, unscrew the unit and replace and reassemble.
painter is offline  
Reply

  Civinfo > 8th Generation Euro Honda Civic (2006 - 2011) > Electronics (8G)

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Civinfo forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
Your User Name is the name that appears by all your posts on the forum, and so should not be your email address.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
Indicator LED Wing Mirror Schematic Cividave Lights (8G) 2 15th June 2015 23:27
Indicator Wing Mirror Indicator LED replacement? law000 Lights (8G) 4 27th September 2014 20:46
Indicator Wing Mirror Led Module borse2010 Lights (8G) 1 22nd April 2012 20:03

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome