Speedo Speedo Display Fault - Civinfo
 
LinkBack Thread Tools
post #1 of 1 (permalink) Old 10th May 2010, 20:29 Thread Starter
 
Join Date: 17th April 2007
Posts: 16
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader: (0)
Speedo Display Fault

I have a 58 plate 2.2EX and sometimes when the temperature is low (at 4 degrees or less like this morning) starting off from cold the speedo "displays all the eights" (EG 888 MPH). After about 10 minutes driving it starts to work OK.

The fault is intermittant and my dealer says they can only attend to it if they actually experience the fault (which is unlikely unless they use the car for a month of cold starts in the winter).

Has anyone else had this fault / got any ideas how to get an easy fix while the car is still under maker's warranty?
mikdys is offline  
Reply

  Civinfo > 8th Generation Euro Honda Civic (2006 - 2011) > Electronics (8G)

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Civinfo forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
Your User Name is the name that appears by all your posts on the forum, and so should not be your email address.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
Indications Flashing Glow Plug light and Engine Fault Display SmileyMan Engines and Transmission (8G) 11 24th July 2019 21:33
Head Unit iPod connector that display track info on Honda display DervMan Ipods, MP3 Players and ICE (8G) 7 15th March 2010 00:54
Speedo Speedo Windlepoons Electronics (8G) 17 16th September 2009 18:17
Speedo speedo briang Electronics (8G) 1 9th September 2006 20:27
Speedo Speedo Charles_Harding Electronics (8G) 9 25th August 2006 00:08

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome