No AC dash controls or mirror controls - Civinfo
 
LinkBack Thread Tools
post #1 of 2 (permalink) Old 16th July 2018, 11:03 Thread Starter
 
Car: 2010 2.2 Diese 5DR Civic EX
Join Date: 16th July 2018
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader: (0)
Question No AC dash controls or mirror controls

Hi all,

First time posting here, looking for some friendly advice!

I started up my 2010 Civic (2.2 diesel EX) yesterday to find that the dashboard controls for the AC had stopped working altogether. AC button, temperature controls etc, everything related to climate control. Additionally, I had no power to my mirrors.

Prior to this there had been absolutely no indication that there was something awry - no strange fan noises, no issues with achieving the correct temperature.

My initial thought was that the associated fuse had blown. Some digging through the car's manual led me to Fuse #36 within the interior fuse box, which is listed as 'IG2 HAC'. This is a 10A micro-blade fuse.

I removed it and inspected it, and I could see clearly that the fuse had blown. A quick trip to Halfords following to get some replacements. I installed the replacement fuse, turned the engine on, but to my disappointment the controls were still not functional. I removed the new fuse only to find that it had also blown.

I should note that my wing mirror (driver-side) did get knocked about 6 months ago but has continued to rotate/fold in and out ok (albeit slightly misaligned), with the 4-way adjusters also working fine.

I'm now at a point where I'd like some advice on what to try next before heading to a garage for a (likely) expensive repair. Can anybody help me with the following?:
  • Are there any schematics available of the associated wiring that I could use to perform some further diagnostics myself?
  • Are there any other fuses (any any other components for that matter) that I should check?
  • Might I have a short somewhere related to the wing mirror? How easily can I check the wiring to the mirror?
  • Is there any relationship with the temperature sensors for the AC? Might the hot weather have caused an issue leading to fuse 36 blowing continuously?

Thanks in advance!
schismatic is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 16th July 2018, 11:34
Administrator
 
Farqui's Avatar
 
Car: x'06 2.2 EX FK3 Milano
Join Date: 29th April 2014
Location: n.Notts ENGLAND
Posts: 17,791
Thanks: 5,716
Thanked 4,143 Times in 3,839 Posts
iTrader: (31)
Eco display Eco display
Garage
Welcome to

Sorry to hear that you have issues and it sounds like you need to do more digging into what is blowing the fuse. Try disconnecting components on that feed and rechecking the fuse.

Digging into the mirror and check all the connections wouldn't hurt either.

Has your AC ever worked?

Is your 12v battery in good condition with a solid ground? Modern car electrics rely on a solid electrical system, if it isn't then you can all sorts of weird voodoo going on.

Good luck and let us know how you get on.
Farqui is online now  
Reply

  Civinfo > 8th Generation Euro Honda Civic (2006 - 2011) > Electronics (8G)

Tags
ac fuse electrical

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Civinfo forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
Your User Name is the name that appears by all your posts on the forum, and so should not be your email address.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
No Bluetooth Input, No DAB, No Problem RickHondaR Honda CR-Z 10 18th August 2016 05:48
Lights Dash light no longer working for AC FAN MODE etc.. roundy Bugs, faults and irritations (9G) 5 22nd July 2016 11:34
Electrics No radio anymore, no A/C screen, no central lock… escargot08 Electronics (8G) 7 21st July 2014 22:27
Technical dash temp/ac display not working mayhem Ipods, MP3 Players and ICE (8G) 2 27th March 2013 19:59

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome