Electrics LCD not displaying and radio/heater not working - Civinfo
 
LinkBack Thread Tools
post #1 of 1 (permalink) Old 29th December 2018, 17:24 Thread Starter
 
Car: 2009 Civic 1.4 petrol
Join Date: 29th December 2018
Location: London ENGLAND
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader: (0)
Question LCD not displaying and radio/heater not working

Hi, need advice and guidance please. '59 plate Civic LCD started going faint and bitty then went off all together. After checking previous forums I assumed that it was the common fault of dry joints in the solder, I bought a second hand replacement one which I fitted but didn't resolve the fault. Both old and new ones light up partially around the edges from the soldered pins, am I correct in thinking that every pin must light up thus sending a current to the motherboard thing then that's where the LCD's work from? I have a couple of photos but cant seem to load them on here.
All advice welcome.
Steve Barclay is offline  
Reply

  Civinfo > 8th Generation Euro Honda Civic (2006 - 2011) > Electronics (8G)

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Civinfo forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
Your User Name is the name that appears by all your posts on the forum, and so should not be your email address.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
Electrics LCD stereo/temp display not working Lee30 Electronics (8G) 20 19th March 2019 07:02
Speedo FN2 Type R not displaying Type R red light on dash 5150andy Electronics (8G) 11 25th August 2018 15:20
Other radio and heater background lights not working help jay2348 Electronics (8G) 3 16th October 2015 08:37
Head Unit MP3s - Not displaying the full title chromosome Ipods, MP3 Players and ICE (8G) 6 18th February 2015 10:24
Electrics Outside Temperature Sensor not displaying and AC failure. NYMoors Electronics (8G) 3 17th August 2013 11:28

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome