Speedo Speedo not working, maybe mixed with revs - Civinfo
 
LinkBack Thread Tools
post #1 of 1 (permalink) Old 14th April 2019, 00:44 Thread Starter
 
Join Date: 14th April 2019
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader: (0)
Speedo not working, maybe mixed with revs

I bought an old 2006 civic and basically the speedometer doesn't work.

It seems that if I accelerate the speedo goes up depending on the acceleration, whereas the rev counter on the left does nothing. Speedo is 0 mph if not putting foot down. I am wondering if they somehow have the wires messed up.

Does this sound like a cheap/easy fix? Garage said they'd cover it as part of the purchase if it wasn't a huge job.
meowth is offline  
Reply

  Civinfo > 8th Generation Euro Honda Civic (2006 - 2011) > Electronics (8G)

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Civinfo forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
Your User Name is the name that appears by all your posts on the forum, and so should not be your email address.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
Satnav Satnav display not working Vesku Electronics (8G) 33 25th September 2015 18:38
Electrics Radio + Climate Control Stopped Working pigwah Electronics (8G) 0 26th May 2014 15:51
Hobbies Kirsty Any non Civic chat here please! 42 5th April 2010 09:48
Calibrate the speedo Pottsy This is How To ... (Guides Only) (8G) 37 27th September 2009 00:53
speedo suddenly stopped working after only a few days lawman General Discussion (8G) 10 5th May 2008 08:32

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome