Electrics Instrument Cluster flickering on and off - Civinfo
 
LinkBack Thread Tools
post #1 of 11 (permalink) Old 5th August 2019, 21:55 Thread Starter
 
Join Date: 12th June 2018
Posts: 19
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader: (0)
Instrument Cluster flickering on and off

Evening. For the last few months the instrument panel lights have been randomly filckering on and off. If the stay off then a slight nudge of the dimmer dial will bring them back to life. I though it may be a problem with the dimmer dial potentiometer but I bought a second hand one and that has the same problem although I suppose that could also be faulty. Does anyone have any idea as to what the fault could be? Thanks
kPATm is offline  
Sponsored Links
Advertisement
 
post #2 of 11 (permalink) Old 16th August 2019, 11:30
 
Join Date: 30th October 2006
Location: ΧΡΥΣΟΥΠΟΛΗ GR
Posts: 9
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader: (0)
Eco display Eco display
Send a message via AIM to jbabos
Hello

I also have the same problem. I believe it is not the dimmer switch because the lights increases and decreases normally
jbabos is offline  
post #3 of 11 (permalink) Old 16th August 2019, 21:33 Thread Starter
** Thread starter **
 
Join Date: 12th June 2018
Posts: 19
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader: (0)
Thats true. Cant really think what it could be as it only takes a very minor tap on the dimmer switch to cause the flicker. I actually opened up my original dimmer potentiometer to see if there was something obvious but TBH I dont really know what I would be looking for.
I'm thinking about bypassing the dimmer so as the cluster is always at full but I cant seem to find a pin out for the cluster connector
kPATm is offline  
 
post #4 of 11 (permalink) Old 17th August 2019, 09:22
 
Join Date: 30th October 2006
Location: ΧΡΥΣΟΥΠΟΛΗ GR
Posts: 9
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader: (0)
Eco display Eco display
Send a message via AIM to jbabos
I searched online a lot and found that another guy on a different car had the same problem and he disconnected the battery pols rubbed them on the inside and the problem was fixed. I did the same and post the result.
jbabos is offline  
post #5 of 11 (permalink) Old 17th August 2019, 11:36
 
Join Date: 30th October 2006
Location: ΧΡΥΣΟΥΠΟΛΗ GR
Posts: 9
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader: (0)
Eco display Eco display
Send a message via AIM to jbabos
Also try to adjust the brightness from the dimmer while you keep at least 2500 rpm. When i do this on my car the problem almost disapperas.
jbabos is offline  
post #6 of 11 (permalink) Old 19th August 2019, 15:31 Thread Starter
** Thread starter **
 
Join Date: 12th June 2018
Posts: 19
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader: (0)
Well I installed the replacement 2nd hand cluster using my original Dimmer dial and the cluster works fine so its not a fault with the dimmer like I thought. Really dont know what it could be.
kPATm is offline  
post #7 of 11 (permalink) Old 19th August 2019, 20:30 Thread Starter
** Thread starter **
 
Join Date: 12th June 2018
Posts: 19
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader: (0)
Quote:
Originally Posted by jbabos View Post
I searched online a lot and found that another guy on a different car had the same problem and he disconnected the battery pols rubbed them on the inside and the problem was fixed. I did the same and post the result.



Can you elaborate on this babos. I dont really know what you mean?
kPATm is offline  
post #8 of 11 (permalink) Old 19th August 2019, 20:39
 
Join Date: 30th October 2006
Location: ΧΡΥΣΟΥΠΟΛΗ GR
Posts: 9
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader: (0)
Eco display Eco display
Send a message via AIM to jbabos
I have tried to disconnect the battery rubbed the battery cables from the car with a sandpaper as i' ve seen from a video of another car that had a similar problem with ours but unfortunately nothing happend. I don't know what else to do. I am thinking to order a new dash from honda.

Last edited by jbabos; 19th August 2019 at 20:45.
jbabos is offline  
post #9 of 11 (permalink) Old 19th August 2019, 20:47
 
Join Date: 30th October 2006
Location: ΧΡΥΣΟΥΠΟΛΗ GR
Posts: 9
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader: (0)
Eco display Eco display
Send a message via AIM to jbabos
Also to add a comment to my previous post. I found a youtube video with a guy that has a similar problem to ours. I sending the link of the video to check it out and tell me your opinion.

Also try to check if the problem exists in high rpm, because in my car the problem dissappears after 3500 rpm


Thank you
jbabos is offline  
post #10 of 11 (permalink) Old 20th August 2019, 15:58 Thread Starter
** Thread starter **
 
Join Date: 12th June 2018
Posts: 19
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader: (0)
Thanks. I've watched that clip before but I think its a different problem. I did find this post


https://www.civinfo.com/#/topics/288761


Its seems like exactly the same orobkem as ours but unfortunately the original poster had to send his panel away to get fixed. I have posted on the page to ask him if he was informed of the problem. A new instrument panel from Honda would cost a lot of money. I will look into the probkem more but I may just try and pick up another 2nd hand panel with mileage near to what mine is at and just swap them over
kPATm is offline  
post #11 of 11 (permalink) Old 20th August 2019, 16:17 Thread Starter
** Thread starter **
 
Join Date: 12th June 2018
Posts: 19
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader: (0)
Im trying to get the PCB out of the panel to have a look at the LED that illuminates the rev counter but I can see a way to get it off. It would be usefull to have a diagram for the PCB as well
kPATm is offline  
Reply

  Civinfo > 8th Generation Euro Honda Civic (2006 - 2011) > Electronics (8G)

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Civinfo forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
Your User Name is the name that appears by all your posts on the forum, and so should not be your email address.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in













Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome