Speedo Speedo issue - Civinfo
 
LinkBack Thread Tools
post #1 of 4 (permalink) Old 29th September 2010, 17:57 Thread Starter
Supporter
 
ryeboi76's Avatar
 
Car: 2.2 Type S GT
Join Date: 5th September 2010
Location: Cardiff,UK WALES
Posts: 16
Thanks: 13
Thanked 2 Times in 1 Post
iTrader: (0)
Speedo issue

Hi all. Got a problem with my speedo and need advice. When doing between 20-29 mph and 50-59 mph the first number has a halo around it. All other speeds are fine it's just the 2 and 5. Any advice or causes would be appreciated.
ryeboi76 is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 30th September 2010, 17:52
Bog
Supporter
 
Bog's Avatar
 
Car: 2016 CR-V 1.6 160 4WD
Join Date: 5th October 2006
Location: Radlett, Hertfordshire GB
Posts: 6,455
Thanks: 281
Thanked 851 Times in 676 Posts
iTrader: (34)
Eco display
Have got any pics?
Bog is offline  
post #3 of 4 (permalink) Old 30th September 2010, 18:06
Supporter
 
steve fox's Avatar
 
Car: 2008 2.2 SE Blueish Silver
Join Date: 5th June 2009
Location: Bingham, South Notts ENGLAND
Posts: 748
Thanks: 7
Thanked 54 Times in 49 Posts
iTrader: (1)
Sounds like a replacement display is going to be needed, could be expensive unless it's a warranty job
steve fox is offline  
 
post #4 of 4 (permalink) Old 30th September 2010, 18:16
Unofficial Trader
 
dablink's Avatar
 
Car: CRV Urban Titanium
Join Date: 7th August 2009
Location: London, UK GB
Posts: 1,295
Thanks: 207
Thanked 163 Times in 153 Posts
iTrader: (13)
had a problem with my speed display year...it was replaced under warranty...if you are not happy with it...get it replaced mate....(I can see you have a 2010 car so you should be cool)
dablink is offline  
Reply

  Civinfo > 8th Generation Euro Honda Civic (2006 - 2011) > Electronics (8G)

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Civinfo forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
Your User Name is the name that appears by all your posts on the forum, and so should not be your email address.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
Faults Speedo reading philscivic Engines and Transmission (8G) 16 30th June 2011 09:36
Speedo Rev counter/Speedo Light Issue/Fault - Any 1else had it? jamesg23 Electronics (8G) 2 12th August 2010 23:26
Speedo Speedo Windlepoons Electronics (8G) 17 16th September 2009 18:17
Speedo speedo briang Electronics (8G) 1 9th September 2006 20:27
Speedo Speedo Charles_Harding Electronics (8G) 9 25th August 2006 00:08

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome