Electrics Radio display gone mental - Civinfo
 
LinkBack Thread Tools
post #1 of 17 (permalink) Old 5th November 2010, 23:27 Thread Starter
Supporter
 
calvin23's Avatar
 
Join Date: 31st August 2010
Location: Bolton GB
Posts: 317
Thanks: 3
Thanked 31 Times in 31 Posts
iTrader: (0)
Radio display gone mental

I have seen a post like this before with no solution.My radio display is showing everything on, then fades out again,then on then off.Is it a big problem or somthing small PLEASE HELP
calvin23 is offline  
Sponsored Links
Advertisement
 
post #2 of 17 (permalink) Old 6th November 2010, 20:37 Thread Starter
Supporter
** Thread starter **
 
calvin23's Avatar
 
Join Date: 31st August 2010
Location: Bolton GB
Posts: 317
Thanks: 3
Thanked 31 Times in 31 Posts
iTrader: (0)
Anyone have any ideas?
calvin23 is offline  
post #3 of 17 (permalink) Old 17th July 2011, 13:13
Supporter
 
amronno's Avatar
 
Car: 2012 1.8i Ex Navi Leather MR
Join Date: 8th August 2007
Location: Bergen, Norway NO
Posts: 1,600
Thanks: 216
Thanked 84 Times in 78 Posts
iTrader: (1)
Did you find any fix to this rare fault?

Mine has done almost exactly the same for quite some time now, getting worse and worse, switching between normal and 'bleeding' mode (where all the hidden background info lit up) more and more frequently. I can't tell you how annoying it is!

I hope it is caused by a dodgy connection somewhere, but I suspect there is no cure to this problem other than to replace the whole radio/temp. unit... ...and I don't think that will be cheap!

Ps; my car is the sat-nav version, so it is the smaller version display unit besides the sat-nav screen.

I think time has come to pay a visit at the local Honda dealership!
amronno is offline  
 
post #4 of 17 (permalink) Old 17th July 2011, 15:27
R.I.P - (User sadly passed away)
 
J. Derek Riddell's Avatar
 
Car: 2007 1.8 'Executive' (EX)
Join Date: 8th November 2007
Location: Isle of Hundvåg, Stavanger, Norway NO
Posts: 9,228
Thanks: 297
Thanked 1,111 Times in 831 Posts
iTrader: (5)
Quote:
Originally Posted by amronno View Post
....... I think time has come to pay a visit at the local Honda dealership!
Try asking in this and the Wanted sections - I just got a replacement CD player for €50 …
J. Derek Riddell is offline  
Thanks to J. Derek Riddell from:
post #5 of 17 (permalink) Old 17th July 2011, 17:15
Supporter
 
amronno's Avatar
 
Car: 2012 1.8i Ex Navi Leather MR
Join Date: 8th August 2007
Location: Bergen, Norway NO
Posts: 1,600
Thanks: 216
Thanked 84 Times in 78 Posts
iTrader: (1)
Quote:
Originally Posted by J. Derek Riddell View Post
Try asking in this and the Wanted sections - I just got a replacement CD player for €50 …


Thanks for that!

I could always do that, of course, but I think it is much easier to get hold of a replacement HU than this info display.

Anyone know the parts number of this radio display?
amronno is offline  
post #6 of 17 (permalink) Old 17th July 2011, 17:19
R.I.P - (User sadly passed away)
 
J. Derek Riddell's Avatar
 
Car: 2007 1.8 'Executive' (EX)
Join Date: 8th November 2007
Location: Isle of Hundvåg, Stavanger, Norway NO
Posts: 9,228
Thanks: 297
Thanked 1,111 Times in 831 Posts
iTrader: (5)
Quote:
Originally Posted by amronno View Post
Thanks for that! I could always do that, of course, but I think it is much easier to get hold of a replacement HU than this info display. Anyone know the parts number of this radio display?
A whole new HU is serious money ! ...

But, in any case, like the CD player, I think the radio \ info display unit is a separate module ? ...

Part no. - no idea ...
J. Derek Riddell is offline  
post #7 of 17 (permalink) Old 17th July 2011, 17:40
Supporter
 
amronno's Avatar
 
Car: 2012 1.8i Ex Navi Leather MR
Join Date: 8th August 2007
Location: Bergen, Norway NO
Posts: 1,600
Thanks: 216
Thanked 84 Times in 78 Posts
iTrader: (1)
Quote:
Originally Posted by J. Derek Riddell View Post
A whole new HU is serious money ! ...

But, in any case, like the CD player, I think the radio \ info display unit is a separate module ? ...

Part no. - no idea ...


So, what you are saying is the CD player you bought from another member on here is a separate part of the HU? Didn't know that, I thought if the CD player broken-down you had to replace the whole unit. Sorry for the confusion! My bad!

Yes, the radio display is a separate module, and I also think it is an easy job to replace it, meaning you don't have to dismantle a lot of trim/panels on the dashboard to get access to it...hopefully!
amronno is offline  
post #8 of 17 (permalink) Old 12th September 2011, 00:00
 
Car: 2007 CTR GT, Red
Join Date: 18th April 2011
Location: Glasgow, UK SCOTLAND
Posts: 45
Thanks: 0
Thanked 2 Times in 2 Posts
iTrader: (2)
Also having this issue..it is temperamental though, only occurs sometimes but when it does, it stays for that day. Pain in the arse!
ocheng100 is offline  
post #9 of 17 (permalink) Old 19th September 2011, 10:37
Supporter
 
Clive242's Avatar
 
Car: 2008MY 1.8ES, Galaxy Grey
Join Date: 30th October 2007
Location: Lost in 1983 ENGLAND
Posts: 144
Thanks: 20
Thanked 3 Times in 3 Posts
iTrader: (0)
Sounds like I have the same issue. The CD/Climate Control/Clock display will either be blank, hang or show a corrupted mess of LCD segments.

The car has been back to the dealer 4 times over the last 6 months. Three times the connections have been checked and it's been ok for a while. Last Tuesday the whole unit was replaced (£360 part), and the problem came back again yesterday.

About to ring Honda, but any suggestions more than welcome.

Cheers
Clive242 is offline  
post #10 of 17 (permalink) Old 19th September 2011, 11:18
Supporter
 
onweed's Avatar
 
Join Date: 21st June 2009
Location: Elmpt, Germany DE
Posts: 1,930
Thanks: 147
Thanked 112 Times in 103 Posts
iTrader: (1)
An easy thing you can try, probably wont work but worth a try.

Disconnect the battery, go have a cup of tea or whatever and put the negative back on.

Seems to resolve any things I get.
onweed is offline  
post #11 of 17 (permalink) Old 19th September 2011, 12:43
Banned
 
Jpetrie's Avatar
 
Car: 2008 2.2 NHB Type S GT
Join Date: 11th March 2011
Location: Southampton GB
Posts: 1,929
Thanks: 169
Thanked 290 Times in 219 Posts
iTrader: (7)
Quote:
Originally Posted by onweed View Post
An easy thing you can try, probably wont work but worth a try.

Disconnect the battery, go have a cup of tea or whatever and put the negative back on.

Seems to resolve any things I get.
Would it fix a hole in the exhaust by any chance?
Jpetrie is offline  
post #12 of 17 (permalink) Old 19th September 2011, 12:47
Unofficial Trader
 
dablink's Avatar
 
Car: CRV Urban Titanium
Join Date: 7th August 2009
Location: London, UK GB
Posts: 1,295
Thanks: 207
Thanked 163 Times in 153 Posts
iTrader: (13)
Quote:
Originally Posted by Jpetrie View Post
Would it fix a hole in the exhaust by any chance?
dablink is offline  
post #13 of 17 (permalink) Old 19th September 2011, 14:12
Supporter
 
onweed's Avatar
 
Join Date: 21st June 2009
Location: Elmpt, Germany DE
Posts: 1,930
Thanks: 147
Thanked 112 Times in 103 Posts
iTrader: (1)
Quote:
Originally Posted by Jpetrie View Post
Would it fix a hole in the exhaust by any chance?
No but gun gum will. Used that to seal my decat pipe to the exhaust. Worked a treat.
onweed is offline  
post #14 of 17 (permalink) Old 26th September 2011, 11:25
Supporter
 
Clive242's Avatar
 
Car: 2008MY 1.8ES, Galaxy Grey
Join Date: 30th October 2007
Location: Lost in 1983 ENGLAND
Posts: 144
Thanks: 20
Thanked 3 Times in 3 Posts
iTrader: (0)
Quote:
Originally Posted by onweed View Post
Disconnect the battery, go have a cup of tea or whatever and put the negative back on..
Good idea, but I'm hoping for a permanent fix.

My dealer has had the car back and investigated. It's not the display unit, or the cabling, so apparently it must be the stereo unit. Everything displayed on the screen is driven by the stereo.

Cheers
Clive242 is offline  
post #15 of 17 (permalink) Old 29th September 2011, 12:41
 
ThePurifier's Avatar
 
Car: 2009 VW Scirocco GT 2.0TSI
Join Date: 14th March 2010
Location: Lincolnshire, UK ENGLAND
Posts: 179
Thanks: 5
Thanked 8 Times in 8 Posts
iTrader: (0)
I was having some problems with mine earlier in the year but thankfully seems to be ok at the minute. I got quoted at £848.99 from Honda (exc VAT and fitting) for a replacement HU
ThePurifier is offline  
post #16 of 17 (permalink) Old 29th September 2011, 12:48
Bog
Supporter
 
Bog's Avatar
 
Car: 2016 CR-V 1.6 160 4WD
Join Date: 5th October 2006
Location: Radlett, Hertfordshire GB
Posts: 6,455
Thanks: 281
Thanked 851 Times in 676 Posts
iTrader: (34)
Eco display
Quote:
Originally Posted by onweed View Post
No but gun gum will. Used that to seal my decat pipe to the exhaust. Worked a treat.
I read that too quick... was thinking... what's 'but gum' oh er
Bog is offline  
post #17 of 17 (permalink) Old 2nd September 2013, 09:40
 
Iiyama's Avatar
 
Car: 2007 1.8 Type-S, NHB
Join Date: 23rd November 2010
Location: Ljubljana, SLO SI
Posts: 25
Thanks: 0
Thanked 2 Times in 2 Posts
iTrader: (0)
ok im trying to get behind the screen but cant remove it My screen doest this thing but i know that the connector behind it is doing these problems just cant get to it to fix it. Anyone know how to remove it?
Iiyama is offline  
Reply

  Civinfo > 8th Generation Euro Honda Civic (2006 - 2011) > Electronics (8G)

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Civinfo forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
Your User Name is the name that appears by all your posts on the forum, and so should not be your email address.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
Head Unit radio display STINGA Ipods, MP3 Players and ICE (8G) 2 14th October 2010 14:28
Electrics Radio LED Display Nighthawk08 Bugs, faults and irritations (8G) 1 5th August 2010 22:11
Head Unit non OEM radio and display TechnoTools Ipods, MP3 Players and ICE (8G) 6 15th November 2007 03:00
Radio/CD display Lozza General Discussion (8G) 0 25th March 2007 21:26

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome