Computer PGM-FI code enquiry - Civinfo
 
LinkBack Thread Tools
post #1 of 11 (permalink) Old 2nd March 2011, 19:58 Thread Starter
 
Join Date: 2nd March 2011
Location: Coventry, UK GB
Posts: 4
Thanks: 1
Thanked 0 Times in 0 Posts
iTrader: (0)
PGM-FI code enquiry

I've just collected my 2008 Civic 2.2 diesel from a body shop after some panel repairs and as I drove away I saw an error code in the display "PGM-FI". The message was not there before the car went in for the panel repair, and there's no reason I can think of for it the engine management system to have suddenly deteriorated as a result of the wing / bonnet / bumper trim replacement it has had. It's too late a night to return it to the body shop, but can anyone suggest a causal link? Could it be a failure to properly reconnect the battery earth lead? Any ideas? I can imagine the body shop shrugging and saying that it's not a body issue ...
MrAlpen is offline  
Sponsored Links
Advertisement
 
post #2 of 11 (permalink) Old 2nd March 2011, 20:03
Supporter
 
Car: Mazda MX-5 (lightly modded)
Join Date: 1st July 2007
Location: GB GB
Posts: 15,644
Thanks: 1,166
Thanked 1,546 Times in 1,415 Posts
iTrader: (8)
Its probably due to the battery being disconnected
robbo51 is offline  
post #3 of 11 (permalink) Old 2nd March 2011, 20:09 Thread Starter
** Thread starter **
 
Join Date: 2nd March 2011
Location: Coventry, UK GB
Posts: 4
Thanks: 1
Thanked 0 Times in 0 Posts
iTrader: (0)
Sound plausible, Robbo51 - but are you suggesting that there's damage, or just that the battery disconnect / reconnect can randomly confuse the fault diagnosis system, and a repeat disconnect / reconnect would likely fix it?
MrAlpen is offline  
 
post #4 of 11 (permalink) Old 2nd March 2011, 20:23
Supporter
 
Car: Mazda MX-5 (lightly modded)
Join Date: 1st July 2007
Location: GB GB
Posts: 15,644
Thanks: 1,166
Thanked 1,546 Times in 1,415 Posts
iTrader: (8)
The manual tells you how to remove the "PGM-FI" mesage
If I remember, you turn the ignition on and off again 3 times at 30 second intervals...It may take several attempts but it does work
robbo51 is offline  
Thank You to robbo51 from 2 Users:
post #5 of 11 (permalink) Old 3rd March 2011, 19:08 Thread Starter
** Thread starter **
 
Join Date: 2nd March 2011
Location: Coventry, UK GB
Posts: 4
Thanks: 1
Thanked 0 Times in 0 Posts
iTrader: (0)
Sadly could not clear it this way. The body shop is supposed to be sending out some kind of auto electrical bod to look at it.
MrAlpen is offline  
post #6 of 11 (permalink) Old 4th March 2011, 21:38
The Talented Mr. Robbieee
 
Robbieee's Avatar
 
Car: Ford Fiesta Zetec S
Join Date: 28th September 2007
Location: Glasvegas SCOTLAND
Posts: 3,295
Thanks: 105
Thanked 135 Times in 132 Posts
iTrader: (14)
That error message is a engine management fuel injection error. Have you chipped your civic or had it remapped? Sure they didnt take your car out and "kane" it to the limits?
Robbieee is offline  
post #7 of 11 (permalink) Old 4th March 2011, 22:51 Thread Starter
** Thread starter **
 
Join Date: 2nd March 2011
Location: Coventry, UK GB
Posts: 4
Thanks: 1
Thanked 0 Times in 0 Posts
iTrader: (0)
The electronics guy who came out with a diagnostic unit today read an error code reporting a damaged aircon sensor ... the sensor is right at the front of the right longit, which puts it into the damage zone from the accident that the body shop were repairing (some numpty reversed out of a side road into the car as my wife was driving past). So it sort-of fits ... the sensor looks ok, but I guess it took a bit of a slap in the accident. Anyway, seems like it'll need to be replaced. Odd that the error was this PGM-FI: seems a bit of a catch-all if it's flagging aircon sensor errors ... unless there's more than one fault here of course.
MrAlpen is offline  
post #8 of 11 (permalink) Old 6th June 2011, 13:22
 
Join Date: 6th June 2011
Location: Greenock GB
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader: (0)
Hi Guys,

I have a Honda Civic 2008 model CDTi,

I have when to to urn on the engine today and when I turned the key before hitting the start button I have a error PGM-FI on the dial.
I do not have a clue about cars or what this means. I have read numerous posts and not too sure what I can or should do with it. I did start the engine and it was fine, im really worried about this and any help wpuld be greatly appreciated.
jambof1985 is offline  
post #9 of 11 (permalink) Old 6th June 2011, 13:29
Supporter
 
NoNumpty's Avatar
 
Car: 2008 2.2 i-CTDi ES NHB
Join Date: 20th May 2008
Location: Cheshire UK GB
Posts: 4,106
Thanks: 59
Thanked 347 Times in 331 Posts
iTrader: (0)
Quote:
Originally Posted by jambof1985 View Post
Hi Guys,

I have a Honda Civic 2008 model CDTi,

I have when to to urn on the engine today and when I turned the key before hitting the start button I have a error PGM-FI on the dial.
I do not have a clue about cars or what this means. I have read numerous posts and not too sure what I can or should do with it. I did start the engine and it was fine, im really worried about this and any help wpuld be greatly appreciated.
Does your aircon work OK? - try both hot and cold temperatures to make sure it's blowing the correct air

Have you tried resetting the error as robbo51 suggested?
NoNumpty is offline  
post #10 of 11 (permalink) Old 5th July 2012, 16:57
 
Join Date: 28th April 2012
Location: Malta MT
Posts: 37
Thanks: 0
Thanked 1 Time in 1 Post
iTrader: (0)
Hi Guys,

I know that this post is a little bit old now, but today when I was going to work, half-way this error had occurred, I did not touch anything and surely I did not disconnected the battery leads, I've checked the a/c too as suggested by NoNumpty, and its OK,

Can anyone give me a clue or help me out from where or what should I check more, I hope this is not a huge problem since I bought my car only 4 months ago having 80,000 miles!! :/
Anglu is offline  
post #11 of 11 (permalink) Old 15th November 2016, 06:31
 
Join Date: 15th November 2016
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader: (0)
I have a Honda civic 2002 that shows the engine light and flicking of the battery occasssionaly. am not sure of cars
Dailes is offline  
Reply

  Civinfo > 8th Generation Euro Honda Civic (2006 - 2011) > Electronics (8G)

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Civinfo forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
Your User Name is the name that appears by all your posts on the forum, and so should not be your email address.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



  LinkBacks (?)
LinkBack to this Thread: https://www.civinfo.com/forum/electronics-8g/52359-pgm-fi-code-enquiry.html
Posted By For Type Date
Forums CivicYume - Consulter le sujet - Erreur tableau de bord This thread Refback 24th July 2013 08:45
Forums CivicYume • Consulter le sujet - Erreur tableau de bord This thread Refback 23rd June 2011 10:55

Similar Threads
Thread Thread Starter Forum Replies Last Post
Colour Code Nighthawk Black ? (ral code) xon General Discussion (8G) 4 21st October 2015 20:13
to code or not to code.. that's the question Man in Black Styling (8G) 8 18th July 2010 22:02
Servicing Just a quick service enquiry Boogle Buying, Dealers and Servicing 2 17th September 2009 21:49

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome