Speedo If your speedo goes off . . . . . - Civinfo
 
LinkBack Thread Tools
post #1 of 4 (permalink) Old 13th November 2011, 13:53 Thread Starter
 
Join Date: 12th April 2008
Location: Durham, UK ENGLAND
Posts: 2
Thanks: 0
Thanked 1 Time in 1 Post
iTrader: (0)
If your speedo goes off . . . . .

The whole top instrument cluster on my Type-R went blank yesterday so I did what I normally do .. panic. After checking all of the fuses & not finding any blown I then spent a restless evening worrying about how much a new instrument cluster was going to cost me. This morning I reset the ECU by disconnecting the battery -ve for an hour or so and lo and behold the instrument cluster is alive and working fine. Hope this helps anyone who has the same problem in the future. Thanks for the great info. on this forum, Rob
RobPP is offline  
Thanks to RobPP from:
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 13th November 2011, 16:54
everythings upsy daisy.
 
harhay's Avatar
 
Car: 08 silver CTR
Join Date: 4th May 2011
Location: Gloucester GB
Posts: 1,442
Thanks: 63
Thanked 169 Times in 158 Posts
iTrader: (0)
good to know as I have heard the cluster are mega amounts!!
harhay is offline  
post #3 of 4 (permalink) Old 15th November 2011, 10:29 Thread Starter
** Thread starter **
 
Join Date: 12th April 2008
Location: Durham, UK ENGLAND
Posts: 2
Thanks: 0
Thanked 1 Time in 1 Post
iTrader: (0)
Bad news .. looks like the fix isn't permanent. The display turned itself off again this morning.
RobPP is offline  
 
post #4 of 4 (permalink) Old 30th December 2011, 17:01
Supporter
 
Car: TypeR 09, Black
Join Date: 6th September 2010
Location: Bristol GB
Posts: 33
Thanks: 1
Thanked 4 Times in 4 Posts
iTrader: (0)
Was it just the Speedo part?

RobPP

I've just posted a related query here http://www.civinfo.com/forum/electro...asionally.html

Have you resolved?

Regards
HaydnD is offline  
Reply

  Civinfo > 8th Generation Euro Honda Civic (2006 - 2011) > Electronics (8G)

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Civinfo forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
Your User Name is the name that appears by all your posts on the forum, and so should not be your email address.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
Speedo Digital Speedo GlenMH Electronics (8G) 16 8th June 2014 15:31
Speedo Speedo issue ryeboi76 Electronics (8G) 3 30th September 2010 18:16
Speedo Speedo Windlepoons Electronics (8G) 17 16th September 2009 18:17
Speedo speedo briang Electronics (8G) 1 9th September 2006 20:27
Speedo Speedo Charles_Harding Electronics (8G) 9 25th August 2006 00:08

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome