DVD/CD EJECTED - BAD DISC - 2012 MK9 Diesel - Civinfo
Reply
 
LinkBack Thread Tools
post #1 of 22 (permalink) Old 4th July 2017, 13:20 Thread Starter
 
Car: 2012 2.2 Milano Red
Join Date: 8th March 2015
Location: Manchester GB
Posts: 343
Thanks: 99
Thanked 26 Times in 21 Posts
iTrader: (0)
DVD/CD EJECTED - BAD DISC - 2012 MK9 Diesel

I've got this on the General Discussion but realise this is the most appropriate section

All of a sudden CDs are ejected and I get ' Bad Disc ' when I insert a Music CD. Tried other discs with the same result. Happens with the original dscs as well as burnt ones. All the other functions. hard drive, radio, sat nav etc are fine.

Oddly enough I had the brake fluid changed by a Honda Dealer four days ago. It had been working previously and this is the first time I have used it since. I appreciate that there is no connection between the two of course, but wonder whether it has been interfered with..

I've had one response with the suggestion to use a DVD head cleaner, but that is not a solution because it immediately ejects the cleaning disc just as it does the playing discs and throws up the 'Bad Disc' fault. Additionally I realise that the DVD motor is running without there being a disc in place,.

I've spoke to the Honda Service Manager and of course despite it being such a coincidence they will not acknowledge any connection, but have offered to rund a diagnosis to see whether it will throw anything up. I wonder what the Honda data base has to say on the subject?.

Anyone any experience of this please?
poor1 is offline  
Sponsored Links
Advertisement
 
post #2 of 22 (permalink) Old 4th July 2017, 14:11
 
icivic06's Avatar
 
Join Date: 15th January 2009
Location: birmingham ENGLAND
Posts: 216
Thanks: 81
Thanked 3 Times in 3 Posts
iTrader: (0)
Maybe they disturbed a wire when they were servicing you be surprised how things are linked never know , maybe take battery out some sort of system reset might help. Just saying also have you managed to get DVD working while driving?


Sent from my iPhone using Tapatalk
icivic06 is offline  
post #3 of 22 (permalink) Old 4th July 2017, 15:50 Thread Starter
** Thread starter **
 
Car: 2012 2.2 Milano Red
Join Date: 8th March 2015
Location: Manchester GB
Posts: 343
Thanks: 99
Thanked 26 Times in 21 Posts
iTrader: (0)
I suppose it's possible they disturbed something, but I have a vague recollection of something being different around the unit when I picked it up, but it was not significant at the time and I have a feeling that it might have been something physical. Just too much of a coincidence. This is the trouble entrusting your car to someone else.

I picked up on another forum that a reboot might make it itself if I disconnected the fuse for that circuit, but rather than take the chance of introducing another problem I've disconnected the battery instead and so am waiting see what happens when I reconnect.

As regards viewing the DVD - sorry worked perfectly when stationary and I never tried to change it to work on the move.

How sympathetic are Honda to situations such as this? Is it too much to expect that there could be some goodwill?

Last edited by poor1; 4th July 2017 at 15:55.
poor1 is offline  
 
post #4 of 22 (permalink) Old 4th July 2017, 16:14
 
icivic06's Avatar
 
Join Date: 15th January 2009
Location: birmingham ENGLAND
Posts: 216
Thanks: 81
Thanked 3 Times in 3 Posts
iTrader: (0)
Quote:
Originally Posted by poor1 View Post
I suppose it's possible they disturbed something, but I have a vague recollection of something being different around the unit when I picked it up, but it was not significant at the time and I have a feeling that it might have been something physical. Just too much of a coincidence. This is the trouble entrusting your car to someone else.

I picked up on another forum that a reboot might make it itself if I disconnected the fuse for that circuit, but rather than take the chance of introducing another problem I've disconnected the battery instead and so am waiting see what happens when I reconnect.

As regards viewing the DVD - sorry worked perfectly when stationary and I never tried to change it to work on the move.

How sympathetic are Honda to situations such as this? Is it too much to expect that there could be some goodwill?


Absolutely tweet about it mate sometimes works, do keep us posted


Sent from my iPhone using Tapatalk
icivic06 is offline  
post #5 of 22 (permalink) Old 4th July 2017, 16:14 Thread Starter
** Thread starter **
 
Car: 2012 2.2 Milano Red
Join Date: 8th March 2015
Location: Manchester GB
Posts: 343
Thanks: 99
Thanked 26 Times in 21 Posts
iTrader: (0)
Worst case scenario and I have to replace the unit with a seconds hand unit :

Two questions:

1. How to get the ECU to recognise the unit from another vehicle

2. Will units from all Mk9 Civics be compatible or were there changes made during the production run?. Mine is a 2012 model.
poor1 is offline  
post #6 of 22 (permalink) Old 4th July 2017, 16:26
 
icivic06's Avatar
 
Join Date: 15th January 2009
Location: birmingham ENGLAND
Posts: 216
Thanks: 81
Thanked 3 Times in 3 Posts
iTrader: (0)
Quote:
Originally Posted by poor1 View Post
Worst case scenario and I have to replace the unit with a seconds hand unit :



Two questions:



1. How to get the ECU to recognise the unit from another vehicle



2. Will units from all Mk9 Civics be compatible or were there changes made during the production run?. Mine is a 2012 model.


I'm guessing ecu should pick up the unit as it's factory fitted of you buy second hand best to have similar I know some got premium written and some don't


Sent from my iPhone using Tapatalk
icivic06 is offline  
post #7 of 22 (permalink) Old 4th July 2017, 17:00 Thread Starter
** Thread starter **
 
Car: 2012 2.2 Milano Red
Join Date: 8th March 2015
Location: Manchester GB
Posts: 343
Thanks: 99
Thanked 26 Times in 21 Posts
iTrader: (0)
Quote:
Originally Posted by icivic06 View Post
I'm guessing ecu should pick up the unit as it's factory fitted of you buy second hand best to have similar I know some got premium written and some don't


Sent from my iPhone using Tapatalk
Sorry I don't understand exactly what you mean.

I would try to get hold of a unit off an identical car, but I don't know whether the units are interchangeable throughout the MK 9 range. Mine is 2012. Was there a change in 2013 or later?.

The reboot theory did not work. I disconnected the battery for over two hours and it's exactly the same as it was.
poor1 is offline  
post #8 of 22 (permalink) Old 4th July 2017, 17:25
Administrator
 
Kremmen's Avatar
 
Car: MY13 1.8 EX Auto
Join Date: 7th January 2007
Location: West London ENGLAND
Posts: 20,944
Thanks: 857
Thanked 1,708 Times in 1,431 Posts
iTrader: (0)
Eco display Eco display
Garage
I've never used my CD player. I use a USB stick instead.

I wouldn't be too sure you can just plug another one in without dealer help. I think they are VIN coded.

I'd be asking them exactly what they did under the circumstances.
Kremmen is offline  
post #9 of 22 (permalink) Old 4th July 2017, 19:05 Thread Starter
** Thread starter **
 
Car: 2012 2.2 Milano Red
Join Date: 8th March 2015
Location: Manchester GB
Posts: 343
Thanks: 99
Thanked 26 Times in 21 Posts
iTrader: (0)
Quote:
Originally Posted by Kremmen View Post
I've never used my CD player. I use a USB stick instead.

I wouldn't be too sure you can just plug another one in without dealer help. I think they are VIN coded.

I'd be asking them exactly what they did under the circumstances.
I have asked the service manager but of course they deny any knowledge.

I would be quite happy to use a USB stick but the associated problem with the 'Bad Disc' problem is that the CD Unit is acting peculiarly and I can hear the motor whissing away when there is no disc there because it immediately ejects them.

I'll certainly try to find out about whether the VIN coding is involved in swapping one from another car. I wonder whether that could be hone with the Honda HDS Diagnostic tool. Any ideas would be helpful. Thanks.
poor1 is offline  
post #10 of 22 (permalink) Old 4th July 2017, 20:35 Thread Starter
** Thread starter **
 
Car: 2012 2.2 Milano Red
Join Date: 8th March 2015
Location: Manchester GB
Posts: 343
Thanks: 99
Thanked 26 Times in 21 Posts
iTrader: (0)
I've now bought a second hand unit for my 2012 Honda Civic diesel exec. Can anyone tell me specifically how to remove the existing Sat Nav/DVD Unit please.

I have a 2006 to 2011 Haynes but that is quite different.
poor1 is offline  
post #11 of 22 (permalink) Old 5th July 2017, 05:00
Administrator
 
Kremmen's Avatar
 
Car: MY13 1.8 EX Auto
Join Date: 7th January 2007
Location: West London ENGLAND
Posts: 20,944
Thanks: 857
Thanked 1,708 Times in 1,431 Posts
iTrader: (0)
Eco display Eco display
Garage
If it's whirring away with no CD then what have they pushed in there would be my first thought.

Not the first time that's happened but usually a child. Got a torch.
Kremmen is offline  
Thanks to Kremmen from:
post #12 of 22 (permalink) Old 5th July 2017, 08:34 Thread Starter
** Thread starter **
 
Car: 2012 2.2 Milano Red
Join Date: 8th March 2015
Location: Manchester GB
Posts: 343
Thanks: 99
Thanked 26 Times in 21 Posts
iTrader: (0)
You could be right. Thanks for the suggestion.

Anyone assist with getting the old unit out please. Which panels need removing to get access. Any exploded drawing in existance. Any Honda workshop manuals?


Many thanks
poor1 is offline  
post #13 of 22 (permalink) Old 15th July 2017, 11:56 Thread Starter
** Thread starter **
 
Car: 2012 2.2 Milano Red
Join Date: 8th March 2015
Location: Manchester GB
Posts: 343
Thanks: 99
Thanked 26 Times in 21 Posts
iTrader: (0)
Now replaced and working fine. See my 'How To' for instructions.

After replacing with integrated unit from another vehicle it will need re-coding by a Honda dealer for a nominal charge.

It's an expensive exercise and hope it doesn't happen again.
poor1 is offline  
post #14 of 22 (permalink) Old 15th July 2017, 11:59
Administrator
 
Kremmen's Avatar
 
Car: MY13 1.8 EX Auto
Join Date: 7th January 2007
Location: West London ENGLAND
Posts: 20,944
Thanks: 857
Thanked 1,708 Times in 1,431 Posts
iTrader: (0)
Eco display Eco display
Garage
Can you now get inside the original one to see any issues ?
Kremmen is offline  
post #15 of 22 (permalink) Old 15th July 2017, 12:43 Thread Starter
** Thread starter **
 
Car: 2012 2.2 Milano Red
Join Date: 8th March 2015
Location: Manchester GB
Posts: 343
Thanks: 99
Thanked 26 Times in 21 Posts
iTrader: (0)
Quote:
Originally Posted by Kremmen View Post
Can you now get inside the original one to see any issues ?
It's probably a mechanical problem within the DVD player. I think it's possible to have a look by removing the top cover but I have not tried as yet.

I did wonder whether it would have been possible to disable the DVD part of the head unit by removing one of the plugs at the back of the unit and thereby continuing to use the Sat Nav, Reverse camera and all the other associated features. As you suggested earlier using a USB instead of the DVD. Leaving as it was was not an option for me because I could not have lived with the Bad Disc nag which was thrown up each time the ignition was turned on.
poor1 is offline  
post #16 of 22 (permalink) Old 15th July 2017, 14:34
Administrator
 
Kremmen's Avatar
 
Car: MY13 1.8 EX Auto
Join Date: 7th January 2007
Location: West London ENGLAND
Posts: 20,944
Thanks: 857
Thanked 1,708 Times in 1,431 Posts
iTrader: (0)
Eco display Eco display
Garage
Given that it only started playing up after a service I wondered whether you could see if anything got poked in there. Does it rattle now it's out.
Kremmen is offline  
post #17 of 22 (permalink) Old 15th July 2017, 17:40 Thread Starter
** Thread starter **
 
Car: 2012 2.2 Milano Red
Join Date: 8th March 2015
Location: Manchester GB
Posts: 343
Thanks: 99
Thanked 26 Times in 21 Posts
iTrader: (0)
Nothing rattling.

FYI: The part number shows it to be an Alpine Unit (or replacement) which are available from the Far East for between $65-$120 so that is an option so long as it is an exact match. The part numbers match exactly pictures of the unit look identical.

https://www.aliexpress.com/item/Orig...812418444.html

Honda estimated 300-400 for a repair which would of course have included removing and fitting.

Last edited by poor1; 15th July 2017 at 17:45.
poor1 is offline  
post #18 of 22 (permalink) Old 25th July 2017, 00:14
Supporter
 
Haltamer's Avatar
 
Car: 9th Gen 1.4 Petrol SE + Navi
Join Date: 13th March 2017
Location: Essex, UK GB
Posts: 2,022
Thanks: 47
Thanked 294 Times in 264 Posts
iTrader: (3)
Garage
The car probably doesn't share your taste in music; "Bad Disc"
Haltamer is offline  
Thanks to Haltamer from:
post #19 of 22 (permalink) Old 26th July 2017, 21:35
I Hate tailgaters!
 
Red Dwarf's Avatar
 
Car: 2016 1.6 SR Lunar Silver
Join Date: 11th December 2011
Location: Blackpool, UK ENGLAND
Posts: 1,334
Thanks: 12
Thanked 105 Times in 101 Posts
iTrader: (0)
Eco display Eco display
Garage
Makes you wonder if the maintenance staff put their own disc in to listen to during the service but someone had contaminated paws thats affected inside your player .... maybe.

Have you tried resetting the player, master reset button ??
Red Dwarf is offline  
post #20 of 22 (permalink) Old 28th July 2017, 09:00
Supporter
 
Car: 2008 1.8 GT Type S
Join Date: 14th May 2010
Location: Yorkshire ENGLAND
Posts: 3,216
Thanks: 485
Thanked 306 Times in 271 Posts
iTrader: (2)
Quote:
Originally Posted by poor1 View Post
It's probably a mechanical problem within the DVD player. I think it's possible to have a look by removing the top cover but I have not tried as yet.

I did wonder whether it would have been possible to disable the DVD part of the head unit by removing one of the plugs at the back of the unit and thereby continuing to use the Sat Nav, Reverse camera and all the other associated features. As you suggested earlier using a USB instead of the DVD. Leaving as it was was not an option for me because I could not have lived with the Bad Disc nag which was thrown up each time the ignition was turned on.
The Laser inside is NOT usually Eye Safe, and it's can be invisible so under no circumstances have it connected to any power or power it up when you open it.

The casing will say Class I which is eye safe but that's only because they classify it as safe because it's encased. The actual laser itself can be as high as Class III.

So far as the issue is concerned, it's typical symptoms of a failing laser module as the laser reads the disc and if the laser is becoming weak then when it's unable to read the disc, it will reject it as a bad disc. However, if it's doing this over multiple known good discs, then it's more likely the laser that's unable to read the discs, than the discs that are unreadable.

I highly doubt any other kind of mechanical issue. If it spins the disc on insertion, then rejects it, it's probably the laser.

Last edited by RA108; 28th July 2017 at 09:03.
RA108 is offline  
Thanks to RA108 from:
Reply

  Civinfo > 9th Generation Euro Honda Civic (2012 - 2016) > Electronics and ICE (9G)

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Civinfo forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
Your User Name is the name that appears by all your posts on the forum, and so should not be your email address.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
Questions MK9 2.2d 2012 where to MOT Blackburn - under Honda Approved warranty? mchu6am4 Buying, Dealers and Servicing 4 27th May 2016 10:23
MK9 or MK8 diesel? ched999uk General Discussion (9G) 17 16th January 2016 18:30
MK8 or MK9 diesel? ched999uk General Discussion (8G) 27 14th January 2016 08:04

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome