Performance 2.2 turbo issue? - Civinfo
 
LinkBack Thread Tools
post #1 of 11 (permalink) Old 19th February 2014, 19:29 Thread Starter
Supporter
 
rizlaw's Avatar
 
Car: 2006 2.2 ICDTI SPORT 5DR RED
Join Date: 24th June 2013
Location: Nottingham GB
Posts: 146
Thanks: 11
Thanked 7 Times in 6 Posts
iTrader: (2)
Smile 2.2 turbo issue?

Hi guys my 2.2 is having a sproadic turbo issue.

2 times on motorway when i ragged the crap out of it i got limp mode both times it was overboost which i reset on the fly.

but it also on random occasions has a problem where it spools but no turbo effect at all . then sometimes it just kick in

80% time it working fine.

not clutch and allegdly lookers put a new boost conrol module 6 month ago

any tips on testing etc will be helpful.

i have used odb and measure egr response which seem to be instant but then again i dont know exactly what to look for
rizlaw is offline  
Sponsored Links
Advertisement
 
post #2 of 11 (permalink) Old 19th February 2014, 19:34
Supporter
 
Stezwin's Avatar
 
Join Date: 31st October 2013
Location: Chatham kent ENGLAND
Posts: 448
Thanks: 86
Thanked 51 Times in 45 Posts
iTrader: (0)
I think mine sometimes suffers from severe turbo lag when changing gear at high speeds then foot down and .... Nothing
Stezwin is offline  
post #3 of 11 (permalink) Old 19th February 2014, 19:50 Thread Starter
Supporter
** Thread starter **
 
rizlaw's Avatar
 
Car: 2006 2.2 ICDTI SPORT 5DR RED
Join Date: 24th June 2013
Location: Nottingham GB
Posts: 146
Thanks: 11
Thanked 7 Times in 6 Posts
iTrader: (2)
mines fine in high speed but can overboost but only after boosting for 10 seconds which is plenty
rizlaw is offline  
 
post #4 of 11 (permalink) Old 19th February 2014, 20:40
 
Chip's Avatar
 
Car: 2013 suzuki swift sport
Join Date: 5th March 2009
Location: Herts ENGLAND
Posts: 2,553
Thanks: 308
Thanked 239 Times in 222 Posts
iTrader: (0)
Time to trade in before you get a big bill?
Chip is offline  
post #5 of 11 (permalink) Old 19th February 2014, 22:52
Bye bye Honda...
 
Jon_G's Avatar
 
Car: Volvo V60 VEA D4 (181)
Join Date: 11th May 2012
Location: Ludlow, UK ENGLAND
Posts: 5,732
Thanks: 1,049
Thanked 1,263 Times in 1,040 Posts
iTrader: (1)
I think your boost actuator might be sticking. Maybe either the EVR itself or the linkage.
Jon_G is offline  
post #6 of 11 (permalink) Old 19th February 2014, 23:03
Syx
#MrGrumpy
 
Syx's Avatar
 
Car: 2008 2.2 CTS GT
Join Date: 22nd December 2009
Location: Luton, UK GB
Posts: 13,117
Thanks: 1,272
Thanked 2,657 Times in 2,260 Posts
iTrader: (94)
Eco display
Send a message via Skype™ to Syx
Quote:
Originally Posted by rizlaw View Post
mines fine in high speed but can overboost but only after boosting for 10 seconds which is plenty
How are you determining that it is overboosting?
Syx is offline  
post #7 of 11 (permalink) Old 20th February 2014, 20:37
Supporter
 
Stezwin's Avatar
 
Join Date: 31st October 2013
Location: Chatham kent ENGLAND
Posts: 448
Thanks: 86
Thanked 51 Times in 45 Posts
iTrader: (0)
Today i gave it my all in 2nd and it gave up it felt like it blew aload of **** out the back pretty sure all the rev lights came on too
Stezwin is offline  
post #8 of 11 (permalink) Old 20th February 2014, 20:43
Supporter
 
Stezwin's Avatar
 
Join Date: 31st October 2013
Location: Chatham kent ENGLAND
Posts: 448
Thanks: 86
Thanked 51 Times in 45 Posts
iTrader: (0)
Id also like anyones opinions on where to look for problems as my civic seems a little slow off the mark like i said above when changing from 3rd to 4th for about a second theres nothing from the throttle

Any ideas what i can look for
Stezwin is offline  
post #9 of 11 (permalink) Old 21st February 2014, 19:23 Thread Starter
Supporter
** Thread starter **
 
rizlaw's Avatar
 
Car: 2006 2.2 ICDTI SPORT 5DR RED
Join Date: 24th June 2013
Location: Nottingham GB
Posts: 146
Thanks: 11
Thanked 7 Times in 6 Posts
iTrader: (2)
done 500 miles in 1 day no turbo issues, i know its over boosting as i get 2 codes on obd.
rizlaw is offline  
post #10 of 11 (permalink) Old 21st February 2014, 19:24 Thread Starter
Supporter
** Thread starter **
 
rizlaw's Avatar
 
Car: 2006 2.2 ICDTI SPORT 5DR RED
Join Date: 24th June 2013
Location: Nottingham GB
Posts: 146
Thanks: 11
Thanked 7 Times in 6 Posts
iTrader: (2)
any way of unsticking the evr or the linkage.
rizlaw is offline  
post #11 of 11 (permalink) Old 21st February 2014, 19:44
Bye bye Honda...
 
Jon_G's Avatar
 
Car: Volvo V60 VEA D4 (181)
Join Date: 11th May 2012
Location: Ludlow, UK ENGLAND
Posts: 5,732
Thanks: 1,049
Thanked 1,263 Times in 1,040 Posts
iTrader: (1)
Quote:
Originally Posted by rizlaw View Post
any way of unsticking the evr or the linkage.
Linkage - WD40 and wiggling it (the grease can set hard). Or indeed the VNT mechanism can become sticky (you may be able to free this by moving the linkage?).

Apply suction to the boost actuator to see that the linkage moves. Check the release filter isn't blocked. It is possible to swap the boost control EVR over with the IMRC EVR and see if the boost problem becomes an IMRC problem instead.
Jon_G is offline  
Reply

  Civinfo > 8th Generation Euro Honda Civic (2006 - 2011) > Engines and Transmission (8G)

Tags
2.2 , civic , turbo

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Civinfo forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
Your User Name is the name that appears by all your posts on the forum, and so should not be your email address.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
1.7 ctdi turbo civic issue??? andvil13 Previous Civics 29 21st October 2015 22:10
Engine 2.2 I-CDTI Possible Turbo Issue Gremlyng Bugs, faults and irritations (8G) 31 23rd July 2013 11:21
turbo shae Cleaning 13 15th July 2012 12:31
Turbo Fn2 Louis_Scofield Type-R 16 9th July 2012 01:09
Performance Turbo lag? Mr Quay Engines and Transmission (8G) 8 3rd March 2010 20:55

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome