Air Filter Clip - Civinfo
 5Likes
  • 1 Post By canman
  • 1 Post By canman
  • 1 Post By nturnb
  • 2 Post By nturnb
 
LinkBack Thread Tools
post #1 of 17 (permalink) Old 7th July 2019, 10:43 Thread Starter
Supporter
 
Join Date: 9th December 2013
Location: Melton Mowbray GB
Posts: 906
Thanks: 10
Thanked 86 Times in 78 Posts
iTrader: (0)
Air Filter Clip

Just had car back from a service... Checking oil level etc, all good... But noticed this.... Any idea what it should look like because it doesn't seem right. Cheers Stuart
Attached Images
File Type: jpg IMG_20190707_104045_1562492577624.jpg (52.2 KB, 99 views)
cavalrystu is offline  
Sponsored Links
Advertisement
 
post #2 of 17 (permalink) Old 7th July 2019, 23:32
 
Car: 2014 1.6 DTEC 5 Door White
Join Date: 26th March 2017
Posts: 107
Thanks: 0
Thanked 7 Times in 7 Posts
iTrader: (0)
I service mine myself, and this clip is very hard to get back on without it pinging off. I did loose this clip myself (fell down the engine bay) but managed to get it back by taking off the service cover underneath. It looks like a 3 cm long black piece of plastic with a circular cutout. I will try and get a photo for you in the morning. I did run it without this clip for a week or 2 without any issues.
shaintaylor is offline  
post #3 of 17 (permalink) Old 8th July 2019, 08:53
Super Moderator
 
M8TJT's Avatar
 
Car: 10G 1.5 Civic Prestige
Join Date: 10th October 2015
Location: Bexhill, Sussex GB
Posts: 2,913
Thanks: 87
Thanked 220 Times in 212 Posts
iTrader: (1)
Are you saying that there is a plastic bit missing? @shaintaylor
M8TJT is offline  
 
post #4 of 17 (permalink) Old 8th July 2019, 09:18 Thread Starter
Supporter
** Thread starter **
 
Join Date: 9th December 2013
Location: Melton Mowbray GB
Posts: 906
Thanks: 10
Thanked 86 Times in 78 Posts
iTrader: (0)
I assume something is missing, because it just moves back and forward. I don't remember seeing it before, but it could always have been like it.... but it can't be right, because the clip doesn't do anything. I'm going to assume the dealer will resolve, but want to make sure I know what to tell them
cavalrystu is offline  
post #5 of 17 (permalink) Old 8th July 2019, 11:03
 
Car: 2014 1.6 DTEC 5 Door White
Join Date: 26th March 2017
Posts: 107
Thanks: 0
Thanked 7 Times in 7 Posts
iTrader: (0)
Yes there is a plastic clip missing. Please see the below photos -

https://imgur.com/a/X4tYzvk
shaintaylor is offline  
Thanks to shaintaylor from:
post #6 of 17 (permalink) Old 8th July 2019, 14:01 Thread Starter
Supporter
** Thread starter **
 
Join Date: 9th December 2013
Location: Melton Mowbray GB
Posts: 906
Thanks: 10
Thanked 86 Times in 78 Posts
iTrader: (0)
Well, that's a stupid design.... wonder how much that tiny piece of plastic would cost, or if the dealer will resolve. Lets see....
cavalrystu is offline  
post #7 of 17 (permalink) Old 8th July 2019, 23:28
 
Car: 2012 Civic 2.2 I-DTEC
Join Date: 17th December 2013
Location: Mayo Ireland IE
Posts: 151
Thanks: 24
Thanked 14 Times in 14 Posts
iTrader: (0)
I lost mine ages ago as well. If you get the part number could you post it please
cavalrystu likes this.
canman is offline  
post #8 of 17 (permalink) Old 2nd August 2019, 21:47
 
Car: 2012 Civic 2.2 I-DTEC
Join Date: 17th December 2013
Location: Mayo Ireland IE
Posts: 151
Thanks: 24
Thanked 14 Times in 14 Posts
iTrader: (0)
I order a replacement from ebay. Hope this works. https://www.ebay.co.uk/itm/401808838077
canman is offline  
post #9 of 17 (permalink) Old 4th September 2019, 16:27
Ex-Pat Geordie!
 
nturnb's Avatar
 
Car: 2015 Civic S Navi I-dtec
Join Date: 17th November 2013
Location: Irvine, Ayrshire GB
Posts: 2,188
Thanks: 119
Thanked 223 Times in 204 Posts
iTrader: (0)
Eco display
I lost mine last year, no issues so far.. One of the most stupid designs I've seen. Cover seems to be clamped down quite snugly by the other 3 clips.
nturnb is offline  
post #10 of 17 (permalink) Old 6th September 2019, 21:33
 
Car: 2012 Civic 2.2 I-DTEC
Join Date: 17th December 2013
Location: Mayo Ireland IE
Posts: 151
Thanks: 24
Thanked 14 Times in 14 Posts
iTrader: (0)
Quote:
Originally Posted by canman View Post
I order a replacement from ebay. Hope this works. https://www.ebay.co.uk/itm/401808838077
worked a treat if anyone is wondering
M8TJT likes this.
canman is offline  
post #11 of 17 (permalink) Old 7th September 2019, 19:16
Ex-Pat Geordie!
 
nturnb's Avatar
 
Car: 2015 Civic S Navi I-dtec
Join Date: 17th November 2013
Location: Irvine, Ayrshire GB
Posts: 2,188
Thanks: 119
Thanked 223 Times in 204 Posts
iTrader: (0)
Eco display
Just ordered one, can't grumble at that price.....
canman likes this.
nturnb is offline  
post #12 of 17 (permalink) Old 12th September 2019, 13:56
 
Join Date: 11th August 2019
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader: (0)
I hope you don't mind me jumping onto your air filter thread...


I just had a basic service done, but they told me it didn't include the air filter etc. So I bought one off the net, and just went out to change it. The existing one looked sparkling clean, exactly like the new one in the box. This is odd isn't it? I would have expected the existing one to look dirty - it hasn't been changed for 3 years as far as I know, about 15k miles.


Not sure if I should bother changing it now!
Neilzbee is offline  
post #13 of 17 (permalink) Old 12th September 2019, 14:05
Ex-Pat Geordie!
 
nturnb's Avatar
 
Car: 2015 Civic S Navi I-dtec
Join Date: 17th November 2013
Location: Irvine, Ayrshire GB
Posts: 2,188
Thanks: 119
Thanked 223 Times in 204 Posts
iTrader: (0)
Eco display
You mustn't be doing many miles then as mine looked like this after two year and Honda said it was perfectly fine hence the reason I service my own.
Attached Images
File Type: jpg Filter.jpg (67.3 KB, 29 views)
Neil11 and iMZee like this.
nturnb is offline  
post #14 of 17 (permalink) Old 14th September 2019, 12:09
 
Join Date: 11th August 2019
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader: (0)
Quote:
Originally Posted by nturnb View Post
You mustn't be doing many miles then as mine looked like this after two year and Honda said it was perfectly fine hence the reason I service my own.
Sorry, I'm not quite sure what that says in regards to my comment...

My question is, is it normal for an air filter to look completely new after 3 years of use? My experience from older cars is no, they look very dirty - but maybe this Honda just works differently and doesn't require replacing.
Neilzbee is offline  
post #15 of 17 (permalink) Old 14th September 2019, 18:53
Ex-Pat Geordie!
 
nturnb's Avatar
 
Car: 2015 Civic S Navi I-dtec
Join Date: 17th November 2013
Location: Irvine, Ayrshire GB
Posts: 2,188
Thanks: 119
Thanked 223 Times in 204 Posts
iTrader: (0)
Eco display
Quote:
Originally Posted by Neilzbee View Post
Sorry, I'm not quite sure what that says in regards to my comment...

My question is, is it normal for an air filter to look completely new after 3 years of use? My experience from older cars is no, they look very dirty - but maybe this Honda just works differently and doesn't require replacing.
The picture I posted was after 2 years and 27K miles. You said yours looked almost new after 3 years, I suggested you must have a low mileage car as my filter was absolutely filthy.. I change my oil now twice a year and the filter every second service and it is always very dirty.
nturnb is offline  
post #16 of 17 (permalink) Old 14th September 2019, 23:43
 
Car: 2012 Civic 2.2 I-DTEC
Join Date: 17th December 2013
Location: Mayo Ireland IE
Posts: 151
Thanks: 24
Thanked 14 Times in 14 Posts
iTrader: (0)
Quote:
Originally Posted by nturnb View Post
The picture I posted was after 2 years and 27K miles. You said yours looked almost new after 3 years, I suggested you must have a low mileage car as my filter was absolutely filthy.. I change my oil now twice a year and the filter every second service and it is always very dirty.

Yours is really dirty. Mine would be nothing like yours after a year. Its very black?
canman is offline  
post #17 of 17 (permalink) Old Today, 09:45 Thread Starter
Supporter
** Thread starter **
 
Join Date: 9th December 2013
Location: Melton Mowbray GB
Posts: 906
Thanks: 10
Thanked 86 Times in 78 Posts
iTrader: (0)
17219P65000 > if you need the part number
cavalrystu is offline  
Reply

  Civinfo > 9th Generation Euro Honda Civic (2012 - 2016) > General Discussion (9G)

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Civinfo forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
Your User Name is the name that appears by all your posts on the forum, and so should not be your email address.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in













Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome