Head Unit Sat nav wont display on head unit? - Civinfo
 
LinkBack Thread Tools
post #1 of 4 (permalink) Old 4th February 2014, 18:34 Thread Starter
Supporter
 
Dave-civic's Avatar
 
Car: 2008 Honda Civic Type R GT
Join Date: 20th February 2009
Location: Scotland,UK SCOTLAND
Posts: 313
Thanks: 64
Thanked 64 Times in 38 Posts
iTrader: (2)
Garage
Sat nav wont display on head unit?

Just wondering if anyone has fitted the Pioneer AVH-3500DAB head unit and the Pioneer AVIC-250F Navigation unit to their car? I've fitted both, and although I can hear the sat nav announcing speed limits etc through the speakers, I just cant get the actual map to display on the screen. I've tried all the problem/possible causes out to no avail. Anyone else experienced this?

Also, after installing the head unit, I was left with one white connector that was left with nowhere to plug into. I'm running the conversion kit for keeping the steering remote buttons in use and also the climate control screen.

Any idea why I have one connector left over, is this normal?

Also, theres a wire from the nav unit that says attach to Speed Sensor wire (if one is available), does the civic typeS (1.8 8th gen) have one? so confused and pee'd off at this not working!

Thanks

Last edited by Dave-civic; 4th February 2014 at 18:37.
Dave-civic is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 5th February 2014, 09:54
R-398
 
yasuraka's Avatar
 
Car: 2009 FN2 CW
Join Date: 15th November 2012
Location: Falkirk SCOTLAND
Posts: 702
Thanks: 74
Thanked 58 Times in 57 Posts
iTrader: (17)
Garage
Quote:
Originally Posted by Dave-civic View Post
Just wondering if anyone has fitted the Pioneer AVH-3500DAB head unit and the Pioneer AVIC-250F Navigation unit to their car? I've fitted both, and although I can hear the sat nav announcing speed limits etc through the speakers, I just cant get the actual map to display on the screen. I've tried all the problem/possible causes out to no avail. Anyone else experienced this?

Also, after installing the head unit, I was left with one white connector that was left with nowhere to plug into. I'm running the conversion kit for keeping the steering remote buttons in use and also the climate control screen.

Any idea why I have one connector left over, is this normal?

Also, theres a wire from the nav unit that says attach to Speed Sensor wire (if one is available), does the civic typeS (1.8 8th gen) have one? so confused and pee'd off at this not working!

Thanks

Ill start at the end, the speed pulse would be the pink wire from connects2 loom and would be connected to the relevant wire marked speed pulse on the pioneer loom, should be pink aswell but will be labeled anyway.

Picture was sent to me from Bob at impulse when I had a dilema about speed cable



As for why you arent getting a picture. Is there a little switch on the front of the 250F for changing resolution? Newer head units needed the higher resolution to display. Also you need to ensure that you select the proper RGB input on the head unit, there will be 2 options for this. First is iPhone and the other is Navi.
yasuraka is offline  
post #3 of 4 (permalink) Old 5th February 2014, 14:23 Thread Starter
Supporter
** Thread starter **
 
Dave-civic's Avatar
 
Car: 2008 Honda Civic Type R GT
Join Date: 20th February 2009
Location: Scotland,UK SCOTLAND
Posts: 313
Thanks: 64
Thanked 64 Times in 38 Posts
iTrader: (2)
Garage
Thanks for that Barry, much appreciated mate. I'll need to dismantle the dash again and check that speed pulse wire, and if the head unit has one I'll need to connect it up. Know it isnt connected at present. The RGB is something I'm having a lot of problems with, as it won't let me change the input. Keep getting a message on the screen saying to change it, first disconnect the Iphone. Easy, as there isnt one connected, dont have one! lol then it says make sure the devices bluetooth is off, again shouldnt be a prob as I dont have an iphone. So not sure why it isnt letting me change the settings for that, as there isnt anything else I can do apart from close the message. Really frustrating! I'll take a pic of the unused white block conector once i get the dash appart again. The white connector is part of the cars loom, and was plugged into the rear of the oem head unit.
Dave-civic is offline  
 
post #4 of 4 (permalink) Old 5th February 2014, 19:17 Thread Starter
Supporter
** Thread starter **
 
Dave-civic's Avatar
 
Car: 2008 Honda Civic Type R GT
Join Date: 20th February 2009
Location: Scotland,UK SCOTLAND
Posts: 313
Thanks: 64
Thanked 64 Times in 38 Posts
iTrader: (2)
Garage
Ok, wee update and some useful info for anyone who's thinking about this head unit and navigation unit. Contacted Pioneer as I still couldnt get this working. The guy said that when installing this, even plugging in the sat nav cable and usb cable can stop you from accessing the RGB section of the system menu, meaning you won't be able to change the settings. So after stripping everything down again, removing all cables from the head unit etc and disconnecting the sat nav altogether, I powered the head unit up. This time, was able to access the RGB setting to change them over to Navi, plugged in the sat nav and bingo, we're all up and running! Just a pitty Pioneer didn't think to actually put that bit of info in the installation instructions eh! Would have saved a lot of time and work on the install.But it's in, and now everything is set up how I want it, it sounds amazing, and the sat nav works brilliantly.
So for anyone fitting this................DON'T PLUG ANY LEADS IN (EXCEPT THE POWER/SPEAKER CABLES) UNTIL YOU HAVE SET THE RGB SETTINGS, OTHERWISE YOUR NAV UNIT WILL NOT WORK!.

Hope this helps other members
Dave-civic is offline  
Reply

  Civinfo > 8th Generation Euro Honda Civic (2006 - 2011) > Ipods, MP3 Players and ICE (8G)

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Civinfo forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
Your User Name is the name that appears by all your posts on the forum, and so should not be your email address.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
Head Unit New head unit 7even_up Ipods, MP3 Players and ICE (8G) 22 27th March 2013 05:29
Other Aftermarket head up display? webby Electronics (8G) 6 16th January 2012 16:41
Head Up Display Front Plastic mastermindmark General Discussion (8G) 20 20th September 2008 17:04
Other Head up Display (merged) Maldax Electronics (8G) 27 18th May 2007 08:01

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome