Amplifier Please Someone Help! - Civinfo
 
LinkBack Thread Tools
post #1 of 2 (permalink) Old 12th April 2008, 14:00 Thread Starter
Civinfo's Bulb Supplier
 
Mr JP's Avatar
 
Join Date: 2nd February 2007
Location: Kent, UK ENGLAND
Posts: 13,427
Thanks: 553
Thanked 1,431 Times in 1,328 Posts
iTrader: (217)
Please Someone Help!

Ive just installed my amp to run my powerful rear speakers, only when I turn the ignition on there is interference heard through the speakers, this then gets louder when I start the car and when I rev the engine it goes up with the revs, it's like a hissing/whistling.

My dad reckons its lack of supression on my alternator?

Is this right?, any one else had it?

AND most importantly how do I FIX it because I cant drive round like this!


thankyou for any responses,

JP
Mr JP is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 12th April 2008, 14:32
FWH
Supporter
 
FWH's Avatar
 
Car: MX-5, C6 Vette & MB S212
Join Date: 3rd June 2007
Location: Where Polar Bears roam the streets SE
Posts: 22,623
Thanks: 558
Thanked 1,029 Times in 772 Posts
iTrader: (1)
FWH is offline  
Reply

  Civinfo > 8th Generation Euro Honda Civic (2006 - 2011) > Ipods, MP3 Players and ICE (8G)

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Civinfo forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
Your User Name is the name that appears by all your posts on the forum, and so should not be your email address.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome