Civinfo - Reply to Topic
Thread: Electrics My car just had a stroke and I am about too Reply to Thread
Title:
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :
Post Icons
You may choose an icon for your message from the following list:
 

Register Now



In order to be able to post messages on the Civinfo forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
Your User Name is the name that appears by all your posts on the forum, and so should not be your email address.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










  Additional Options
Miscellaneous Options

  Topic Review (Newest First)
9th March 2019 13:54
A3756 Quick update: Battery was fine, but alternator burned down (quite literally). All good now.
3rd March 2019 11:54
RA108 You can buy a battery tester than also tests the alternator for around a tenner:

https://www.amazon.co.uk/Laser-2274-...battery+tester

I've got one like this, but there are plenty to choose from and some even cheaper. All you need is something that can indicate both the battery and alternator state. BTW to test the alternator, you'll need to be able to get the car to start. The battery can be tested with the car switched off.
3rd March 2019 11:27
cosmicma things to check

battery voltage

alternator

earthing straps on body and engine

the symptoms you describe sounds like a failing alternator , dead battery or both
3rd March 2019 10:09
cb550 Had same issue with an Alfa once. AA turned up, confirmed the alternator had packed up, got me back home on a low loader. Had an extended warranty so got it fixed for free.

If you're not practically minded car wise to carry out some diagnostic checks, a reliable garage of your choice should pretty quickly determine the actual cause.......
2nd March 2019 19:33
A3756
My car just had a stroke and I am about too

Today as I was driving, I've noticed an unusual humming sound coming from inside the engine bay and wasn't sure what could it be. I had places to be, so just ignored it with intention to check later.

Half a day later, as I was about to head back home, I started turning around in a tight parking lot and as I spun my wheels a loud 'crack' came from the engine bay and VSA error followed by ABS light came up. "Sensor broke again" I thought, since I had that happen to every car I've owned so far, and continued my journey.

Five minutes later the VSA & ABS lights started blinking accompanied by the ding sound and started to annoy me. Few more minutes later power steering error came up and suddenly I was barely able to move the steering wheel and had to go really slow. As I was looking for an empty parking lot around, to dump the car for the night, the 'Grand Finale' started: All the dash lights started blinking, all the possible errors were showing up, headlights started flashing (as I was in the middle of the road on a late evening), blinkers blinking, radio got possessed, tachometer went crazy, basically everything electric lost it's ****.

I switched off everything I could and turned into the first exit. Now the car is in the middle of nowhere and I'm wiring this not knowing what to do. I tried starting it back up, when I turn the key everything comes up as normal, but when I press the engine start button everything switches off like there was no power. I'd assume alternator went out and because of voltage drop everything went crazy, but I'm nowhere near experianced enough to know for sure and this forum was great at helping me so far, so I hope to find out the problem until tomorrow, so I could start looking for parts or a good mechanic. Thank You.

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

 
For the best viewing experience please update your browser to Google Chrome