here we go again turbo or what ? - Civinfo
 
LinkBack Thread Tools
post #1 of 2 (permalink) Old 19th September 2017, 16:54 Thread Starter
 
Join Date: 5th May 2011
Location: uk GB
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader: (0)
here we go again turbo or what ?

hi guys ive had a honda civic 2004 plate 1.7ctdi, i bought it about 7 years ago, in the first year i had it , i thad started going into limp mode when driving, it was eventually diagnosed as a turbo problem, apperently common on these civics, unfortuantely my civic was not covered under the honda turbo extended warranty scheme as its mileage was just over what they said it should be. Anyway i had to buy a new turbo from honda, around 400 i think it was. In 7 years that ive had the car ive only done about 23000 miles, mainly for work and back and shopping locally. Now its 2017, it goes into limp mode under hard acceleration in 3rd gear, i get nothing on the dash, no warning lights are displayed. If i leave the car for about 15 minutes its back to normal, but happens again under hard acceleration in 3rd gear. I ve also noticed that the car sounds load when driving as if its got a blown exhaust and sounds like its got one of those sports big bore exhaust. The exhaust is not leaking and is in good condition, i had this checked by a local car mechanic. Any ideas what it could be. I thought it may need a service so ive had it serviced yesterday, new air filter, oil filter, oil etc...but still sounds the same, like a blown exhaust. I had the engine cleaned with engine flush prior to replacing the oil. The car drives much smoother but the problem remains. I just rang honda dealers, appaerently the new turbo i had fitted only had 12 months warranty, which is a bit silly considering i paid 400 for a new turbo, id thought it might have something like X ampunt of years and X amount of milaegae. Ive only done about 23000 miles since i had it replaced...any ideas guys..
goofy gorilla is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 19th January 2018, 07:12
Supporter
 
Zaheen's Avatar
 
Car: Silver 2.2 EX (Type R Kit)
Join Date: 25th April 2014
Location: West Yorkshire GB
Posts: 339
Thanks: 48
Thanked 35 Times in 31 Posts
iTrader: (5)
Nobody replied here, did you manage to fix the issue?
Zaheen is offline  
Reply

  Civinfo > Other Hondas > Previous Civics

Tags
turbo

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Civinfo forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
Your User Name is the name that appears by all your posts on the forum, and so should not be your email address.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
Exhaust Turbo browseallmighty Engines and Transmission (8G) 3 12th January 2017 01:51
Faults Turbo Help Chaos Engines and Transmission (8G) 9 2nd February 2014 22:05
Old turbo... a5hy General Discussion (8G) 6 5th January 2013 15:48
turbo shae Cleaning 13 15th July 2012 12:31
Turbo it is then TommyLamb Type-R 1 9th October 2010 22:26

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome