Site Screwed 2 - Civinfo
 7Likes
  • 2 Post By shaunwistow
  • 4 Post By guten
  • 1 Post By MrLongbeard
 
LinkBack Thread Tools
post #1 of 13 (permalink) Old 23rd July 2018, 05:23 Thread Starter
Administrator
 
Kremmen's Avatar
 
Car: MY13 1.8 EX Auto
Join Date: 7th January 2007
Location: West London ENGLAND
Posts: 20,944
Thanks: 857
Thanked 1,708 Times in 1,431 Posts
iTrader: (0)
Eco display Eco display
Garage
Site Screwed 2

Whenever I come here (since Friday) this is what I'm greeted with:

Screenshot_20180723-051833_Firefox.jpg

It's not reading my UserCP setting to display the blue skin.

When this does happen pressing the Menu button loads vbulletin but at a 'recent posts' display.

From there I can get back to normal.
Kremmen is offline  
Sponsored Links
Advertisement
 
post #2 of 13 (permalink) Old 24th July 2018, 22:02
Supporter
 
Car: 2012 2.2 I-Dtec
Join Date: 15th June 2015
Location: Worcestershire ENGLAND
Posts: 273
Thanks: 19
Thanked 21 Times in 19 Posts
iTrader: (0)
Good init?
That's what I've been getting for a while now, I just go and find another corner of the internet to play in until I'm on a proper computer
MrLongbeard is offline  
post #3 of 13 (permalink) Old 24th July 2018, 22:20
more torque than the mrs
 
deni.babe's Avatar
 
Car: 2008 2.2 type s gt blusilver
Join Date: 7th February 2010
Location: west midlands GB
Posts: 6,564
Thanks: 1,323
Thanked 1,798 Times in 1,568 Posts
iTrader: (22)
Garage
I'm getting all sorts atm Pete I press the like button it says error lol until I refresh .. IDK...
deni.babe is offline  
 
post #4 of 13 (permalink) Old 24th July 2018, 22:26
Cleaning Moderator
 
shaunwistow's Avatar
 
Car: Astra 2.0 SRi with VXR Pack
Join Date: 5th March 2010
Location: Sheffield, S6 ENGLAND
Posts: 12,648
Thanks: 4,245
Thanked 4,119 Times in 3,375 Posts
iTrader: (64)
Send a message via Skype™ to shaunwistow
It’s ****ed & the owners don’t give a flying ....
guten and nturnb like this.
shaunwistow is offline  
Thanks to shaunwistow from:
post #5 of 13 (permalink) Old 25th July 2018, 06:33 Thread Starter
Administrator
** Thread starter **
 
Kremmen's Avatar
 
Car: MY13 1.8 EX Auto
Join Date: 7th January 2007
Location: West London ENGLAND
Posts: 20,944
Thanks: 857
Thanked 1,708 Times in 1,431 Posts
iTrader: (0)
Eco display Eco display
Garage
That issue was my bookmark that was http

Only after a few complaints till they reveal that the site was converted to https.

It's all very well making these changes but how about telling us

My main issue now, apart from the Wiki, for which they should ne thoroughly ashamed, is the site performance.
I can watch it load bit by bit sometimes.
All my other forums are flying about as normal.
Kremmen is offline  
post #6 of 13 (permalink) Old 25th July 2018, 09:30
Supporter
 
guten's Avatar
 
Car: 07 NHB CTR GT NAV/HFT
Join Date: 23rd February 2011
Location: England ENGLAND
Posts: 701
Thanks: 61
Thanked 107 Times in 106 Posts
iTrader: (2)
Quote:
Originally Posted by shaunwistow View Post
Itís ****ed & the owners donít give a flying ....
I agree with Shaun.... itís getting worse, Not better.
guten is offline  
post #7 of 13 (permalink) Old 25th July 2018, 23:23
drives a shed now
 
Car: 2007 CTS GT i-shift
Join Date: 9th June 2013
Location: UK GB
Posts: 1,429
Thanks: 1,039
Thanked 514 Times in 420 Posts
iTrader: (3)
Didn't really notice they had moved to this protocol to be honest, though I visit and spend far less time here, than I used to. Ah those golden years, RIP Civinfo.

When a site moves to SSL/TLS (https) it's usually a good thing. Given this move, thought I'd take a look at the issued certificate.
It's issued by Let's Encrypt authority, which absolutely is not a bad thing, I use it for my test domains - it's totally free.
See the cert was issued 27th June and expires 25th September, which is normal because Let's Encrypt authority only issue certs valid for 90 days. Therefore it needs to be renewed and updated on the hosting servers before expiring, so we as users don't get the invalid cert browser warning.
Every 90 days can be an admin challenge, but there are automated tools/agent that can do this.
Sure the site owners have, nothing ever goes wrong with these guys in charge

Just like the migration to Google Cloud, they tested and planned before moving production, right - d'oh!

Last edited by onearmbandit; 25th July 2018 at 23:31.
onearmbandit is offline  
post #8 of 13 (permalink) Old 26th July 2018, 00:11
Supporter
 
Haltamer's Avatar
 
Car: 9th Gen 1.4 Petrol SE + Navi
Join Date: 13th March 2017
Location: Essex, UK GB
Posts: 2,019
Thanks: 46
Thanked 293 Times in 263 Posts
iTrader: (3)
Garage
Quote:
Originally Posted by onearmbandit View Post
Every 90 days can be an admin challenge, but there are automated tools/agent that can do this.
Sure the site owners have, nothing ever goes wrong with these guys in charge
I'd noticed this, and was interested to see the following subject alternative names:
Quote:
DNS Name=1000rr.com
DNS Name=1000rr.net
DNS Name=2coolfishing.com
DNS Name=300cforums.com
DNS Name=annuairedesmedecinsduquebec.ca
DNS Name=antiquetractorsforum.com
DNS Name=archerytalkblog.com
DNS Name=astonmartinforum.com
DNS Name=astonmartinlife.com
DNS Name=ausrc.com
DNS Name=basketballforum.com
DNS Name=bcfishingreports.com
DNS Name=benelliforum.com
DNS Name=bmwlt.com
DNS Name=caferacer.net
DNS Name=caliberforumz.com
DNS Name=can-amtalk.com
DNS Name=cbr250.com
DNS Name=cherokeesrt8.com
DNS Name=chicagolandfishing.com
DNS Name=cichlid-forum.com
DNS Name=civinfo.com
DNS Name=club4g.org
DNS Name=clubcivicquebec.com
DNS Name=clubilx.com
DNS Name=clubrsx.com
DNS Name=cmaxownersclub.com
DNS Name=completemustang.com
DNS Name=crownvic.net
DNS Name=crxcommunity.com
DNS Name=cubeforums.com
DNS Name=cumminsforum.com
DNS Name=cx5drivers.com
DNS Name=cx7club.com
DNS Name=dakotaforumz.com
DNS Name=deerhuntingchat.com
DNS Name=diecastaircraftforum.com
DNS Name=diecastxchange.com
DNS Name=dodgedartforumz.com
DNS Name=durangoforumz.com
DNS Name=ehmac.ca
DNS Name=elcaminocentral.com
DNS Name=elementownersclub.com
DNS Name=explorertalk.com
DNS Name=f150forumz.com
DNS Name=forum.clubcivicquebec.com
DNS Name=forums.clubilx.com
DNS Name=forums.clubrsx.com
DNS Name=www.1000rr.com
DNS Name=www.1000rr.net
DNS Name=www.2coolfishing.com
DNS Name=www.300cforums.com
DNS Name=www.annuairedesmedecinsduquebec.ca
DNS Name=www.antiquetractorsforum.com
DNS Name=www.archerytalkblog.com
DNS Name=www.astonmartinforum.com
DNS Name=www.astonmartinlife.com
DNS Name=www.ausrc.com
DNS Name=www.basketballforum.com
DNS Name=www.bcfishingreports.com
DNS Name=www.benelliforum.com
DNS Name=www.bmwlt.com
DNS Name=www.caferacer.net
DNS Name=www.caliberforumz.com
DNS Name=www.can-amtalk.com
DNS Name=www.cbr250.com
DNS Name=www.cherokeesrt8.com
DNS Name=www.chicagolandfishing.com
DNS Name=www.cichlid-forum.com
DNS Name=www.civinfo.com
DNS Name=www.club4g.org
DNS Name=www.clubcivicquebec.com
DNS Name=www.clubilx.com
DNS Name=www.clubrsx.com
DNS Name=www.cmaxownersclub.com
DNS Name=www.completemustang.com
DNS Name=www.crownvic.net
DNS Name=www.crxcommunity.com
DNS Name=www.cubeforums.com
DNS Name=www.cumminsforum.com
DNS Name=www.cx5drivers.com
DNS Name=www.cx7club.com
DNS Name=www.dakotaforumz.com
DNS Name=www.deerhuntingchat.com
DNS Name=www.diecastaircraftforum.com
DNS Name=www.diecastxchange.com
DNS Name=www.dodgedartforumz.com
DNS Name=www.durangoforumz.com
DNS Name=www.ehmac.ca
DNS Name=www.elcaminocentral.com
DNS Name=www.elementownersclub.com
DNS Name=www.explorertalk.com
DNS Name=www.f150forumz.com
So when there is a renewal failure, it's fires all round!
Haltamer is offline  
post #9 of 13 (permalink) Old 26th July 2018, 10:43
Das
i-Vtec
 
Das's Avatar
 
Car: 2009 1.8 ES
Join Date: 3rd March 2018
Location: West Lothian SCOTLAND
Posts: 1,393
Thanks: 81
Thanked 166 Times in 163 Posts
iTrader: (7)
Garage
Quote:
Originally Posted by Kremmen View Post
It's all very well making these changes but how about telling us
To be fair Im sure there was a thread about the upgrade to an https server.
Das is offline  
post #10 of 13 (permalink) Old 26th July 2018, 10:50
Supporter
 
Car: 2012 2.2 I-Dtec
Join Date: 15th June 2015
Location: Worcestershire ENGLAND
Posts: 273
Thanks: 19
Thanked 21 Times in 19 Posts
iTrader: (0)
Ahah, changing the bookmark has fixed the mickey mouse mobile issue on one of my devices but not on another

Never had a problem with speed, maybe you've been given the miserable user hack.........
MrLongbeard is offline  
post #11 of 13 (permalink) Old 26th July 2018, 15:38
drives a shed now
 
Car: 2007 CTS GT i-shift
Join Date: 9th June 2013
Location: UK GB
Posts: 1,429
Thanks: 1,039
Thanked 514 Times in 420 Posts
iTrader: (3)
Quote:
Originally Posted by mrlongbeard View Post
ahah, changing the bookmark has fixed the mickey mouse mobile issue on one of my devices But not on another

Never had a problem with speed, maybe you've been given the miserable user hack.........
I've never needed to set any bookmark to https, so may be your browser? The site implements HSTS with the subdomains directive.
strict-transport-security: max-age=3600; includeSubDomains

I cleared my HSTS cache then hit my http bookmark again, with dev tools open in Chrome.
My browser requests http:// and the response is 301 Moved Permanently, with a new location for my browser to request the page: https://

Screen Shot 2018-07-26 at 14.24.19.png

My browser now sends a get to the https address, the site loads, and I login with my creds.

Screen Shot 2018-07-26 at 14.24.34.png

If I log out and close the tab then open my http bookmark again, my browsers (which support HSTS) will automatically change from http:// to https://civinfo.com before sending the request.
Interesting to note, they have only set max-age to 3600 (1 hour), usually for testing. So, after 1 hour, if I hit my http bookmark again, I get the 301 redirect - a 'wasteful' request!

"We take the security of your data seriously so updates like this do happen from time to time."
https://www.civinfo.com/forum/site-s...ty-update.html

The site's header security, scores a D.
https://securityheaders.com/?q=www.c...owRedirects=on

Last edited by onearmbandit; 26th July 2018 at 15:55.
onearmbandit is offline  
post #12 of 13 (permalink) Old 26th July 2018, 16:02
Supporter
 
Car: 2012 2.2 I-Dtec
Join Date: 15th June 2015
Location: Worcestershire ENGLAND
Posts: 273
Thanks: 19
Thanked 21 Times in 19 Posts
iTrader: (0)
Quote:
Originally Posted by onearmbandit View Post
I've never needed to set any bookmark to https, so may be your browser?
Maybe.
But I'm a stubborn S.O.B, it used to work, they broke it so they can fix it, I've better things to do than work around their screw ups.

We're only here as traffic to generate them revenue, if they want that revenue they shouldn't drive the traffic away.
onearmbandit likes this.
MrLongbeard is offline  
post #13 of 13 (permalink) Old 26th July 2018, 16:53 Thread Starter
Administrator
** Thread starter **
 
Kremmen's Avatar
 
Car: MY13 1.8 EX Auto
Join Date: 7th January 2007
Location: West London ENGLAND
Posts: 20,944
Thanks: 857
Thanked 1,708 Times in 1,431 Posts
iTrader: (0)
Eco display Eco display
Garage
Firefox on the PC did indeed auto change the bookmark to https but the Tablet FF didn't.
Kremmen is offline  
Reply

  Civinfo > Welcome > Site suggestions, feedback and rules

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Civinfo forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
Your User Name is the name that appears by all your posts on the forum, and so should not be your email address.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in













Similar Threads
Thread Thread Starter Forum Replies Last Post
Site screwed up again scaramanga Site suggestions, feedback and rules 377 12th June 2019 17:37
help i've majorly screwed my wing dreamworks General Discussion (8G) 5 8th June 2014 17:30
I'm completely screwed. Jpetrie General Discussion (8G) 9 18th September 2011 09:07
I'm completely screwed. Jpetrie Any non Civic chat here please! 6 25th August 2011 19:46
Brakes Front Discs, think I've been screwed euphonium_john Wheels, Tyres, Suspension and Brakes (8G) 55 22nd April 2009 10:26

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome