Help with lowering springs - Civinfo
 
LinkBack Thread Tools
post #1 of 11 (permalink) Old 18th January 2016, 21:43 Thread Starter
 
slimjamz's Avatar
 
Car: 2010 gt type r
Join Date: 17th November 2013
Location: widnes,uk ENGLAND
Posts: 82
Thanks: 18
Thanked 9 Times in 8 Posts
iTrader: (0)
Help with lowering springs

Has anybody come across an issue with there lowering springs. I recently had eibach 15mil springs fitted to my fn2 with a fast road set up at the same time. I seem to have an issue with a knocking noise when turning left. Initially I thought the noise was coming from the front passenger wheel area. But I'm just not sure. I keep thinking Mabe it's the springs just settling in as I imagine they need abit of time to slightly soften up but the noise is starting to annoy me now. Has anybody else had this issue when lowering? Or something similar


Sent from my iPhone using Tapatalk
slimjamz is offline  
Sponsored Links
Advertisement
 
post #2 of 11 (permalink) Old 18th January 2016, 23:14
Supporter
 
SteveT's Avatar
 
Car: 2009 CTR, Milano
Join Date: 24th September 2015
Location: Suffolk ENGLAND
Posts: 253
Thanks: 68
Thanked 72 Times in 68 Posts
iTrader: (7)
Quote:
Originally Posted by slimjamz View Post
Has anybody come across an issue with there lowering springs. I recently had eibach 15mil springs fitted to my fn2 with a fast road set up at the same time. I seem to have an issue with a knocking noise when turning left. Initially I thought the noise was coming from the front passenger wheel area. But I'm just not sure. I keep thinking Mabe it's the springs just settling in as I imagine they need abit of time to slightly soften up but the noise is starting to annoy me now. Has anybody else had this issue when lowering? Or something similar


Sent from my iPhone using Tapatalk
Did you get the springs fitted at a garage, if so I would give them a call and explain the issue. It may be excess play in the anti rollbar drop link or perhaps a worn strut top mount. I have the same setup on mine and got the drop links replaced when the springs were fitted; there should be no bedding in period per se. Also, check that your OSF wheel nuts have been re-torqued correctly and are not loose.

Sent from my D6503 using Tapatalk
SteveT is offline  
post #3 of 11 (permalink) Old 18th January 2016, 23:18 Thread Starter
** Thread starter **
 
slimjamz's Avatar
 
Car: 2010 gt type r
Join Date: 17th November 2013
Location: widnes,uk ENGLAND
Posts: 82
Thanks: 18
Thanked 9 Times in 8 Posts
iTrader: (0)
Thanks for the reply Steve T. Yes a garage fitted the springs aswell as doing a frsu. I know it's something to do with the springs being fitted as I previously never had this knocking noise. I have spoke to the garage they are more than happy to check it over as soon as I get a day off to get up to them. I was just trying to rule out anything simple and avoid going back to be honest as it's an hours drive away from were I live. Wasn't sure if it's a common thing and disappears. Guess if it persists I'll be going back, the car has only done 33k so I wouldn't have imagined drop links cv joints or anything of that nature would have excessive wear. Thanks for the reply


Sent from my iPhone using Tapatalk
slimjamz is offline  
Thanks to slimjamz from:
 
post #4 of 11 (permalink) Old 18th January 2016, 23:21
Supporter
 
SteveT's Avatar
 
Car: 2009 CTR, Milano
Join Date: 24th September 2015
Location: Suffolk ENGLAND
Posts: 253
Thanks: 68
Thanked 72 Times in 68 Posts
iTrader: (7)
Quote:
Originally Posted by slimjamz View Post
Thanks for the reply Steve T. Yes a garage fitted the springs aswell as doing a frsu. I know it's something to do with the springs being fitted as I previously never had this knocking noise. I have spoke to the garage they are more than happy to check it over as soon as I get a day off to get up to them. I was just trying to rule out anything simple and avoid going back to be honest as it's an hours drive away from were I live. Wasn't sure if it's a common thing and disappears. Guess if it persists I'll be going back, the car has only done 33k so I wouldn't have imagined drop links cv joints or anything of that nature would have excessive wear. Thanks for the reply


Sent from my iPhone using Tapatalk
No worries... Just as an aside my droplinks were worn and needed replacing (they were knocking) and car was on 42k. You need to remove the droplinks when changing the springs so if yours have been 'disturbed' that may have contributed to your issue?

Sent from my D6503 using Tapatalk
SteveT is offline  
Thanks to SteveT from:
post #5 of 11 (permalink) Old 18th January 2016, 23:23 Thread Starter
** Thread starter **
 
slimjamz's Avatar
 
Car: 2010 gt type r
Join Date: 17th November 2013
Location: widnes,uk ENGLAND
Posts: 82
Thanks: 18
Thanked 9 Times in 8 Posts
iTrader: (0)
I never thought about this, I guess it's not going to just disappear, no way to it other than getting it back in I guess.


Sent from my iPhone using Tapatalk
slimjamz is offline  
post #6 of 11 (permalink) Old 18th January 2016, 23:30
Supporter
 
SteveT's Avatar
 
Car: 2009 CTR, Milano
Join Date: 24th September 2015
Location: Suffolk ENGLAND
Posts: 253
Thanks: 68
Thanked 72 Times in 68 Posts
iTrader: (7)
Quote:
Originally Posted by slimjamz View Post
I never thought about this, I guess it's not going to just disappear, no way to it other than getting it back in I guess.


Sent from my iPhone using Tapatalk
Afraid it's unlikely to disappear; you can check the obvious first but I'd be going back to the garage and getting the camber bolts, links, arb bushes, bump stops and top mounts checked... It may be worth bagging a set of Meyle droplinks off eBay (~40) before you go.

Sent from my D6503 using Tapatalk
SteveT is offline  
Thanks to SteveT from:
post #7 of 11 (permalink) Old 19th January 2016, 10:27
Supporter
 
Alanok's Avatar
 
Car: 2008 CTR, Alabaster Silver
Join Date: 30th March 2009
Location: Darlington, UK ENGLAND
Posts: 1,610
Thanks: 134
Thanked 240 Times in 219 Posts
iTrader: (10)
Send a message via MSN to Alanok
I wonder if garage hasn't seated the springs correctly in the top mounts.
Alanok is offline  
post #8 of 11 (permalink) Old 19th January 2016, 15:37 Thread Starter
** Thread starter **
 
slimjamz's Avatar
 
Car: 2010 gt type r
Join Date: 17th November 2013
Location: widnes,uk ENGLAND
Posts: 82
Thanks: 18
Thanked 9 Times in 8 Posts
iTrader: (0)
Mabe mate yea going back in a week tomoro so will see


Sent from my iPhone using Tapatalk
slimjamz is offline  
post #9 of 11 (permalink) Old 30th January 2016, 23:09
Supporter
 
james.llewellyn's Avatar
 
Join Date: 12th February 2014
Location: Wolverhampton ENGLAND
Posts: 258
Thanks: 20
Thanked 17 Times in 15 Posts
iTrader: (2)
Drop links most likely buddy 🏻
james.llewellyn is offline  
post #10 of 11 (permalink) Old 30th January 2016, 23:10 Thread Starter
** Thread starter **
 
slimjamz's Avatar
 
Car: 2010 gt type r
Join Date: 17th November 2013
Location: widnes,uk ENGLAND
Posts: 82
Thanks: 18
Thanked 9 Times in 8 Posts
iTrader: (0)
I sorted it, the garage said the springs had slipped out of position slightly from the top mount, put back in greased up and all good now


Sent from my iPhone using Tapatalk
slimjamz is offline  
post #11 of 11 (permalink) Old 30th January 2016, 23:18
Supporter
 
james.llewellyn's Avatar
 
Join Date: 12th February 2014
Location: Wolverhampton ENGLAND
Posts: 258
Thanks: 20
Thanked 17 Times in 15 Posts
iTrader: (2)
Happy days then mate
james.llewellyn is offline  
Reply

  Civinfo > Civic Type R > Type-R

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Civinfo forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
Your User Name is the name that appears by all your posts on the forum, and so should not be your email address.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
Suspension Eibach Lowering Springs Versus Apex Lowering Springs 2.2 i-CTDI PradaFK3 Wheels, Tyres, Suspension and Brakes (8G) 41 19th February 2014 09:21
Suspension PI lowering springs robm255 Wheels, Tyres, Suspension and Brakes (8G) 7 14th April 2013 13:45
Suspension 30mm ABP Lowering Springs VRS Eibach >25mm springs blackness_rr Wheels, Tyres, Suspension and Brakes (8G) 6 21st May 2012 11:14
Suspension Lowering springs pandastrike3 Wheels, Tyres, Suspension and Brakes (8G) 35 14th May 2010 21:39

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome