Tegiwa airbox problem sealing to maf holder. - Civinfo
 
LinkBack Thread Tools
post #1 of 2 (permalink) Old 25th March 2018, 21:34 Thread Starter
Supporter
 
Leejay-B's Avatar
 
Car: None
Join Date: 2nd April 2013
Location: Surrey, UK ENGLAND
Posts: 1,461
Thanks: 218
Thanked 121 Times in 120 Posts
iTrader: (3)
Garage
Tegiwa airbox problem sealing to maf holder.

I have a Tegiwa airbox. Problem is I can't get the maf holder section, the metal pipe, to seal against the airbox when doing it up. The very slight curve in the box means nearly a mm gap. Maybe half a mm but still enough to not seal properly.
If I do it up even tighter it might crack. Shall I use sticky foam round the maf holder face that meets the airbox to make it airtight?
Are all the boxes like this? It's not major but I shouldn't have to DIY bodge to make it right.

Cheers.
Leejay-B is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 26th March 2018, 11:11
250bhp.... finally :)
 
musegroove's Avatar
 
Car: 08 CTR, Milano Red
Join Date: 2nd September 2014
Location: manchester GB
Posts: 4,272
Thanks: 136
Thanked 430 Times in 410 Posts
iTrader: (8)
Bought it new?

If so send it back as it should fit flush. I remember mine having the tiniest curve on outer edges but the inside was flat, flush and sealed.
musegroove is offline  
Reply

  Civinfo > Civic Type R > Type-R

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Civinfo forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
Your User Name is the name that appears by all your posts on the forum, and so should not be your email address.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
MAF Sensor Problem ? civic2011 Engines and Transmission (9G) 13 16th April 2014 18:58
Induction Strange problem with MAF Sensor! Dawid S Engines and Transmission (8G) 10 9th December 2008 18:19

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome