2006+ Honda Civic Forum banner

1 - 11 of 11 Posts

·
Premium Member
Joined
·
146 Posts
Discussion Starter #1
Hi guys my 2.2 is having a sproadic turbo issue.

2 times on motorway when i ragged the crap out of it i got limp mode both times it was overboost which i reset on the fly.

but it also on random occasions has a problem where it spools but no turbo effect at all . then sometimes it just kick in

80% time it working fine.

not clutch and allegdly lookers put a new boost conrol module 6 month ago

any tips on testing etc will be helpful.

i have used odb and measure egr response which seem to be instant but then again i dont know exactly what to look for
 

·
Premium Member
Joined
·
146 Posts
Discussion Starter #3
mines fine in high speed but can overboost but only after boosting for 10 seconds which is plenty
 

·
#MrGrumpy
Joined
·
13,117 Posts
mines fine in high speed but can overboost but only after boosting for 10 seconds which is plenty
How are you determining that it is overboosting?
 

·
Premium Member
Joined
·
146 Posts
Discussion Starter #9
done 500 miles in 1 day no turbo issues, i know its over boosting as i get 2 codes on obd.
 

·
Bye bye Honda...
Joined
·
5,853 Posts
any way of unsticking the evr or the linkage.
Linkage - WD40 and wiggling it (the grease can set hard). Or indeed the VNT mechanism can become sticky (you may be able to free this by moving the linkage?).

Apply suction to the boost actuator to see that the linkage moves. Check the release filter isn't blocked. It is possible to swap the boost control EVR over with the IMRC EVR and see if the boost problem becomes an IMRC problem instead.
 
1 - 11 of 11 Posts
Top