2006+ Honda Civic Forum banner

1 - 20 of 45 Posts

·
K20 addict
Joined
·
983 Posts
Discussion Starter #1
Ok so in november I had the whole lot done, new pump, condensor, relay and regas.
Was working fine til now (always had climate on) but now I went to get it Ice cold and its not playing ball. Even the revs don't did anymore.

Surely not needing a regas already??
 

·
K20 addict
Joined
·
983 Posts
Discussion Starter #3

·
K20 addict
Joined
·
983 Posts
Discussion Starter #5
The air con is murder! Have you changed your relay?
Yep, relay (genuine), condensor and pump in November! Guessing a leak has sprung and low pressure means its not kicking in.
Hopefully something simple like the seals on the pressure switches. Will get it in to an ac place
 

·
Premium Member
Joined
·
511 Posts
Yep, relay (genuine), condensor and pump in November! Guessing a leak has sprung and low pressure means its not kicking in.
Hopefully something simple like the seals on the pressure switches. Will get it in to an ac place
Wooops I skipped passed the relay part in your original post :worms: I’m going to be doing the same with mine, any idea on the cost of getting it all replaced? It just doesn’t work at all. Zero cold air :(
 

·
K20 addict
Joined
·
983 Posts
Discussion Starter #7
Wooops I skipped passed the relay part in your original post :worms: I’m going to be doing the same with mine, any idea on the cost of getting it all replaced? It just doesn’t work at all. Zero cold air :(
Completely depends whats gone mate. Ive tallied up ive spent close to 400 all in so far including all those parts, 2 regas and labour.
Pump can be the expensive part, risk second hand or get a new one for like 160 quid. I got mine off a lad doing a turbo conversion for 40 quid so I knew it was still working and he just wanted rid.
 

·
Premium Member
Joined
·
511 Posts
Completely depends whats gone mate. Ive tallied up ive spent close to 400 all in so far including all those parts, 2 regas and labour.
Pump can be the expensive part, risk second hand or get a new one for like 160 quid. I got mine off a lad doing a turbo conversion for 40 quid so I knew it was still working and he just wanted rid.
Thanks mate. Sorry for hijacking your thread a bit there!
 

·
K20 addict
Joined
·
983 Posts
Discussion Starter #9

·
K20 addict
Joined
·
983 Posts
Discussion Starter #10
Air con pressure tested and regassed.

Works fine now but clearly a minor leak somewhere so will check for leaks with the dye he's put in now, when it runs out again.

Would've thought it'd be a fairly chunky leak for it to lose its gas since november tho?!
 

·
K20 addict
Joined
·
983 Posts
Discussion Starter #11
This was the job sheet
 

·
K20 addict
Joined
·
983 Posts
Discussion Starter #12
How often do you lot have the AC on? Mine's constantly on 'auto' at 20 deg. Could that be why it's ran out so fast?
 

·
Premium Member
Joined
·
1,212 Posts
How often do you lot have the AC on? Mine's constantly on 'auto' at 20 deg. Could that be why it's ran out so fast?
i keep mine on constantly
about 18 degrees in summer and 22 ish in winter
i re did mine last year but not because of a leak the high pressure sensor was playing up and it was re gassed when i bought the car nearly 5 years ago

by rights it's a sealed unit ( like your fridge ) and shouldn't need re gassing for quite some time
if it does the refrigerant must be leaking out somewhere
 

·
K20 addict
Joined
·
983 Posts
Discussion Starter #14
i keep mine on constantly
about 18 degrees in summer and 22 ish in winter
i re did mine last year but not because of a leak the high pressure sensor was playing up and it was re gassed when i bought the car nearly 5 years ago

by rights it's a sealed unit ( like your fridge ) and shouldn't need re gassing for quite some time
if it does the refrigerant must be leaking out somewhere
Must be. Annoyingly can't trace it.....yet. Hopefully the dye will when it empties again
 

·
Premium Member
Joined
·
386 Posts
Mine was leaking at the compressor
It would last about a month between regases before stopping again

Had mine nitrogen tested and that's where then leak was from
So far it's been a month and it's still going

Dye was added as well and i check it once a week with glasses and a UV light
 

·
K20 addict
Joined
·
983 Posts
Discussion Starter #16
Mine was leaking at the compressor
It would last about a month between regases before stopping again

Had mine nitrogen tested and that's where then leak was from
So far it's been a month and it's still going

Dye was added as well and i check it once a week with glasses and a UV light
New compressor job?
 

·
Premium Member
Joined
·
386 Posts
Yes i had to fit one luckily a mate of mine is a manager at Gsf so i got a denso unit cheap plus £100 for fitting and gas and dye
 

·
Clutch pedal guru
Joined
·
5,107 Posts
To lose most of the refrigerant in 4.5 months isn't a major leak. It's probably a leaky joint or something simple like that.
 

·
K20 addict
Joined
·
983 Posts
Discussion Starter #19
And its dead again! No leaks detected but all pressure lost in less than a month. Getting seriously f**ked off with this car now!!
 
1 - 20 of 45 Posts
Top