2006+ Honda Civic Forum banner

1 - 17 of 17 Posts

·
Registered
Joined
·
115 Posts
I service mine myself, and this clip is very hard to get back on without it pinging off. I did loose this clip myself (fell down the engine bay) but managed to get it back by taking off the service cover underneath. It looks like a 3 cm long black piece of plastic with a circular cutout. I will try and get a photo for you in the morning. I did run it without this clip for a week or 2 without any issues.
 

·
Premium Member
Joined
·
940 Posts
Discussion Starter #4
I assume something is missing, because it just moves back and forward. I don't remember seeing it before, but it could always have been like it.... but it can't be right, because the clip doesn't do anything. I'm going to assume the dealer will resolve, but want to make sure I know what to tell them
 

·
Premium Member
Joined
·
940 Posts
Discussion Starter #6
Well, that's a stupid design.... wonder how much that tiny piece of plastic would cost, or if the dealer will resolve. Lets see....
 

·
Ex-Pat Geordie!
Joined
·
2,267 Posts
I lost mine last year, no issues so far.. One of the most stupid designs I've seen. Cover seems to be clamped down quite snugly by the other 3 clips.
 

·
Registered
Joined
·
5 Posts
I hope you don't mind me jumping onto your air filter thread...


I just had a basic service done, but they told me it didn't include the air filter etc. So I bought one off the net, and just went out to change it. The existing one looked sparkling clean, exactly like the new one in the box. This is odd isn't it? I would have expected the existing one to look dirty - it hasn't been changed for 3 years as far as I know, about 15k miles.


Not sure if I should bother changing it now!
 

·
Ex-Pat Geordie!
Joined
·
2,267 Posts
You mustn't be doing many miles then as mine looked like this after two year and Honda said it was perfectly fine hence the reason I service my own.
 

Attachments

·
Registered
Joined
·
5 Posts
You mustn't be doing many miles then as mine looked like this after two year and Honda said it was perfectly fine hence the reason I service my own.
Sorry, I'm not quite sure what that says in regards to my comment...

My question is, is it normal for an air filter to look completely new after 3 years of use? My experience from older cars is no, they look very dirty - but maybe this Honda just works differently and doesn't require replacing.
 

·
Ex-Pat Geordie!
Joined
·
2,267 Posts
Sorry, I'm not quite sure what that says in regards to my comment...

My question is, is it normal for an air filter to look completely new after 3 years of use? My experience from older cars is no, they look very dirty - but maybe this Honda just works differently and doesn't require replacing.
The picture I posted was after 2 years and 27K miles. You said yours looked almost new after 3 years, I suggested you must have a low mileage car as my filter was absolutely filthy.. I change my oil now twice a year and the filter every second service and it is always very dirty.
 

·
Registered
Joined
·
180 Posts
The picture I posted was after 2 years and 27K miles. You said yours looked almost new after 3 years, I suggested you must have a low mileage car as my filter was absolutely filthy.. I change my oil now twice a year and the filter every second service and it is always very dirty.

Yours is really dirty. Mine would be nothing like yours after a year. Its very black?
 
1 - 17 of 17 Posts
Top