2006+ Honda Civic Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1
First post, so hello all!

So I have a 2010 Type S 2.2CDTI and the Aircon is playing up. Just from skimming over the some of the problems here it seems AC is somewhat of a common problem on these cars.

I started to notice in the warmer weather that the AC is struggling in the higher temperatures. Weird thing is that for the 5 - 10 mins it blows out very cold, and then gradually as the car warms up, the AC starts to blow warmer and warmer.
I got it regassed this morning, and initially it seemed to do the trick as it was blowing out ice cold as I pulled away from the garage. However after taking a little drive through the country lanes this afternoon in the 22-24C heat, it started to blow out warm again.

I've checked the fuses and it seems I still have the old Omron relay, so I guess thats first on the list to replace. If I recall, you used to be able to hear the click of the solenoid when you turned the AC on and off, however I can't hear it anymore, so it could possibly be the relay?

Any ideas?

Thanks
 

·
Registered
Joined
·
6 Posts
Discussion Starter #2
Just checked the compressor clutch, and its not engaging at all. So its either a sticky relay or a the clutch is knackered?
 

·
Registered
Joined
·
6 Posts
Discussion Starter #4
So I got a new relay and fitted it. Checked the compressor and it was now spinning. Didn't take long till cold air was blowing inside. Problem solved I thought, however driving a bit later and it was blowing warm again. I checked to see if the compressor is still spinning and it wasn't anymore. I tried bridging the two connections on the fitting for the relay to simulate the relay activating, but now the clutch isn't engaging at all regardless.
 
1 - 5 of 5 Posts
Top