2006+ Honda Civic Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
16 Posts
Discussion Starter #1
Hi guys,

Just wondered if anyone has some suggestions for the problem I've got with the car.

Last week the central locking button stopped working on the drivers side windows control panel.

Then a couple of days ago the all the window buttons stopped working as well. :(

They don't work on the individual doors either. I have checked the 20amp fuse for the windows and door lock icon one and both are fine. I then checked the power windows 40amp square fuse under the bonnet fuse box and that is fine too.

Im thinking maybe going to a scrapper and getting the button panel and replacing that to see if it solves the problem.

Apart from taking it to an expensive electrocution, any further suggestions are welcome.

Cheers in advance.

P.s) i did a search for similar issues and most seem to be solved by doing the windows reset thing but im unable to do that for obvious reasons.
 

·
Premium Member
Joined
·
823 Posts
I'd personally pull the door card off and check the connections to the window switch unit, try it with the door open too
 

·
Registered
Joined
·
16 Posts
Discussion Starter #3
Cheers bench, i was contemplating doing that... Bit cold these days but will check it our probably next weekend now as im busy tomorrow.

Any door panel removal instructions about?
 

·
Premium Member
Joined
·
823 Posts
Lower the window first ( if poss) 2 Phillips screws behind a small plastic panel on the door handle and another one under the door handle pull/arm rest

Then pull the panel from the bottom and work round, I start from behind the speaker, they will be on tight so you may need to use a little force, usually easier if it's warm, the clips tend to break in the cold but easily source-able off ebay £3 ish for 10
 

·
Registered
Joined
·
16 Posts
Discussion Starter #5
Nice one fella, i might just do it after a journey to warm up the plastic a little. ��
 

·
Registered
Joined
·
16 Posts
Discussion Starter #6
Right... Never got chance to try this and had the car in the garage to check it out. They reckon its the switches panel too.

Honda quoted £500 for a new one and apparently it has to be programmed in to work so even if i get another used one i will still have to get the software sorted.

Think if the weather is good this weekend i will attempt it.
 
1 - 6 of 6 Posts
Top