2006+ Honda Civic Forum banner
1 - 20 of 23 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter · #1 ·
Hi,
I was driving back home on the motorway tonight, with the cruise control on, and all of a sudden, engine warning light comes on and I seem to have lost the turbo?!.

Car wouldn't go past about 60mph, cruise control wouldn't work, so I just gingerly nursed the car home. I'm not expecting anyone to diagnose the problem exactly, just wondering if anyone has suffered similar.

Car is a 2006 2.2 ctdi, 39000 on the clock.

Hopefully just something like a hose blown, or a connector etc...:(
 

·
Premium Member
Joined
·
693 Posts
Does it stil do it after restarting it do these have a egr like ford etc as my mondeo done this it was the egr to intercooler pipe had split maf sensor ?
 
  • Like
Reactions: nobeerinthefridge

·
Premium Member
Joined
·
1,036 Posts
Had any recent work done on it?
 
  • Like
Reactions: nobeerinthefridge

·
Premium Member
Joined
·
424 Posts
The maf is a sensor iqn the air box. If it goes wrong the engine does not know how much air its getting. If you unplug it the ecu uses a default. It also uses defaults for other sensors so if your car runs better with it disconected it doesnt mean its deffinately the maf but as you also have an engine light hopefully that will point you in the right direction
 

·
Registered
Joined
·
10 Posts
Discussion Starter · #14 ·
I did that diagnostic check of Pottsys, and it only came up with one fault -

PA51
DTC 1241

Engine not running at all this morning. Starts, goes to idle, then dies. I think Green flag'll be towing me to the local garage today.
 
1 - 20 of 23 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top