2006+ Honda Civic Forum banner

1 - 7 of 7 Posts

·
Premium Member
Joined
·
114 Posts
Discussion Starter #1 (Edited)
Hi Guys,

I've got a conceptual problem. I've ordered a Pioneer AppRadio 3 head unit and the Connects2 cable set with fascia and the patch cable. They haven't arrived yet, but I'm already breaking my head on how to connect these things.
Please excuse the ignorance, this is the first radio I'll be installing (I have previously installed an mp3 adapter, and an internal bluetooth module, I'm also decent with a soldering iron so not really affraid, just a bit confused)

For the AppRadio - I expect to get with it the powercable which most likely will be a plug on one end with stripped cables on the other end for power, ground, speakers etc., am I right here?

Then there is the Connects set, which will connect with the existing plugs on the Civic side, but how do I connect the stripped power/speaker cables with the rest of this hairball? :confused:

Do I need another adapter in between, perhaps an extra socket that I don't know about? Or am I supposed to cut off one of the existing stereo plugs, then strip and splice the cables?

I've looked through the double din topics but I'm affraid I'm no wiser. :police:

Cheers
 

·
Premium Member
Joined
·
114 Posts
Discussion Starter #2
So I think I found an answer to my own question and as usual I was overthinking it.
The radio arrives with a standardized connector on the other end of the power cable, and the whole story is plug and play... with the minor exception of the hand brake.
 

·
#MrGrumpy
Joined
·
13,117 Posts
The whole system is basically plug and play.

The radio will have standardised connectors on one end, that connect to the Connects2 loom. The OEM connectors then plug into the other end of the Connects2 loom.

There are a few other bits like aerial, handbrake etc. but they are fairly straightforward.
Head over to the Pioneer website; they have the installation manuals of their head units so you can see what you'll need to do :)
 

·
Premium Member
Joined
·
114 Posts
Discussion Starter #4
Thanks Syx, I got it all now, it really is easier than I thought, I have no idea why I haven't done this earlier.
My Connects2 set just arrived, looks great, if my radio shows up tomorrow then I'll have some fun over the weekend :)
 

·
Premium Member
Joined
·
114 Posts
Discussion Starter #5
So I've attempted my double din installation today and unfortunately failed miserably.
What I got is a Connects2 set with all the correct cables and adapters, fascia, and my double din AppRadio from Pioneer.
Everything fits very well together, unfortunately when I've reconnected the battery in the car after wiring everything, my AC display never woke up... steering controls are dead as well.

I've tried connecting/disconnecting the black box (connects 2 adapter) and it doesn't help. Seems I got a dud...

To sum it up, the only thing soldered on was my green wire for the handbrake, on the Connects2 the blue and pink wires were isolated and taped up, don't see how I would need them, and every other connection was plug and play. I only have the antenna adapter left to solder on to a 12v line, but that's the last thing on my list.
On a positive note - my radio works beautifully, good reception even without the powered antenna, excellent GPS reception, I'm really happy... with the exception of the Connects2 adapter... just my luck.

Is there anything I can try before I send it back for a replacement?
 

·
Premium Member
Joined
·
295 Posts
It's probably a dud box, but you could check the wires going from the loom into the black box with a multimeter. At least one of them presumably will have 12v. At least that would give you an indication it's the box and not the loom.
 

·
Premium Member
Joined
·
114 Posts
Discussion Starter #7
Yup it was broken, got a replacement and fitted it yesterday... what a mindblowing improvement over that crappy oem panasonic :)
 
1 - 7 of 7 Posts
Top