2006+ Honda Civic Forum banner

1 - 17 of 17 Posts

·
Premium Member
Joined
·
135 Posts
Discussion Starter #1
Thinking of getting a pioneer SPH-DA100 appradio 2 now that they've come down in price a bit. Can anyone give me a definitive answer as to what other bits I'll need to use it with my galaxy S3, and any reviews would also be much appreciated.
 

·
Premium Member
Joined
·
135 Posts
Discussion Starter #3
Looking at the way the wiring is done and reading a bit online, I'm going to try and just use the mhl adapter and run my own phone power from the lighter through a usb circuit, will be about £10, rather than the expensive pioneer kit. If it works.
 

·
Premium Member
Joined
·
1,780 Posts
Sorry to thread jack, but I have a question which is based on this.

I have the appradio 3 and a sony xperia z.

Currently I am connecting with just the usb, but want to fully utilise the radios functions.

The wiring kit from pioneer is crazy expensive considering the radio came with most of the cables that are in the kit!

All I'd need is the power box and mhl adapter if I have the usb and hdmi cables already connected correct?

If so would this adapter be sufficient?
Micro USB to HDMI MHL Cable adapter Black | eBay

And what would I need for power?
 

·
Premium Member
Joined
·
135 Posts
Discussion Starter #5 (Edited)

·
Premium Member
Joined
·
135 Posts
Discussion Starter #7
I was thinking of running power under centre console to behind cubby hole, then modifying a dock with the adapter usb permanently in, fixing it to inside of cubby so phone can be slid into it and and then forgotten about.
 

·
Premium Member
Joined
·
1,780 Posts
Will have to look into that.
Just looking at the wiring diagram here:

Find apps for your car - AppRadio Mode from Pioneer - Pioneer UK
(Selecting android, then da110)

I'll need the top connection method and doesn't mention anything about additional power :s. All i am missing from that diagram is the mhl adapter

Edit:

Looking at some of the mhl adapters that have 5v power written on the side of them with a connection.
 

·
Premium Member
Joined
·
135 Posts
Discussion Starter #10
OK, got this installed today, and its all working fine in principle, just need help with a couple of points if anyone has any info.

Radio reception is very poor, from reading around, I think I have to connect the blue wire on aerial adapter to a 12v source? can anyone recommend somewhere that doesn't involve a load of cable running.

I'm having to set unit up from scratch every time it is turned on, am assuming that I need a permanent live from somewhere, again, any ideas greatly appreciated.

Also, I'm putting in a reversing camera this weekend, would I need to, and if so how do I connect it so it comes on when reverse gear is selected? or is this included in the connects2 wiring loom?
 

·
Premium Member
Joined
·
135 Posts
Discussion Starter #12
After a lot of head scratching and swearing, finally got this sorted, the connects 2 cables had the 12v ignition and 12v permanent around the wrong way. Switched them over and all works fine. Ran the aerial 12v into the ignition 12v and can now pick up most radio stations. Have run the reversing camera and just need to get it connected up to the lights later.

One question left, when I connect up camera to lights, the cable has a live and neutral for power, and a reverse gear signal spur on each end (lights and head unit). I've connected the spur at the head end into the pink reverse gear signal cable on connects2 loom, do I need to also connect the spur at the lights end to the lights + or will it pick up the reverse gear from the one on head unit, as I was expecting a blank screen when I reversed this morning, but nothing changed on head unit
 

·
#MrGrumpy
Joined
·
13,117 Posts
Check that the Connects2 connection isn't an input to the HU rather than an output - as I suspect it is.
Most HUs that have reversing camera support have a separate input for reverse so that they know to switch to the camera.
 

·
Premium Member
Joined
·
135 Posts
Discussion Starter #14
Check that the Connects2 connection isn't an input to the HU rather than an output - as I suspect it is.
Most HUs that have reversing camera support have a separate input for reverse so that they know to switch to the camera.
Thanks mate, if its an input, would connecting the rear signal spur to the 12v of the reversing light be useable as a signal to the HU? I couldnt see anything else on the HU that looked like an input.
 

·
#MrGrumpy
Joined
·
13,117 Posts

·
Premium Member
Joined
·
135 Posts
Discussion Starter #17
Got this all working now, thanks for your help Syx. Connected camera 12v and reverse signal spur to reverse light wire and all seems to be fine. Camera comes on when reverse is selected, although it also seems to come on at random other times too. There is a setting on the HU for camera polarity, with battery and ground as options. Both seem to work the same, would it make any difference which is chosen?

Apart from that, I think its a tidy little unit, have tested it with an iphone and an android and both give excellent results. The iphone seems to be robust, connection wise, but thats probably down to the connector size. Next step is to DIY a dock for the car so that I can just slide the phone in and have it connect.

I think all in, for fascia, head unit, camera and cables / adapters its come in at £330, which I think is a bargain.
 
1 - 17 of 17 Posts
Top