2006+ Honda Civic Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1 (Edited)
Alright,

This is my first post so please be gentle

I have been drawn to the forum due to an issue (and one of many to be honest) I am having with my 2007 5-door Civic 2.2 CDTI EX S&L (thought I'd put the long name ).

When tootling down to Alton Towers the other week, CD player going, there was a hell of a bang which sounded like when you put speaker wires together and the radio shut off. Luckily I was on the M62 and hence stationary, so popped ignition off then on and it all came back to life, albeit the dash was VERY hot.

Anyways, all was well until the LCD screen (which shows clock, climate etc) started to flicker with a 'feedback' type noise over the speakers and eventually went off all together, only flicking on now and again.

Over the next few days, the radio started to jump stations, jump functions and the CD player was very temperamental.

Finally, the stereo has lost all controllability; it is constantly 'on' playing white noise of flickering volume levels, so annoying and deafening that I have had to pull the fuse as I cannot turn it off.

Has anyone ever had such issues? Funnily enough the Sat Nav screen has remained functional (until I pulled the fuse) but the audio menu will not show up, voice rec don't function and Bluetooth is dead.

Any help would be brilliant and much appreciated, even if it is only advise on dismantling the dash.

Regards,

Diehard
 

·
Registered
Joined
·
151 Posts
When I drive my VW Polo at work, every so often, (maybe once a month) I get a very loud bang out of the speakers, and it all switches off, frightens the life out of me, then after a few seconds, I switch it back on again, and then I see "learning" on the display, for about a minute, it looks like it is loading all the stations and settings info back into it's memory, it's a horrible noise, but only seems to do this if I play a lot of MP3 CD's etc not sure if it is overheating or long use that causes it, if I just listen to the radio, everything is fine, good luck with your Civic DH
 

·
Registered
Joined
·
4 Posts
Discussion Starter #3
When I drive my VW Polo at work, every so often, (maybe once a month) I get a very loud bang out of the speakers, and it all switches off, frightens the life out of me, then after a few seconds, I switch it back on again, and then I see "learning" on the display, for about a minute, it looks like it is loading all the station and settings info back into it's memory, it's a horrible noise, but only seems to do this if I play a lot of MP3 CD's etc not sure if it is overheating or long use that causes it, if I just listen to the radio, everything is fine, good luck with your Civic DH
Funnily enough it was an MP3 CD I was listening too when it went pop... Really hope it's not melted something inside.
 

·
Premium Member
Joined
·
336 Posts
Alright,

This is my first post so please be gentle

I have been drawn to the forum due to an issue (and one of many to be honest) I am having with my 2007 5-door Civic 2.2 CDTI EX S&L (thought I'd put the long name ).

When tootling down to Alton Towers the other week, CD player going, there was a hell of a bang which sounded like when you put speaker wires together and the radio shut off. Luckily I was on the M62 and hence stationary, so popped ignition off then on and it all came back to life, albeit the dash was VERY hot.

Anyways, all was well until the LCD screen (which shows clock, climate etc) started to flicker with a 'feedback' type noise over the speakers and eventually went off all together, only flicking on now and again.

Over the next few days, the radio started to jump stations, jump functions and the CD player was very temperamental.

Finally, the stereo has lost all controllability; it is constantly 'on' playing white noise of flickering volume levels, so annoying and deafening that I have had to pull the fuse as I cannot turn it off.

Has anyone ever had such issues? Funnily enough the Sat Nav screen has remained functional (until I pulled the fuse) but the audio menu will not show up, voice rec don't function and Bluetooth is dead.

Any help would be brilliant and much appreciated, even if it is only advise on dismantling the dash.

Regards,

Diehard
I'd recommend you take it to a Honda Dealer or Auto Electrician and get it checked. Definitely should not be doing that!
 

·
Registered
Joined
·
4 Posts
Discussion Starter #5
Well pulled the radio out today, disconnects all connections and check every male and female socket for scorching, broken wires etc but all good. Couldn't get behind DVD screen/clock screen tho, however I am thinking the actual single DIN master unit is knckered.

Does anyone known if the CD unit is the same on all similar age hondas with the SAt Nav, Bluetooth, Voice Control etc being just Add on units if spec requires them?
 

·
R.I.P - (User sadly passed away)
Joined
·
9,228 Posts
Well pulled the radio out today, disconnects all connections and check every male and female socket for scorching, broken wires etc but all good. Couldn't get behind DVD screen/clock screen tho, however I am thinking the actual single DIN master unit is knckered. Does anyone known if the CD unit is the same on all similar age hondas with the SAt Nav, Bluetooth, Voice Control etc being just Add on units if spec requires them?
First, get a good auto-electrician to check it out …

Second, if the unit is dead - all Civics pre-2009 are exactly the same - try a vehicle dismantler ? …
 

·
Registered
Joined
·
1 Posts
i have the similar problem.but i realised that when this hapening i switch on climate at the lowest degree , its come back and works normally. i thinks its about overheating problem , i will go to dealer next saturday what will say ? :confused:
 

·
Mugenised CR-Z GT
Joined
·
502 Posts
If you have the radio out take the top cover off and look for any blown capacitors or scorching on the circuit board
 
1 - 8 of 8 Posts
Top