2006+ Honda Civic Forum banner

1 - 2 of 2 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
Hi,
I have a civic 2006 sedan 4 doors with 1.8 engine.
Since the day i purchased the car (used) over 4 years ago, i feel a wobble of the car causing vibration to the whole car. I think its starting from the front and it happens on a speed of 25-30km/h at a constant speed, doesn't happen during acceleration or when removing my foot completely from the gas peddle to slow down. I tried many things but none did work for me:
1. Changed the engine 2 years ago( damaged due to water leak) but i thing they used the same fuel injectors
2. Changed tires
3. replaced lcoation of tires
5. changed CV joints
6. I did a steering wheel aligment
7. changed brake pads
8. changed two engine mounts
9. scanned my car using an autel scanner and it only gave an issue with o2 sensors, so i repalced the sensors with used ones and after few days later the check engine turned on and the o2 sensors gave same problem. so i suspect the catalitic converter is the problem or maybe the used sensors are also damaged.

does any one have an idea on how to fix the problem?
 

·
Registered
Joined
·
38 Posts
Had the tyres re-balanced? You could have lost a wheel weight
Wheel bearing?
Steering rack bushes?
Lower Control Arm bushes?
Wheel nut stud/nut lose or cross threaded or even partially sheared or elongated from misuse or impact tools?

Get under the car with a pry bar and start looking for movement in bushes to give you an idea where the problem might be
 
1 - 2 of 2 Posts
Top