2006+ Honda Civic Forum banner

21 - 24 of 24 Posts

·
Registered
Joined
·
254 Posts
Have you checked the rest of the fuses, including the one youve just changed?
The fuse I changed was new and got the dash and reverse lights back on but with the warning lights I mentioned but there's a lot of warnings and in the central area it says vsa and then airbag symbol then engine symbol
I guess I will wait till in the morning and check all the other fuses
Thanks Das

Sent from my HS_10DTB12A using Tapatalk
 

·
Registered
Joined
·
254 Posts
The fuse I changed was new and got the dash and reverse lights back on but with the warning lights I mentioned but there's a lot of warnings and in the central area it says vsa and then airbag symbol then engine symbol
I guess I will wait till in the morning and check all the other fuses
Thanks Das

Sent from my HS_10DTB12A using Tapatalk
So I got up this morning and checked all fuses and non were blown so I reconnected the battery and the dash had all the warnings again so disconnected the battery again and decided I would put the dash under tray back on and ring around a few garages but as I was about to click it into place I was staring at a black rubber kind of grommet or bubble with wires going into it and for want of a better explanation the boy told not to press the switch haha I pressed it and it clicked oh dam I thought what have I wrecked now but put the cover on and connected battery the lights had all disappeared!!!
The rubber switch must be an accident or electrical system reset switch and I can only assume somehow I set it off by banging on the dash under tray too hard to press it into place. I have no idea but lots of sweat tears and swearing later I am now so happy to be back chugging down the road.
All from a reverse light bulb blowing a fuse

Sent from my HS_10DTB12A using Tapatalk
 
21 - 24 of 24 Posts
Top