2006+ Honda Civic Forum banner

1 - 20 of 70 Posts

·
R.I.P - (User sadly passed away)
Joined
·
9,228 Posts
Discussion Starter #1
Recently, the CD player has been refusing to function at times - it loads and reads, but nothing happens ...

I've tried a lens cleaner, but no improvement at all - looks like the unit is 'shot' ...

Is the CD player a separate module, or do I need a whole new HU ? ...
 

·
R.I.P - (User sadly passed away)
Joined
·
9,228 Posts
Discussion Starter #3
It's a solid unit i believe. May find some pics on a double din install thread? Aux in and forget about CDs?
Aux-in bought, but still not completely installed (Dension 300) ...

However, I'd rather keep the original functionality as well, thinking about eventual resale \ trade-in ...
 

·
Cockup Specialist
Joined
·
12,885 Posts
Recently, the CD player has been refusing to function at times - it loads and reads, but nothing happens ...

I've tried a lens cleaner, but no improvement at all - looks like the unit is 'shot' ...

Is the CD player a separate module, or do I need a whole new HU ? ...
Are you using rewritable MP3 CDs ?
They do age and cause all sorts of problems.
Try a proper CD if you haven't.
:thumbsup:
 

·
Premium Member
Joined
·
215 Posts
Not to worry you, but I had this a couple of months back and it turned out to be the head unit that was goosed!

Honda asked for . . . prepare your self . . . £1000 to replace it with a new one or £600 for a second hand one!!
But I bought one for £125 from a local scrappy (seen one on ebay for the same price) and had the Honda garage fit it for about £85 I think.

If you are a DIY guy you could probably save yourself £85 but I couldn't get the top plastic cover off and scratched the plastic above it so I just caved in and got them to do it.

But like Relic said, try a proper CD in first and maybe even a newly burned one?
 

·
Premium Member
Joined
·
10,524 Posts
theres a few guys on here running double din's. Maybe PM them and ask if they would be willing to sell

Via a proper for sale advert i add

:)
 

·
R.I.P - (User sadly passed away)
Joined
·
9,228 Posts
Discussion Starter #8
Are you using rewritable MP3 CDs ? They do age and cause all sorts of problems. Try a proper CD if you haven't. :thumbsup:
I've only been using original CDs - problem is that the player will work fine for several days, then sulk for a while, then cooperate again ...

Not to worry you, but I had this a couple of months back and it turned out to be the head unit that was goosed! Honda asked for ... prepare your self ... £1000 to replace it with a new one or £600 for a second hand one!! But I bought one for £125 from a local scrappy (seen one on ebay for the same price) and had the Honda garage fit it for about £85 I think. If you are a DIY guy you could probably save yourself £85 but I couldn't get the top plastic cover off and scratched the plastic above it so I just caved in and got them to do it. But like Relic said, try a proper CD in first and maybe even a newly burned one?
£1000 (in the UK) ! - that'll be twice that here !!! ...

There's a few guys on here running Double DINs. Maybe PM them and ask if they would be willing to sell. Via a proper for sale advert I add. :)
That's not a bad idea at all ...

I believe Alpine charge about £140 to repair the unit.
And neither is that ...
 

·
R.I.P - (User sadly passed away)
Joined
·
9,228 Posts
Discussion Starter #10
I can give you my CD module as I have dismantlled the unit. It should be a 1-hour job to change it. Interested? Andrej P.S.:It is from the satnav unit.
Absolutely YES !!! - take this to PMs ? …
 

·
R.I.P - (User sadly passed away)
Joined
·
9,228 Posts
Discussion Starter #12

·
R.I.P - (User sadly passed away)
Joined
·
9,228 Posts
Discussion Starter #14

·
R.I.P - (User sadly passed away)
Joined
·
9,228 Posts
Discussion Starter #15
Thanks for that - looking forward to my "replacement" ! ...
Unit received today - looks like new - thank you so very much ! ...

Please let me have your PayPal address (via PM), and I'll send money in return ...
 

·
R.I.P - (User sadly passed away)
Joined
·
9,228 Posts
Discussion Starter #16
Update ...

Replacement installed last week - didn't use it that much, but worked fine ...

But, yesterday the same fault came back - I get as far as 'DISC READ' on the screen, which persists for far too long, then I get an error message and nothing happens ! ...

So, it's not the CD player itself, that is faulty ...

Grrrrrrr - any tips \ ideas, peeps ? ...
 

·
R.I.P - (User sadly passed away)
Joined
·
9,228 Posts
Discussion Starter #17
Replacement installed last week - didn't use it that much, but worked fine ... But, yesterday the same fault came back - I get as far as 'DISC READ' on the screen, which persists for far too long, then I get an error message and nothing happens ! ... So, it's not the CD player itself, that is faulty ... Grrrrrrr - any tips \ ideas, peeps ? ...
I'm fed up now - what could be the problem ? - I've got my Dension 300 'aux-in' installed, and it runs just fine - but, I hate knowing that the CD-player won't work ...

Help me, people ! - could it be that the "HU" is buggered, or is it possibly something simple ? ..
 

·
OOOOSH
Joined
·
800 Posts
Mine has recently stopped working, radio and iPod link works fine, but when I put a cd in, it makes a mechanical clicking noise for a minute, and then states 'disc error'.
I've tried mp3 disc and proper purchased disc, it makes no difference, also cleaned the lens with one those cleaning disc things, again to no avail.
Booked in to the dealer a week on Tuesday, we'll see what they have to say.
 

·
R.I.P - (User sadly passed away)
Joined
·
9,228 Posts
Discussion Starter #19
Mine has recently stopped working, radio and iPod link works fine, but when I put a cd in, it makes a mechanical clicking noise for a minute, and then states 'disc error'. I've tried mp3 disc and proper purchased disc, it makes no difference, also cleaned the lens with one those cleaning disc things, again to no avail. Booked in to the dealer a week on Tuesday, we'll see what they have to say.
Pretty much what I experienced - and I've changed out the CD-player, thinking that was the problem - but no, exactly the same issue ...
 

·
Registered
Joined
·
111 Posts
Mine has recently stopped working, radio and iPod link works fine, but when I put a cd in, it makes a mechanical clicking noise for a minute, and then states 'disc error'.
I've tried mp3 disc and proper purchased disc, it makes no difference, also cleaned the lens with one those cleaning disc things, again to no avail.
Booked in to the dealer a week on Tuesday, we'll see what they have to say.
In exactly the same situation now.

56 plate, non sat nav model.

What was the outcome for you ?
 
1 - 20 of 70 Posts
Top