2006+ Honda Civic Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
Picked up my new Civic iCTDI Sport a few days ago. Its done about 180 miles now most of which was the 150 back home from the dealer. When I started it today I noticed the oil pressure warning did not go out imeadiately, only after two or three seconds on idle. Is this normal behaviour for the iCDTI engine?
 

·
Premium Member
Joined
·
12,492 Posts
Mine goes out just before the battery light goes out. It shouldn't stay on for very long at all - but then if nothing comes up in the main display (in the centre of the rev counter) then I guess the car thinks nothing's wrong...

PS It's not the oil level indicator is it (the level is the oil can but with a wavey line underneath)?
 

·
Registered
Joined
·
4 Posts
Discussion Starter #3
No it's not the oil level icon with the wavey line. When I noticed it I switched off and checked the level at the dipstick, which was fine. I have seen the oil pressure appear in the main display also but it couldn't have been displayed for more than 1/10th second at startup. Anyway now I know how another car behaves I can go to the dealer and say I think something's wrong with some confidence. Thanks.
 

·
Premium Member
Joined
·
3,004 Posts
This has happened in my CTDI loaner before. Lit for about 3/4 seconds longer than normal. I'm assuming that this is normal on occasion. Nothing in the manual about it, nor is there any other warning on the main display.

The engine completely failed to start once, and I had to wait and retry!
 
1 - 4 of 4 Posts
Top