2006+ Honda Civic Forum banner
1 - 20 of 32 Posts

·
Registered
Joined
·
15 Posts
Discussion Starter · #1 ·
Hey guys! I recently bought new double din head unit and all the accessories to it. The new HU is a JVC KW-M745DBT. I also bought a new "frame" and cable. The cable i baught was a Connects2 CTSHO002. Once I had connected everything together and test fitted etc. There where two cables from the car who had nothing to connect to (the cables marked in the picture below). Also the little screen that shows the AC setting and such only blinks "00.00.2008". The frequency it blinks in vary. And on top of that the fingertipcontrols on the steering wheel doesn't work. Anyone here who has an idea of what the problem might be?

314363
 

·
Premium Member
Joined
·
66 Posts
Vaguely remember the same issues when I installed one years ago. They ended up inviting me to their office as it was pretty close by and swapped it out for a new one.
So I guess it was faulty
 

·
Registered
Joined
·
15 Posts
Discussion Starter · #3 ·
Vaguely remember the same issues when I installed one years ago. They ended up inviting me to their office as it was pretty close by and swapped it out for a new one.
So I guess it was faulty
So the cable is most likely the problem?
 

·
Registered
Joined
·
280 Posts
The bottom plug with the black cables is the Ariel lead.
But the other plug from the wiring loom should plug into the connect2 box, Or so mine did when I connected it to my car.
 

·
Registered
Joined
·
280 Posts
Straight off the Connects2 website...


CTSHO002 Connects 2 Stalk Adapter for Honda
The adaptor consists of two parts, these must both be purchased based on your vehicle model and choice of radio brand:

  • Part 1: Vehicle Interface (Shown Here)
  • Part 2: Radio Interface (in Related Items)
Simply ensure this interface is the correct model for your vehicle and then select the relevant brand radio interface lead from the recommended items box below.
 

·
Registered
Joined
·
527 Posts
The white connector is for the clock and isn't required, the patch lead is used to adjust the clock from the steering wheel (press and hold the mode button until it starts to blink, then use the other 2 buttons to adjust and move to the next digit)
To get the steering wheel to work with the stereo requires you to set the buttons for it. There are 3 loops on the patch lead that may need cutting depending on what HU you are using (should have the instructions on a sheet of paper)
 

·
Registered
Joined
·
527 Posts
You need all 3 bits, the main Connects2 adapter (only the grey plugs are for the original wiring, the others are for the HU harness and patch lead) the aerial adapter (plugs onto the original aerial wire and into the back of the HU, and the blue wire connects to the antenna power wire on the HU harness) and the patch lead (this plugs into the Connects2 adapter and connects to the HU harness)
 

·
Registered
Joined
·
15 Posts
Discussion Starter · #14 ·
You need all 3 bits, the main Connects2 adapter (only the grey plugs are for the original wiring, the others are for the HU harness and patch lead) the aerial adapter (plugs onto the original aerial wire and into the back of the HU, and the blue wire connects to the antenna power wire on the HU harness) and the patch lead (this plugs into the Connects2 adapter and connects to the HU harness)
Do I really need the aerial adapter in order for the steeringwheel controlls and the "ac and clock" screen to work?
 

·
Registered
Joined
·
527 Posts
You need the aerial adapter to change it to the correct connector for the HU and to power the aerial, as the one on the car needs power to work
 

·
Registered
Joined
·
527 Posts
Have you tried pressing and holding the Mode button down on the steering wheel to see if the clock starts flashing for adjustment.
 

·
Registered
Joined
·
15 Posts
Discussion Starter · #19 · (Edited)
Have you tried pressing and holding the Mode button down on the steering wheel to see if the clock starts flashing for adjustment.
Yes, I've tried it. But the problem is that the clock isn't there at all and not the ac settings either. The only thing that is on the screen is the date "00.00.2008". That's all that's on the screen, and it's flashing.
314412
 

·
Premium Member
Joined
·
205 Posts
Do you have to set the date and time using the double din? I don't have one but i think i recall someone on here had a flashing date/time until they set it using the headunit.
 
1 - 20 of 32 Posts
Top