2006+ Honda Civic Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter #1
Hi, hoping for some good advice here

Recently had a front shock change on both front sides. Within a week or two I began to get like a very quiet rattle on the front off side at low speed over uneven bits of road and also creaking over speed bumps. Only occurs on one side and never had the issue before the shock change.

Typically I brought it back tat the garage but none of them could find it and even after I went out it had vanished and then came back approx two weeks later! I was told the the top strut mounts looked ok. Don't really wana change the strut mounts as from other threads it might not solve the problem. I did have the subframe bolts regreased the other month at Honda tuning tdi North. Could it be that the strut bolts have become a little loose? Or the rubber housing around the coil springs?? Not convinced it's the bump stops due t the previous threads on that not solving a similar issue. Anyone have any ideas??
 

·
Registered
Joined
·
32 Posts
The creaking sounds like the spring might not being seated properly. I had the same issue before I fitted some Eibach springs. With the rattle sound I would check the drop link and make sure that's done up tight.

Like you say it's worth checking the subframe bolts as that's another thing that was causing a creaking noise on mine when I first got it lol!
 

·
Registered
Joined
·
8 Posts
Discussion Starter #3
Thanks for the reply. Yeah I've had the sub frame bolts greased and tightened last month.

I've brought it back to the mechanic today as the noise was a little more noticeable and took it out for a run. Mechanics of the opinion that it is the drop links. Just bizarre how they went after a week or two of having the shocks replaced!!

Think I'm guna run with getting the drop links done. If it doesn't solve it I give up!!

Any idea on decent quality oe drop links??
 

·
Registered
Joined
·
58 Posts
Could the shocks be faulty? I've had faulty shocks fitted before by a mechanic and was in the same predicament as you, except the noise I had was there straight after having them fit, rather than 2 weeks.
 

·
Registered
Joined
·
8 Posts
Discussion Starter #7
Just had the drop links changed..and £70 quid later the noise is still there. Not happy. I've been told the spring load on the strut was fine. The ball joints looked good. It's definitely something to do with the spring compression and something has a little play in it causing the clonking or squeak. Again it's only on the front offside. No idea what to do now apart from hitting the car with a massive mallet!!😡 Not wantImg to waste another penny on it.
 
1 - 7 of 7 Posts
Top