2006+ Honda Civic Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
23 Posts
Discussion Starter #1
I'm loving my "new" Civic (2010 1.8 SE) but the FM radio is the worst I've ever experienced in my 30+ years of driving.

The CD player is great, I love the MP3 functionailty and the FM radio is great - UNTIL I turn the rear demister or blower on. The interference is ridiculous! As soon as I turn the demister/fan off then the reception is fine again. RDS works as it should, but the whole thing is useless if any fans are running or the demister is in use. Of course this means it's impossible to have the AC and the radio on at the same time.

I've removed the rear hatch trim to check the antenna wiring and earth - everything is fine - although there is an unused lug in there which seems to be for some function my car doesn't have. I notice that Honda don't use stock coax for the radio, but wire to a signal booster/filter using a bespoke connector.

I've looked at all the Wiki's, searched many threads (and there are so many!) but I couldn't find a definitive solution.

Has this issue been buried now, or have people given up trying? Or was there a solution found that I've missed in my two days of searching?

It's a shame that such a great driving experience (I've come from an '04 Meriva) is spoiled by something as ludicrous as the lack of an FM radio. :(
 

·
Registered
Joined
·
23 Posts
Discussion Starter #5
I'm guessing there is a dodgy connection somewhere, because since writing the original post, my reception is absolutely fine no matter what fans/demister I have turned on, and I haven't done a thing to it!

I'm just waiting for it to go on the blink again, but for now it's working as it should. Crazy!
 
  • Like
Reactions: Bones126

·
Registered
Joined
·
11 Posts
Same on mine sometimes reception is ok other times abysmal, is the aerial earth behind the tailgate centre trim where the lock is?
Thanks
 
1 - 6 of 6 Posts
Top