2006+ Honda Civic Forum banner

1 - 5 of 5 Posts

·
Premium Member
Joined
·
183 Posts
Discussion Starter #1
Firstly Merry Christmas to anyone that can be bothered reading this today:santadance::santa1:

Secondly I need a bit of help......lol

Half way through fitting my nice new Pioneer AppRadio 3 Double Din and came across a problem with fitting the 103mm cage.

I have the full kit that I ordered from Impulse so it's the genuine fascia, the problem I'm having is that the 103mm cage that was supplied doesn't locate flush back into the fascia and sits proud as shown in the pic below

Am I just being a tool or have I been sent the wrong cage or need mount it some other way ?

 

·
Registered
Joined
·
45 Posts
That doesn't look like the cage I was sent with my kit, It shouldn't have those metal pieces at right angles (unless you bent those out?)
 

·
Premium Member
Joined
·
183 Posts
Discussion Starter #3
thanks for confirming Kev and no not altered the cage in any way from how it was sent to me

the lugs at the top and bottom are stopping it being pushed back flush, they are pretty solid as well so can't be bent easily

definitely the wrong cage as it's impossible to mount this in the fascia so will be sent back to impulse
 

·
Premium Member
Joined
·
183 Posts
Discussion Starter #4
just for the record this was all sorted within 30min of Bob from Impulse being back in the office after the holidays and the correct cage was sent out

great customer service as always from them :)
 

·
#MrGrumpy
Joined
·
13,117 Posts
+1 for that - great service from them whenever I've needed it!
 
1 - 5 of 5 Posts
Top