2006+ Honda Civic Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1
Hello everybody.
not sure if this post should be made here.
but i dare to ask you all ig any of yoy face this issue before.
i drive an accord 2.2 icdti facelift model 2008. sometimes when i push the peddal more around 4000 rpm. it suddently cut the fuel. car goes in limp mode.
Also around 2000 rpm when in 5 gear it smokes like hell.
also when it goes in limp mode, system check appears on the dashboard.
when I scan it came up with P1237.
it says on the web "fuel pump secondary circuit malfuntion". any ideea how to solve this issue?
thanks

Sent from my GT-I8190 using Tapatalk 2
 

·
Bye bye Honda...
Joined
·
5,856 Posts
A reliable site I often use for DTCs says that P1237 = "boost pressure lower than expected" and that these things should be considered...
  • Turbo body stuck (Open side stuck)
  • Turbo Charger Boost Control Solenoid negative pressure hose off
  • Turbo Charger Boost Control Solenoid open side stuck
  • Air cleaner taint, damage (Blockage)
  • Turbo compressor : tube off in Intake Manifold
OBD II Fault Codes p1237

I'd assume it was something simple to begin with, so I'd check out the intercooler/turbo/inlet pipework first. Then maybe the boost control solenoid/actuator?

I'd also add the MAP sensor to the above list. Does your scanner enable you to see boost pressure (MAP) in real time?
 

·
Registered
Joined
·
6 Posts
Discussion Starter #3
Dear John, thanks for your fast reply.
I forgot to mention, after i clean the error code, everything goes back to normal, except the smoking at around 2000.
how to describe this better..
cruising at 100km/hr at 2000rpm in 5 gear. if i push the peddal suddently then it smokes worse than a tractor.
Yes i can read the map value with the scan tool. but now i'm not home. will reach in a few days.
any ideea what value should be? limits?
everything started after i changed the fuel filter. I did'nt put OEM, could this be just a coincidence?
thanks once agin
Valentin

Sent from my GT-I8190 using Tapatalk 2
 

·
Bye bye Honda...
Joined
·
5,856 Posts
Fitting a non-oem fuel filter is pretty much the wrong thing to do! I guess there are some very good filter manufacturers who make perfectly good filters, but unfortunately there are some who make filters of a much worse standard than the i-CTDi engine demands... you really need to have a Denso filter on your FL Accord. Is there any possiblity you might have knocked a boost pipe or linkage while replacing the fuel filter? I'd check!

I'm not sure the wrong fuel filter would cause the symptoms and DTC you have mentioned (usually a filter with excess restriction causes a P1065 and/or P0087 DTCs). The dark smoke does suggest insufficient boost, as already mentioned. Only last week my neighbour had the exact same issues with his 2003 Audi A6 1.9 TDi and we found a pipe had fallen off the intercooler (so a 10 minute fix). Hopefully your problem is just as simple.

Welcome to Civinfo. I also have an Accord and this probably is the right place for you to post this query, but (as you probably know) the 8th gen Civic has the same engine (well, a few minor differences) and many Civic diesel owners are very, very knowledgeable and helpful. I expect some of them will contribute to helping advise you on this problem.

EDIT - just found this thread on an Accord site that I am also a member of... http://typeaccord.co.uk/forum/topic/9288-genuine-fuel-filter-p1237-dtc/page__p__103380__hl__p1237__fromsearch__1#entry103380 and, like your problem, this came on after a fuel filter change. It was eventually found to be the turbo boost control EVR actuator, but you can swap this over with another one on your engine to help identify the problem before buying a replacement.
 

·
Registered
Joined
·
6 Posts
Discussion Starter #5
Hello
I have already swapped the 2 solenoids between, so far it seems the mpg increased, but in the same time smoking is still there. i didn't had time to push-it harder to see if the EML comes again. however, first thing to do will install OME FF, once I get back home.
Cheers
 

·
Registered
Joined
·
6 Posts
Discussion Starter #6
Hello everybody. just discovered that the intercooler body has a 3in long crack. will search for a second hand one. to replace. will keep you updated with the outcome.
thanks

Sent from my GT-I8190 using Tapatalk
 

·
Registered
Joined
·
6 Posts
Discussion Starter #7
job done. installed another IC. no more headache.
thanks for help.



Sent from my GT-I8190 using Tapatalk
 
1 - 8 of 8 Posts
Top