2006+ Honda Civic Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
31 Posts
Discussion Starter #1
Hi all

I stupidly decided on a Kwik Fit full service today. Now the engine management warning light (orange) is on, with a P401 (or is it P0401) code which I think is the EGR. The car is now in limp mode, and they asked me to bring the car back tomorrow.

They disconnected the battery apparently, after replacing a filter. I know my EGR is not bust, there was no problem with the car before I took it to Kwik Fit.

Has anyone experienced this before? I dont think the EGR or exhaust is tinkered with during a full service? I think perhaps it was the battery being disconnected that has caused this perhaps?

Any advice greatly appreciated as always.

cheers
 

·
Premium Member
Joined
·
1,177 Posts
If DTC P0401 is indicated, check for poor connections or loose terminals at the EGR valve and the ECM
 

·
Registered
Joined
·
31 Posts
Discussion Starter #4
thanks for your replies

its a 2007 type s GT (2.2 diesel).

i noticed a grey small vacuum pipe was disconnected on the right side of the engine. I plugged it back on and the engine sounds better, but the engine management light is still on.

Where is the EGR valve? would the pipe disconnected cause the limp mode? I can rev above 2k now with the car in neutral, not tried driving it yet
 

·
Registered
Joined
·
31 Posts
Discussion Starter #5
warning light is now out. since i plugged the vaccuum pipe back on, after 20 minutes it has now gone. phew, was bracing myself for a moment back there!
 

·
Registered
Joined
·
35 Posts
From my understanding, the engine management light will stay illuminated until any errors have been cleared - pulling the negative battery terminal for a couple of minutes usually seems to do the trick, provided you have actually fixed the cause of the error.
 

·
The Talented Mr. Robbieee
Joined
·
3,295 Posts
They let those chimps in kwik fit do services?? Whatever next? lol
 
1 - 7 of 7 Posts
Top