2006+ Honda Civic Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
20 Posts
Discussion Starter #1
Hi all,

Got a bit of a problem. I have paid someone to fit a new clutch for me over the weekend on my Civic 2.2 cdti as my original clutch was suffering with the known slipping problem and I didn't fancy paying Honda close to a grand for a new clutch.

The lad I have paid is a friend of a friend and has been a mechanic for Honda before and currently works for Toyota and is clued up with cars.. The clutch feels good but something has triggered the Engine Management Light to come on whilst replacing the clutch and my car has swicthed into limp mode.

Obviously he had to disconnect the battery before starting the work today but is unsure as to why the engine management light has come on. Does anyone have any ideas as to what could have been disturbed to cause the engine management light to come on?

He has access to a diagnostic machine which he his going to link up to the car tomorrow night but any additional help would be appreciated as I am going to have to take time off work tomorrow in case it has went into limp mode for something serious.

Thanks in advance.
 

·
Registered
Joined
·
20 Posts
Discussion Starter #3 (Edited)
Cheers, I shall give that a go when Mark comes round tomorrow or Tuesday. I'll ask him about fitting a clutch for you, no worries. I'll get back to you with his response.

P.s, your car is looking smart. I just seem to keep on spedning money fixing mine rather than doing the mods I really want to do to it. Which tuning box are you using if you dont mind me asking?

Thanks
 
1 - 4 of 4 Posts
Top