2006+ Honda Civic Forum banner

1 - 13 of 13 Posts

·
Registered
Joined
·
26 Posts
Discussion Starter #1
Most likely due to the absolutely baltic conditions, but after a week of sitting unused and frozen, my CTR external temp display is now knackered. Its reading anywhere between 10 and 28 degrees at the moment - which is clearly ridiculous.

Its strange but its actually a touch unnerving when you are driving in what looks like freezing temperatures, yet the car isnt warning you.

Anyway, plan is to take it to the dealers but just wondered if there is a quick fix - could it be as daft a leaf sitting on the sensor?
 

·
Premium Member
Joined
·
420 Posts
i had a reading of 16 degrees when driving in what was clearly ice with heavy downfalls of snow. realised when i got out of the car that I had a massive block of snow formed on the grill and bumper of the car which was blocking the sensor from reading a true temp and it was probably reading off the radiator in the engin bay as no air was coming in from the front.

Just a thought it might not be broke. I knocked all the snow of mine and it was fine after. Only realised when I got to my destination that so much snow had built up driving through blizzards.
 

·
Administrator
Joined
·
21,163 Posts
i had a reading of 16 degrees when driving in what was clearly ice with heavy downfalls of snow. realised when i got out of the car that I had a massive block of snow formed on the grill and bumper of the car which was blocking the sensor from reading a true temp and it was probably reading off the radiator in the engin bay as no air was coming in from the front.

Just a thought it might not be broke. I knocked all the snow of mine and it was fine after. Only realised when I got to my destination that so much snow had built up driving through blizzards.
Another one solved :)
 

·
Premium Member
Joined
·
1,036 Posts
Mine was reading 7 the other day in freezeing conditions, nothing blocking the grill either. All seems fine now, think it's one of them 'characteristics' of the car.
 

·
Aye Aye....
Joined
·
7,101 Posts
I've had this before, i think mines was sitting at something crazy like 50 odd but it just as mysteriously fixed itself and i've not had any problems since
 

·
Registered
Joined
·
70 Posts
I had 55C all the way home in my CTR until suddenly it started to drop at about 1 deg/sec and stabilise at 32C. I assume the misreading is due to the fact my bonnet and grill were both blocked with snow (about 4" of the stuff) and the reading was being influenced by the hot engine. I'll keep an eye on it though...
 
1 - 13 of 13 Posts
Top