2006+ Honda Civic Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
64 Posts
Discussion Starter #1
As title

Took my throttle body off cause of hunting / surging idle when coasting after cleaning TB, tried the idle relearn 4 times, fixed nothing.

Was gonna clean the iacv but cant see one attached to the throttle body like on the ep3's

Cant find info on google, so does the fn2 actually have an IACV?? If so were is it located..

Also has anyone cleaned inside their TPS sensor before?

Ive just sprayed some maf sensor cleaner in there cause could see a bit of crud in there that may have got in why i was cleaning the throttle body the other day... i cleaned the TB while still on car and sprayed carb cleaner in there multiple times.

And later found out that you shouldnt do that..

Thx
 

·
Premium Member
Joined
·
2,235 Posts
K20Z4's are DBW meaning its electronically actuated. the K20's in the EP3 are cable driven so require a IACV

It sounds like you've killed the electronics inside the unit... I'd strip it down and get it in the sun to try to dry it off.
 

·
Registered
Joined
·
64 Posts
Discussion Starter #3
K20Z4's are DBW meaning its electronically actuated. the K20's in the EP3 are cable driven so require a IACV

It sounds like you've killed the electronics inside the unit... I'd strip it down and get it in the sun to try to dry it off.
Thx

Thats what ive done today, tb is off and clean and dry.. I notice that the butterfly inside the TB is slightly open when in the 'closed position' is that normal? Think i read somewhere that it is..

The tps sensor, the hole is small but i defo seen a tiny blob of black colour gunk in there,
seen the dirt colour run out when gently spaying maf sensor cleaner in there,

im thinking it may have got inside there when i was spraying carb cleaner like a mad man inside the TB from all angles the other day while cleaning it

looks perfectly clean in there now,


Lastly, when i took the throttle body off i lost fair bit of coolant from the small coolant hose thats attached to the TB, i dont have proper 'mixed coolant' is it safe to just top up a bit using just water if its needed?
 

·
Registered
Joined
·
64 Posts
Discussion Starter #4
Anyone know how crucial it is to hold the revs dead on 3000rpm when doing the idle relearn process?

I cant do it, the throttle is too sensitive,

everytime ive tried it i can hold it around 3000rpm for a while then my foot moves or shakes once, then revs either go slightly above 3000rpm or quite often hey drop to 2500 or even 2300rpm then i have bring em back up..


Could this be whats causing my bad surging idle problem? My car keeps revving upto 2500rpm and back down when im driving and i start coasting to a stop or put clutch in or just roll in neutral etc..

And when i change gear it jumps up way high and hangs for a second
 

·
Registered
Joined
·
137 Posts
Did you sort this out? Have you looked for vacuum leaks? Also make sure you coolant is bled properly.
 
1 - 5 of 5 Posts
Top